mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/kdiff3 to 1.9.0-1
This commit is contained in:
parent
8192983c69
commit
3826800506
2 changed files with 13 additions and 13 deletions
|
@ -1,4 +1,4 @@
|
|||
From ffb46846f6124ba7e28ba0a27c5457b5891dbdf9 Mon Sep 17 00:00:00 2001
|
||||
From 325099960900c49b06e7e0da736f0d86a3f96092 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 21 Aug 2018 06:51:04 -0600
|
||||
Subject: [PATCH] link atomic
|
||||
|
@ -8,10 +8,10 @@ Subject: [PATCH] link atomic
|
|||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||
index 463e7a9..b7a641a 100644
|
||||
index 3190160..eaac426 100644
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -35,7 +35,7 @@ add_library(kdiff3part MODULE ${kdiff3part_PART_SRCS})
|
||||
@@ -46,7 +46,7 @@ add_library(kdiff3part MODULE ${kdiff3part_PART_SRCS})
|
||||
|
||||
set_target_properties(kdiff3part PROPERTIES DEFINE_SYMBOL KDIFF3_PART)
|
||||
target_compile_features(kdiff3part PRIVATE ${needed_features})
|
||||
|
@ -20,15 +20,15 @@ index 463e7a9..b7a641a 100644
|
|||
target_compile_definitions(kdiff3part PRIVATE -DTRANSLATION_DOMAIN=\"kdiff3\")
|
||||
|
||||
install(TARGETS kdiff3part DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf5/parts )
|
||||
@@ -51,7 +51,7 @@ set(kdiff3_SRCS
|
||||
|
||||
@@ -67,7 +67,7 @@ endif()
|
||||
include(icons/CMakeLists.txt)
|
||||
add_executable(kdiff3 ${kdiff3_SRCS})
|
||||
|
||||
-target_link_libraries(kdiff3 KF5::ConfigCore KF5::ConfigGui KF5::Parts KF5::Crash ${KDiff3_LIBRARIES} )
|
||||
+target_link_libraries(kdiff3 KF5::ConfigCore KF5::ConfigGui KF5::Parts KF5::Crash ${KDiff3_LIBRARIES} atomic)
|
||||
target_compile_features(kdiff3 PRIVATE ${needed_features})
|
||||
|
||||
install(TARGETS kdiff3 ${INSTALL_TARGETS_DEFAULT_ARGS})
|
||||
# See https://cmake.org/cmake/help/v3.15/prop_tgt/MACOSX_BUNDLE_INFO_PLIST.html
|
||||
--
|
||||
2.21.0
|
||||
2.30.1
|
||||
|
||||
|
|
|
@ -5,19 +5,19 @@
|
|||
# - patch to explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=kdiff3
|
||||
pkgver=1.8.5
|
||||
pkgver=1.9.0
|
||||
pkgrel=1
|
||||
pkgdesc="A file comparator/merge tool"
|
||||
pkgdesc='A file comparator/merge tool'
|
||||
arch=(x86_64)
|
||||
url="https://kde.org/applications/development/kdiff3/"
|
||||
url='https://kde.org/applications/development/kdiff3/'
|
||||
license=(GPL)
|
||||
depends=(kparts hicolor-icon-theme)
|
||||
makedepends=(extra-cmake-modules kdoctools)
|
||||
makedepends=(extra-cmake-modules kdoctools boost)
|
||||
source=(https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
0001-link-atomic.patch)
|
||||
sha256sums=('bc92f7d04eb123f9c56dbe3047af67bf715240fa99487ac1d1ccf2a45e0854c1'
|
||||
sha256sums=('a7fd61a23f1e37f25af0efa82265d4723e63889aa3213a58b76ce0c96eab23d0'
|
||||
'SKIP'
|
||||
'414fd602932d4572eb564da71c8adde822dfcc96727693c266195580a04d9809')
|
||||
'47ce388156ae3d70efb6915c94db3502b0bbdfa439aaf4a6b75f7ab6702e338c')
|
||||
validpgpkeys=(EE56D710885D36FB1E4D21F3F442B36D614B06BC) # Michael Reeves <reeves.87@gmail.com>
|
||||
|
||||
prepare() {
|
||||
|
|
Loading…
Reference in a new issue