mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
linux-zedboard: kernel-CVE-2016-0728.patch
This commit is contained in:
parent
3305d1a3bf
commit
39664ce617
2 changed files with 87 additions and 1 deletions
|
@ -9,7 +9,7 @@ _srcname=linux-xlnx-${_commit}
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="ZedBoard"
|
_desc="ZedBoard"
|
||||||
pkgver=3.19.0
|
pkgver=3.19.0
|
||||||
pkgrel=2
|
pkgrel=3
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="https://github.com/Xilinx/linux-xlnx"
|
url="https://github.com/Xilinx/linux-xlnx"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
|
@ -17,9 +17,11 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage' 'git'
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("https://github.com/Xilinx/linux-xlnx/archive/${_commit}.tar.gz"
|
source=("https://github.com/Xilinx/linux-xlnx/archive/${_commit}.tar.gz"
|
||||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
||||||
|
'kernel-CVE-2016-0728.patch'
|
||||||
'config')
|
'config')
|
||||||
md5sums=('a8c513775d714e5d6e7b0ed255920bf4'
|
md5sums=('a8c513775d714e5d6e7b0ed255920bf4'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
|
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||||
'8da8be2690c101b39394b31b4a89355b')
|
'8da8be2690c101b39394b31b4a89355b')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -27,6 +29,9 @@ prepare() {
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
# CVE-2016-0728
|
||||||
|
patch -Np1 -i ../kernel-CVE-2016-0728.patch
|
||||||
|
|
||||||
# AUFS patches
|
# AUFS patches
|
||||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||||
cp -ru "${srcdir}/aufs3-standalone/fs" .
|
cp -ru "${srcdir}/aufs3-standalone/fs" .
|
||||||
|
|
81
core/linux-zedboard/kernel-CVE-2016-0728.patch
Normal file
81
core/linux-zedboard/kernel-CVE-2016-0728.patch
Normal file
|
@ -0,0 +1,81 @@
|
||||||
|
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yevgeny Pats <yevgeny@perception-point.io>
|
||||||
|
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
||||||
|
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
|
||||||
|
|
||||||
|
This fixes CVE-2016-0728.
|
||||||
|
|
||||||
|
If a thread is asked to join as a session keyring the keyring that's already
|
||||||
|
set as its session, we leak a keyring reference.
|
||||||
|
|
||||||
|
This can be tested with the following program:
|
||||||
|
|
||||||
|
#include <stddef.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <keyutils.h>
|
||||||
|
|
||||||
|
int main(int argc, const char *argv[])
|
||||||
|
{
|
||||||
|
int i = 0;
|
||||||
|
key_serial_t serial;
|
||||||
|
|
||||||
|
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||||
|
"leaked-keyring");
|
||||||
|
if (serial < 0) {
|
||||||
|
perror("keyctl");
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (keyctl(KEYCTL_SETPERM, serial,
|
||||||
|
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
||||||
|
perror("keyctl");
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
for (i = 0; i < 100; i++) {
|
||||||
|
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||||
|
"leaked-keyring");
|
||||||
|
if (serial < 0) {
|
||||||
|
perror("keyctl");
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
If, after the program has run, there something like the following line in
|
||||||
|
/proc/keys:
|
||||||
|
|
||||||
|
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
||||||
|
|
||||||
|
with a usage count of 100 * the number of times the program has been run,
|
||||||
|
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
||||||
|
has been garbage collected, then the problem is fixed.
|
||||||
|
|
||||||
|
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
||||||
|
Signed-off-by: David Howells <dhowells@redhat.com>
|
||||||
|
Acked-by: Don Zickus <dzickus@redhat.com>
|
||||||
|
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||||
|
Acked-by: Jarod Wilson <jarod@redhat.com>
|
||||||
|
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
||||||
|
---
|
||||||
|
security/keys/process_keys.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
||||||
|
index a3f85d2..e6d50172 100644
|
||||||
|
--- a/security/keys/process_keys.c
|
||||||
|
+++ b/security/keys/process_keys.c
|
||||||
|
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
|
||||||
|
ret = PTR_ERR(keyring);
|
||||||
|
goto error2;
|
||||||
|
} else if (keyring == new->session_keyring) {
|
||||||
|
+ key_put(keyring);
|
||||||
|
ret = 0;
|
||||||
|
goto error2;
|
||||||
|
}
|
||||||
|
--
|
||||||
|
cgit v0.12
|
||||||
|
|
Loading…
Reference in a new issue