mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/mariadb to 10.5.7-1
This commit is contained in:
parent
11cf00826e
commit
3b70ff562e
2 changed files with 3 additions and 42 deletions
|
@ -1,34 +0,0 @@
|
|||
commit 1bb3ad6dfc885112d05d8d73b066f18a416ca965
|
||||
Author: Geert Hendrickx <geert@hendrickx.be>
|
||||
Date: Thu Aug 27 17:30:03 2020 +0200
|
||||
|
||||
MDEV-23589: Portability: use `uname -n` instead of `hostname`
|
||||
|
||||
Closes PR #1663
|
||||
|
||||
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
|
||||
index 33e32ea22f7..eafb051ad60 100644
|
||||
--- a/scripts/CMakeLists.txt
|
||||
+++ b/scripts/CMakeLists.txt
|
||||
@@ -162,7 +162,7 @@ ELSE()
|
||||
SET(CHECK_PID "kill -s SIGCONT $PID > /dev/null 2> /dev/null")
|
||||
ENDIF()
|
||||
|
||||
-SET(HOSTNAME "hostname")
|
||||
+SET(HOSTNAME "uname -n")
|
||||
SET(MYSQLD_USER "mysql")
|
||||
ENDIF(UNIX)
|
||||
|
||||
diff --git a/support-files/CMakeLists.txt b/support-files/CMakeLists.txt
|
||||
index 80b6ca386df..2a17cf6d0d8 100644
|
||||
--- a/support-files/CMakeLists.txt
|
||||
+++ b/support-files/CMakeLists.txt
|
||||
@@ -30,7 +30,7 @@ ELSE()
|
||||
SET(CXXFLAGS ${CMAKE_CXX_FLAGS})
|
||||
SET(MYSQLD_USER "mysql")
|
||||
SET(ini_file_extension "cnf")
|
||||
- SET(HOSTNAME "hostname")
|
||||
+ SET(HOSTNAME "uname -n")
|
||||
ENDIF()
|
||||
|
||||
# XXX: shouldn't we just have variables for all this stuff and centralise
|
|
@ -8,8 +8,8 @@
|
|||
pkgbase=mariadb
|
||||
pkgname=('mariadb-libs' 'mariadb-clients' 'mariadb' 'mytop')
|
||||
pkgdesc='Fast SQL database server, derived from MySQL'
|
||||
pkgver=10.5.6
|
||||
pkgrel=3
|
||||
pkgver=10.5.7
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
url='https://mariadb.org/'
|
||||
|
@ -23,12 +23,10 @@ validpgpkeys=('199369E5404BD5FC7D2FE43BCBCB082A1BB943DB') # MariaDB Package Sign
|
|||
# https://mariadb.com/kb/en/library/mirror-sites-for-mariadb/
|
||||
source=("https://rsync.osuosl.org/pub/mariadb/mariadb-${pkgver}/source/mariadb-${pkgver}.tar.gz"{,.asc}
|
||||
'0001-arch-specific.patch'
|
||||
'0002-use-uname-n.patch'
|
||||
'0001-libatomic.patch')
|
||||
sha256sums=('ff05dd69e9f6992caf1053242db704f04eda6f9accbcc98b74edfaf6013c45c4'
|
||||
sha256sums=('c06748da7f707b62990b1a7086ed80e68eed396dd3682253130bddbbfacc9039'
|
||||
'SKIP'
|
||||
'3289efb3452d199aec872115f35da3f1d6fd4ce774615076690e9bc8afae1460'
|
||||
'0605142beb6ee2e72957696f2e5b10d3084c6423bc17207fb73cd71306cae8d9'
|
||||
'59947e8154dceae50a38053ed4f659f23e5c95eb2a2fc06f60d57be5814ae1c3')
|
||||
|
||||
prepare() {
|
||||
|
@ -40,9 +38,6 @@ prepare() {
|
|||
# * make systemd-tmpfiles create MYSQL_DATADIR
|
||||
patch -Np1 < ../0001-arch-specific.patch
|
||||
|
||||
# MDEV-23589: Portability: use `uname -n` instead of `hostname`
|
||||
patch -Np1 < ../0002-use-uname-n.patch
|
||||
|
||||
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
|
||||
patch -p1 -i ../0001-libatomic.patch
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue