community/percona-server to 5.7.14_7-1

This commit is contained in:
Kevin Mihelich 2016-08-25 18:01:02 +00:00
parent c84726ee0f
commit 3b9709692d
2 changed files with 5 additions and 34 deletions
community/percona-server

View file

@ -8,7 +8,7 @@
pkgbase=percona-server
pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
pkgver=5.7.13_6
pkgver=5.7.14_7
_boost_ver=1.59.0
_pkgver=${pkgver/_/-}
_myver=${pkgver/_rel*}
@ -20,7 +20,6 @@ license=('GPL' 'AGPL')
url="http://www.percona.com/software/percona-server/"
source=("http://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona-Server-$_pkgver/source/tarball/percona-server-$_pkgver.tar.gz"
"http://sourceforge.net/projects/boost/files/boost/${_boost_ver}/boost_${_boost_ver//./_}.tar.gz"
'make_pair.patch'
'my.cnf'
'mysql-user.conf')
@ -28,8 +27,6 @@ prepare() {
cd $pkgbase-$_pkgver
rm -v sql/sql_yacc.{cc,h}
patch -p1 -i "$srcdir"/make_pair.patch
sed 's|${fullhostname}|"archbuild"|' \
-i storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
}
@ -174,8 +171,7 @@ package_percona-server() {
rm usr/share/man/man1/mysql-test-run.pl.1
}
sha256sums=('ce6867394d43c6814300ebe26310544bb504e0f558c8a3b8278ea6aa838fd645'
sha256sums=('b204ffac56bfc8cf092acca3ce73d63b00450b59f554acd1daeb5a573eec2c1d'
'47f11c8844e579d02691a607fbd32540104a9ac7a2534a8ddaef50daf502baac'
'1db0f48f06545307898bfed9305e5b4c2997ee97375cd8d0b2a36ee93370d00f'
'ae451839c368f0db25a63bb0a6a890194897a8e74818bd4245140933c29e5f83'
'e638a2657085f15b6728f43c1fd6aa551b27608fbf6b435e33afd3606a0cfb0e')

View file

@ -1,25 +0,0 @@
From 34ec0d65ede8392ba3e0f114d72672b3f517f964 Mon Sep 17 00:00:00 2001
From: Christian Hesse <mail@eworm.de>
Date: Tue, 10 May 2016 01:09:34 +0200
Subject: [PATCH] do not pass type to std::make_pair()
We not pass type template arguments to std::make_pair()
explicitly, and let the compiler deduce them on its own.
This fixes compiler error on GCC 6.1.1.
---
client/auth_utils.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/client/auth_utils.cc b/client/auth_utils.cc
index 21416bb..03fd71c 100644
--- a/client/auth_utils.cc
+++ b/client/auth_utils.cc
@@ -61,7 +61,7 @@ int parse_cnf_file(istream &sin, map<string, string > *options,
getline(sin, option_value);
trim(&option_value);
if (option_name.length() > 0)
- options->insert(make_pair<string, string >(option_name, option_value));
+ options->insert(make_pair(option_name, option_value));
}
return ALL_OK;
} catch(...)