mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-armv7 to 4.1.0-2
This commit is contained in:
parent
3e41f9f654
commit
3b9fcef493
10 changed files with 359 additions and 27 deletions
|
@ -1,7 +1,7 @@
|
|||
From 4b71aa5c2f8c1384113abefee4cc04febe5944dd Mon Sep 17 00:00:00 2001
|
||||
From c3378026429b3ff9f2236fe0700db7eb7e450a46 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 1/7] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 5c2fcc45bf5f0639fc0779a368fc6708d771e03e Mon Sep 17 00:00:00 2001
|
||||
From 8e6e2743ebdc2f46f59190391db3d2f37290047f Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 2/7] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From ef219483b7217495b3307abba505067c6935dac4 Mon Sep 17 00:00:00 2001
|
||||
From 67570590136361a2bb0ed62beef15151dc1a4572 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 3/7] SMILE Plug device tree file
|
||||
Subject: [PATCH 3/8] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -205,5 +205,5 @@ index 0000000..d01308a
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 924f341f6e272bf3356b5f636cfa8e3e62ed02f0 Mon Sep 17 00:00:00 2001
|
||||
From 3fe82206833efc04b2625c60eb7f3ea6972d5a53 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 4/7] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 4/8] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -34,5 +34,5 @@ index a448498..14441a6 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From adcfd377f7e6887ed91ea999f1dece87f6c1748b Mon Sep 17 00:00:00 2001
|
||||
From 0cca0b90853cd9e03a5c6d2018d1fb5c790dce59 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 5/7] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
|
|||
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
||||
dev->net->dev_addr) == 0) {
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From fe5199f417904bf8ae27a9939cb585959f98400d Mon Sep 17 00:00:00 2001
|
||||
From 493b50d16cd287231bbe11da07f82184d80ceba2 Mon Sep 17 00:00:00 2001
|
||||
From: dobatog <dobatog@gmail.com>
|
||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 6/7] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
Subject: [PATCH 6/8] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
related to input routing signals.
|
||||
|
||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||
|
@ -45,5 +45,5 @@ index cc17e7e..891f3aa 100644
|
|||
/* input mux */
|
||||
{"Capture Source", "Line", "Line Input"},
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From a43e9af55ac3116a6ea2d3d0686820ee95e4839a Mon Sep 17 00:00:00 2001
|
||||
From b9c28f3bd758d09374fe35e86d5d5d4aeb7c6a0a Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 14 Jun 2015 13:20:25 -0600
|
||||
Subject: [PATCH 7/7] set default cubietruck led triggers
|
||||
Subject: [PATCH 7/8] set default cubietruck led triggers
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -29,5 +29,5 @@ index 8f74a64..1161296 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.4.3
|
||||
2.4.4
|
||||
|
||||
|
|
329
core/linux-armv7/0008-USB-armory-support.patch
Normal file
329
core/linux-armv7/0008-USB-armory-support.patch
Normal file
|
@ -0,0 +1,329 @@
|
|||
From 163421a4fef11bea6cf4bdb4ad9de67fb340bb90 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 7 Mar 2015 16:51:15 -0700
|
||||
Subject: [PATCH 8/8] USB armory support
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 3 +
|
||||
arch/arm/boot/dts/imx53-usbarmory-common.dtsi | 209 ++++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/imx53-usbarmory-gpio.dts | 26 ++++
|
||||
arch/arm/boot/dts/imx53-usbarmory-host.dts | 18 +++
|
||||
arch/arm/boot/dts/imx53-usbarmory.dts | 18 +++
|
||||
5 files changed, 274 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-common.dtsi
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-gpio.dts
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-host.dts
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 2373ab3..27728dd 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -252,6 +252,9 @@ dtb-$(CONFIG_SOC_IMX53) += \
|
||||
imx53-smd.dtb \
|
||||
imx53-tx53-x03x.dtb \
|
||||
imx53-tx53-x13x.dtb \
|
||||
+ imx53-usbarmory.dtb \
|
||||
+ imx53-usbarmory-gpio.dtb \
|
||||
+ imx53-usbarmory-host.dtb \
|
||||
imx53-voipac-bsb.dtb
|
||||
dtb-$(CONFIG_SOC_IMX6Q) += \
|
||||
imx6dl-aristainetos_4.dtb \
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory-common.dtsi b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
|
||||
new file mode 100644
|
||||
index 0000000..c7cbd84
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
|
||||
@@ -0,0 +1,209 @@
|
||||
+/*
|
||||
+ * USB armory MkI device tree include file
|
||||
+ * http://inversepath.com/usbarmory
|
||||
+ *
|
||||
+ * Copyright (C) 2015, Inverse Path
|
||||
+ * Andrej Rosano <andrej@inversepath.com>
|
||||
+ *
|
||||
+ * Licensed under GPLv2
|
||||
+ */
|
||||
+
|
||||
+#include "imx53.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Inverse Path USB armory";
|
||||
+ compatible = "inversepath,imx53-usbarmory", "fsl,imx53";
|
||||
+};
|
||||
+
|
||||
+/ {
|
||||
+ chosen {
|
||||
+ stdout-path = &uart1;
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x70000000 0x20000000>;
|
||||
+ };
|
||||
+
|
||||
+ leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&led_pin_gpio4_27>;
|
||||
+
|
||||
+ user {
|
||||
+ label = "LED";
|
||||
+ gpios = <&gpio4 27 0>;
|
||||
+ linux,default-trigger = "heartbeat";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ soc {
|
||||
+ aips@60000000 {
|
||||
+ sahara: crypto@63ff8000 {
|
||||
+ compatible = "fsl,imx53-sahara";
|
||||
+ reg = <0x63ff8000 0x4000>;
|
||||
+ interrupts = <19 20>;
|
||||
+ clocks = <&clks IMX5_CLK_SAHARA_IPG_GATE>,
|
||||
+ <&clks IMX5_CLK_SAHARA_IPG_GATE>;
|
||||
+ clock-names = "ipg", "ahb";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&cpu0 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,cortex-a8";
|
||||
+ reg = <0x0>;
|
||||
+ clocks = <&clks IMX5_CLK_ARM>;
|
||||
+ clock-latency = <61036>;
|
||||
+ voltage-tolerance = <5>;
|
||||
+ operating-points = <
|
||||
+ /* kHz */
|
||||
+ 166666 850000
|
||||
+ 400000 900000
|
||||
+ 800000 1050000
|
||||
+ >;
|
||||
+};
|
||||
+
|
||||
+&esdhc1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_esdhc1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&iomuxc {
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+ imx53-usbarmory {
|
||||
+ pinctrl_pinheader: pinheadergrp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT8__GPIO5_26 0xc0
|
||||
+ MX53_PAD_CSI0_DAT9__GPIO5_27 0xc0
|
||||
+ MX53_PAD_CSI0_DAT10__GPIO5_28 0xc0
|
||||
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0xc0
|
||||
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0xc0
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ led_pin_gpio4_27: led_gpio4_27@0 {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_esdhc1: esdhc1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_SD1_DATA0__ESDHC1_DAT0 0x1d5
|
||||
+ MX53_PAD_SD1_DATA1__ESDHC1_DAT1 0x1d5
|
||||
+ MX53_PAD_SD1_DATA2__ESDHC1_DAT2 0x1d5
|
||||
+ MX53_PAD_SD1_DATA3__ESDHC1_DAT3 0x1d5
|
||||
+ MX53_PAD_SD1_CMD__ESDHC1_CMD 0x1d5
|
||||
+ MX53_PAD_SD1_CLK__ESDHC1_CLK 0x1d5
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_i2c1: i2c1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0xc0000000
|
||||
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0xc0000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_uart1: uart1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT10__UART1_TXD_MUX 0x1e4
|
||||
+ MX53_PAD_CSI0_DAT11__UART1_RXD_MUX 0x1e4
|
||||
+ >;
|
||||
+ };
|
||||
+ pinctrl_gpio5: gpio5grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT8__GPIO5_26 0xc0
|
||||
+ MX53_PAD_CSI0_DAT9__GPIO5_27 0xc0
|
||||
+ MX53_PAD_CSI0_DAT10__GPIO5_28 0xc0
|
||||
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0xc0
|
||||
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0xc0
|
||||
+ >;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&uart1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_uart1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&vpu {
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&i2c1 {
|
||||
+ ltc3589: pmic@34 {
|
||||
+ compatible = "lltc,ltc3589-2";
|
||||
+ reg = <0x34>;
|
||||
+
|
||||
+ regulators {
|
||||
+ sw1_reg: sw1 {
|
||||
+ regulator-min-microvolt = <591930>;
|
||||
+ regulator-max-microvolt = <1224671>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw2_reg: sw2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456803>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw3_reg: sw3 {
|
||||
+ regulator-min-microvolt = <1341250>;
|
||||
+ regulator-max-microvolt = <2775000>;
|
||||
+ lltc,fb-voltage-divider = <270000 100000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ bb_out_reg: bb-out {
|
||||
+ regulator-min-microvolt = <3387341>;
|
||||
+ regulator-max-microvolt = <3387341>;
|
||||
+ lltc,fb-voltage-divider = <511000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+ ldo1_reg: ldo1 {
|
||||
+ regulator-min-microvolt = <1306329>;
|
||||
+ regulator-max-microvolt = <1306329>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo2_reg: ldo2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456806>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo3_reg: ldo3 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo4_reg: ldo4 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <3200000>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory-gpio.dts b/arch/arm/boot/dts/imx53-usbarmory-gpio.dts
|
||||
new file mode 100644
|
||||
index 0000000..bf85ffa
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory-gpio.dts
|
||||
@@ -0,0 +1,26 @@
|
||||
+/*
|
||||
+ * USB armory MkI device mode device tree file
|
||||
+ * http://inversepath.com/usbarmory
|
||||
+ *
|
||||
+ * Copyright (C) 2015, Inverse Path
|
||||
+ * Andrej Rosano <andrej@inversepath.com>
|
||||
+ *
|
||||
+ * Licensed under GPLv2
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "imx53-usbarmory-common.dtsi"
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "peripheral";
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&iomuxc {
|
||||
+ pinctrl-0 = <&pinctrl_pinheader>;
|
||||
+};
|
||||
+
|
||||
+&uart1 {
|
||||
+ status = "disabled";
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory-host.dts b/arch/arm/boot/dts/imx53-usbarmory-host.dts
|
||||
new file mode 100644
|
||||
index 0000000..ea2ea45
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory-host.dts
|
||||
@@ -0,0 +1,18 @@
|
||||
+/*
|
||||
+ * USB armory MkI host mode device tree file
|
||||
+ * http://inversepath.com/usbarmory
|
||||
+ *
|
||||
+ * Copyright (C) 2015, Inverse Path
|
||||
+ * Andrej Rosano <andrej@inversepath.com>
|
||||
+ *
|
||||
+ * Licensed under GPLv2
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "imx53-usbarmory-common.dtsi"
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "host";
|
||||
+ status = "okay";
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
new file mode 100644
|
||||
index 0000000..902a73b
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
@@ -0,0 +1,18 @@
|
||||
+/*
|
||||
+ * USB armory MkI device mode device tree file
|
||||
+ * http://inversepath.com/usbarmory
|
||||
+ *
|
||||
+ * Copyright (C) 2015, Inverse Path
|
||||
+ * Andrej Rosano <andrej@inversepath.com>
|
||||
+ *
|
||||
+ * Licensed under GPLv2
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "imx53-usbarmory-common.dtsi"
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "peripheral";
|
||||
+ status = "okay";
|
||||
+};
|
||||
--
|
||||
2.4.4
|
||||
|
|
@ -8,7 +8,7 @@ _srcname=linux-4.1
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=4.1.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
rcnrel=armv7-x0
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -27,6 +27,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
||||
'0007-set-default-cubietruck-led-triggers.patch'
|
||||
'0008-USB-armory-support.patch'
|
||||
'config')
|
||||
md5sums=('fe9dc0f6729f36400ea81aa41d614c37'
|
||||
'6666a3775a8bd366bc6501ef954109d2'
|
||||
|
@ -38,7 +39,8 @@ md5sums=('fe9dc0f6729f36400ea81aa41d614c37'
|
|||
'118b747e801e6ddfd898c9e356220f28'
|
||||
'fa1c571243107cb76c265acacc48e05e'
|
||||
'6fb01f0b5cd05de3a44ebf30599eddf9'
|
||||
'f8820ca4963b2dbfc32f441bbc96dc5c')
|
||||
'be06d6059e1e52c7f33ffd08d021ddfb'
|
||||
'7c666728ed21ca965ed2ddaef7579ecc')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -57,6 +59,7 @@ prepare() {
|
|||
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
||||
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
||||
git apply ../0008-USB-armory-support.patch
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs4-standalone/Documentation" .
|
||||
|
@ -114,7 +117,7 @@ _package() {
|
|||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
provides=('kernel26' "linux=${pkgver}" 'aufs_friendly')
|
||||
conflicts=('linux')
|
||||
replaces=('linux-mvebu' 'linux-udoo' 'linux-sun4i' 'linux-sun5i' 'linux-sun7i')
|
||||
replaces=('linux-mvebu' 'linux-udoo' 'linux-sun4i' 'linux-sun5i' 'linux-sun7i' 'linux-usbarmory')
|
||||
install=${pkgname}.install
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -161,7 +164,7 @@ _package-headers() {
|
|||
pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
|
||||
provides=("linux-headers=${pkgver}")
|
||||
conflicts=('linux-headers')
|
||||
replaces=('linux-mvebu-headers' 'linux-sun4i-headers' 'linux-sun5i-headers' 'linux-sun7i-headers')
|
||||
replaces=('linux-mvebu-headers' 'linux-sun4i-headers' 'linux-sun5i-headers' 'linux-sun7i-headers' 'linux-usbarmory-headers')
|
||||
|
||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.1.0-1 Kernel Configuration
|
||||
# Linux/arm 4.1.0-2 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -3790,7 +3790,7 @@ CONFIG_REGULATOR_GPIO=y
|
|||
# CONFIG_REGULATOR_LP3972 is not set
|
||||
# CONFIG_REGULATOR_LP872X is not set
|
||||
# CONFIG_REGULATOR_LP8755 is not set
|
||||
# CONFIG_REGULATOR_LTC3589 is not set
|
||||
CONFIG_REGULATOR_LTC3589=y
|
||||
# CONFIG_REGULATOR_MAX1586 is not set
|
||||
# CONFIG_REGULATOR_MAX8649 is not set
|
||||
# CONFIG_REGULATOR_MAX8660 is not set
|
||||
|
|
Loading…
Reference in a new issue