aur/msp430* packages

This commit is contained in:
Mike Brown 2013-07-20 13:13:30 -04:00
parent 75dda030c9
commit 3c83f10147
10 changed files with 842 additions and 0 deletions

View file

@ -0,0 +1,24 @@
diff -urNad ld/Makefile.am ld_/Makefile.am
--- ld/Makefile.am 2010-11-03 16:22:01.000000000 +1300
+++ ld_/Makefile.am 2011-06-14 22:48:48.942861545 +1200
@@ -37,7 +37,7 @@
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.
-scriptdir = $(tooldir)/lib
+scriptdir = $(libdir)
EMUL = @EMUL@
EMULATION_OFILES = @EMULATION_OFILES@
diff -urNad ld/Makefile.in ld_/Makefile.in
--- ld/Makefile.in 2010-11-05 23:34:22.000000000 +1300
+++ ld_/Makefile.in 2011-06-14 22:48:52.065772461 +1200
@@ -360,7 +360,7 @@
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.
-scriptdir = $(tooldir)/lib
+scriptdir = $(libdir)
BASEDIR = $(srcdir)/..
BFDDIR = $(BASEDIR)/bfd
INCDIR = $(BASEDIR)/include

View file

@ -0,0 +1,261 @@
diff --git c/gas/doc/c-arc.texi i/gas/doc/c-arc.texi
index 3a136a7..cd6f0d9 100644
--- c/gas/doc/c-arc.texi
+++ i/gas/doc/c-arc.texi
@@ -212,7 +212,7 @@ The extension instructions are not macros. The assembler creates
encodings for use of these instructions according to the specification
by the user. The parameters are:
-@table @bullet
+@table @code
@item @var{name}
Name of the extension instruction
diff --git c/gas/doc/c-arm.texi i/gas/doc/c-arm.texi
index d3cccf4..97c2f92 100644
--- c/gas/doc/c-arm.texi
+++ i/gas/doc/c-arm.texi
@@ -376,29 +376,29 @@ ARM and THUMB instructions had their own, separate syntaxes. The new,
@code{unified} syntax, which can be selected via the @code{.syntax}
directive, and has the following main features:
-@table @bullet
-@item
+@table @code
+@item 1
Immediate operands do not require a @code{#} prefix.
-@item
+@item 2
The @code{IT} instruction may appear, and if it does it is validated
against subsequent conditional affixes. In ARM mode it does not
generate machine code, in THUMB mode it does.
-@item
+@item 3
For ARM instructions the conditional affixes always appear at the end
of the instruction. For THUMB instructions conditional affixes can be
used, but only inside the scope of an @code{IT} instruction.
-@item
+@item 4
All of the instructions new to the V6T2 architecture (and later) are
available. (Only a few such instructions can be written in the
@code{divided} syntax).
-@item
+@item 5
The @code{.N} and @code{.W} suffixes are recognized and honored.
-@item
+@item 6
All instructions set the flags if and only if they have an @code{s}
affix.
@end table
@@ -433,28 +433,6 @@ Either @samp{#} or @samp{$} can be used to indicate immediate operands.
@cindex register names, ARM
*TODO* Explain about ARM register naming, and the predefined names.
-@node ARM-Neon-Alignment
-@subsection NEON Alignment Specifiers
-
-@cindex alignment for NEON instructions
-Some NEON load/store instructions allow an optional address
-alignment qualifier.
-The ARM documentation specifies that this is indicated by
-@samp{@@ @var{align}}. However GAS already interprets
-the @samp{@@} character as a "line comment" start,
-so @samp{: @var{align}} is used instead. For example:
-
-@smallexample
- vld1.8 @{q0@}, [r0, :128]
-@end smallexample
-
-@node ARM Floating Point
-@section Floating Point
-
-@cindex floating point, ARM (@sc{ieee})
-@cindex ARM floating point (@sc{ieee})
-The ARM family uses @sc{ieee} floating-point numbers.
-
@node ARM-Relocations
@subsection ARM relocation generation
@@ -497,6 +475,28 @@ respectively. For example to load the 32-bit address of foo into r0:
MOVT r0, #:upper16:foo
@end smallexample
+@node ARM-Neon-Alignment
+@subsection NEON Alignment Specifiers
+
+@cindex alignment for NEON instructions
+Some NEON load/store instructions allow an optional address
+alignment qualifier.
+The ARM documentation specifies that this is indicated by
+@samp{@@ @var{align}}. However GAS already interprets
+the @samp{@@} character as a "line comment" start,
+so @samp{: @var{align}} is used instead. For example:
+
+@smallexample
+ vld1.8 @{q0@}, [r0, :128]
+@end smallexample
+
+@node ARM Floating Point
+@section Floating Point
+
+@cindex floating point, ARM (@sc{ieee})
+@cindex ARM floating point (@sc{ieee})
+The ARM family uses @sc{ieee} floating-point numbers.
+
@node ARM Directives
@section ARM Machine Directives
diff --git c/gas/doc/c-cr16.texi i/gas/doc/c-cr16.texi
index b6cf10f..00ddae2 100644
--- c/gas/doc/c-cr16.texi
+++ i/gas/doc/c-cr16.texi
@@ -43,26 +43,33 @@ Operand expression type qualifier is an optional field in the instruction operan
CR16 target operand qualifiers and its size (in bits):
@table @samp
-@item Immediate Operand
-- s ---- 4 bits
-@item
-- m ---- 16 bits, for movb and movw instructions.
-@item
-- m ---- 20 bits, movd instructions.
-@item
-- l ---- 32 bits
-
-@item Absolute Operand
-- s ---- Illegal specifier for this operand.
-@item
-- m ---- 20 bits, movd instructions.
-
-@item Displacement Operand
-- s ---- 8 bits
-@item
-- m ---- 16 bits
-@item
-- l ---- 24 bits
+@item Immediate Operand: s
+4 bits.
+
+@item Immediate Operand: m
+16 bits, for movb and movw instructions.
+
+@item Immediate Operand: m
+20 bits, movd instructions.
+
+@item Immediate Operand: l
+32 bits.
+
+@item Absolute Operand: s
+Illegal specifier for this operand.
+
+@item Absolute Operand: m
+20 bits, movd instructions.
+
+@item Displacement Operand: s
+8 bits.
+
+@item Displacement Operand: m
+16 bits.
+
+@item Displacement Operand: l
+24 bits
+
@end table
For example:
diff --git c/gas/doc/c-mips.texi i/gas/doc/c-mips.texi
index 715091e..1250c1e 100644
--- c/gas/doc/c-mips.texi
+++ i/gas/doc/c-mips.texi
@@ -220,7 +220,7 @@ the @samp{mad} and @samp{madu} instruction, and to not schedule @samp{nop}
instructions around accesses to the @samp{HI} and @samp{LO} registers.
@samp{-no-m4650} turns off this option.
-@itemx -m3900
+@item -m3900
@itemx -no-m3900
@itemx -m4100
@itemx -no-m4100
diff --git c/gas/doc/c-score.texi i/gas/doc/c-score.texi
index 0820115..a5b570f 100644
--- c/gas/doc/c-score.texi
+++ i/gas/doc/c-score.texi
@@ -36,7 +36,7 @@ implicitly with the @code{gp} register. The default value is 8.
@item -EB
Assemble code for a big-endian cpu
-@itemx -EL
+@item -EL
Assemble code for a little-endian cpu
@item -FIXDD
@@ -48,13 +48,13 @@ Assemble code for no warning message for fix data dependency
@item -SCORE5
Assemble code for target is SCORE5
-@itemx -SCORE5U
+@item -SCORE5U
Assemble code for target is SCORE5U
-@itemx -SCORE7
+@item -SCORE7
Assemble code for target is SCORE7, this is default setting
-@itemx -SCORE3
+@item -SCORE3
Assemble code for target is SCORE3
@item -march=score7
diff --git c/gas/doc/c-tic54x.texi i/gas/doc/c-tic54x.texi
index 4cfb440..9d631a6 100644
--- c/gas/doc/c-tic54x.texi
+++ i/gas/doc/c-tic54x.texi
@@ -108,7 +108,7 @@ In this example, x is replaced with SYM2; SYM2 is replaced with SYM1, and SYM1
is replaced with x. At this point, x has already been encountered
and the substitution stops.
-@smallexample @code
+@smallexample
.asg "x",SYM1
.asg "SYM1",SYM2
.asg "SYM2",x
@@ -125,14 +125,14 @@ Substitution may be forced in situations where replacement might be
ambiguous by placing colons on either side of the subsym. The following
code:
-@smallexample @code
+@smallexample
.eval "10",x
LAB:X: add #x, a
@end smallexample
When assembled becomes:
-@smallexample @code
+@smallexample
LAB10 add #10, a
@end smallexample
@@ -308,7 +308,7 @@ The @code{LDX} pseudo-op is provided for loading the extended addressing bits
of a label or address. For example, if an address @code{_label} resides
in extended program memory, the value of @code{_label} may be loaded as
follows:
-@smallexample @code
+@smallexample
ldx #_label,16,a ; loads extended bits of _label
or #_label,a ; loads lower 16 bits of _label
bacc a ; full address is in accumulator A
@@ -344,7 +344,7 @@ Assign @var{name} the string @var{string}. String replacement is
performed on @var{string} before assignment.
@cindex @code{eval} directive, TIC54X
-@itemx .eval @var{string}, @var{name}
+@item .eval @var{string}, @var{name}
Evaluate the contents of string @var{string} and assign the result as a
string to the subsym @var{name}. String replacement is performed on
@var{string} before assignment.

View file

@ -0,0 +1,91 @@
diff --git i/bfd/doc/bfd.texinfo w/bfd/doc/bfd.texinfo
index 45ffa73..c3ca5e7 100644
--- i/bfd/doc/bfd.texinfo
+++ w/bfd/doc/bfd.texinfo
@@ -322,7 +322,7 @@ All of BFD lives in one directory.
@printindex cp
@tex
-% I think something like @colophon should be in texinfo. In the
+% I think something like @@colophon should be in texinfo. In the
% meantime:
\long\def\colophon{\hbox to0pt{}\vfill
\centerline{The body of this manual is set in}
@@ -333,7 +333,7 @@ All of BFD lives in one directory.
\centerline{{\sl\fontname\tensl\/}}
\centerline{are used for emphasis.}\vfill}
\page\colophon
-% Blame: doc@cygnus.com, 28mar91.
+% Blame: doc@@cygnus.com, 28mar91.
@end tex
@bye
diff --git i/binutils/doc/binutils.texi w/binutils/doc/binutils.texi
index d8d1899..b8f75ce 100644
--- i/binutils/doc/binutils.texi
+++ w/binutils/doc/binutils.texi
@@ -4190,28 +4190,28 @@ equivalent. At least one of the @option{--output-mach},
@table @env
-@itemx --input-mach=@var{machine}
+@item --input-mach=@var{machine}
Set the matching input ELF machine type to @var{machine}. If
@option{--input-mach} isn't specified, it will match any ELF
machine types.
The supported ELF machine types are, @var{L1OM} and @var{x86-64}.
-@itemx --output-mach=@var{machine}
+@item --output-mach=@var{machine}
Change the ELF machine type in the ELF header to @var{machine}. The
supported ELF machine types are the same as @option{--input-mach}.
-@itemx --input-type=@var{type}
+@item --input-type=@var{type}
Set the matching input ELF file type to @var{type}. If
@option{--input-type} isn't specified, it will match any ELF file types.
The supported ELF file types are, @var{rel}, @var{exec} and @var{dyn}.
-@itemx --output-type=@var{type}
+@item --output-type=@var{type}
Change the ELF file type in the ELF header to @var{type}. The
supported ELF types are the same as @option{--input-type}.
-@itemx --input-osabi=@var{osabi}
+@item --input-osabi=@var{osabi}
Set the matching input ELF file OSABI to @var{osbi}. If
@option{--input-osabi} isn't specified, it will match any ELF OSABIs.
@@ -4220,7 +4220,7 @@ The supported ELF OSABIs are, @var{none}, @var{HPUX}, @var{NetBSD},
@var{FreeBSD}, @var{TRU64}, @var{Modesto}, @var{OpenBSD}, @var{OpenVMS},
@var{NSK}, @var{AROS} and @var{FenixOS}.
-@itemx --output-osabi=@var{osabi}
+@item --output-osabi=@var{osabi}
Change the ELF OSABI in the ELF header to @var{type}. The
supported ELF OSABI are the same as @option{--input-osabi}.
diff --git i/ld/ld.texinfo w/ld/ld.texinfo
index 879bcfc..0a0845d 100644
--- i/ld/ld.texinfo
+++ w/ld/ld.texinfo
@@ -7694,7 +7694,7 @@ If you have more than one @code{SECT} statement for the same
@printindex cp
@tex
-% I think something like @colophon should be in texinfo. In the
+% I think something like @@colophon should be in texinfo. In the
% meantime:
\long\def\colophon{\hbox to0pt{}\vfill
\centerline{The body of this manual is set in}
@@ -7705,7 +7705,7 @@ If you have more than one @code{SECT} statement for the same
\centerline{{\sl\fontname\tensl\/}}
\centerline{are used for emphasis.}\vfill}
\page\colophon
-% Blame: doc@cygnus.com, 28mar91.
+% Blame: doc@@cygnus.com, 28mar91.
@end tex
@bye

View file

@ -0,0 +1,96 @@
# Contributor: Rick W. Chen <stuffcorpse at archlinux dot us>
pkgname=binutils-msp430
pkgver=2.21.1a
pkgrel=3
pkgdesc="A set of programs to assemble and manipulate binary and object files for the MSP430 architecture"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/mspgcc/"
license=('GPL')
depends=('zlib')
options=('!emptydirs' '!libtool')
_mspgcc_ver=20120406
_gnu_mirror="http://ftpmirror.gnu.org"
_sf_base="http://sourceforge.net/projects/mspgcc/files"
_patches_base="${_sf_base}/Patches/LTS/${_mspgcc_ver}"
_patches=()
source=("${_sf_base}/mspgcc/mspgcc-${_mspgcc_ver}.tar.bz2"
"${_gnu_mirror}/binutils/binutils-${pkgver}.tar.bz2"
"0001_ld_makefile_libdir.patch"
"0002_binutils-texinfo-5.0-gas-doc.patch"
"0003-binutils-texinfo-5.0.patch")
sha1sums=('cc96a7233f0b1d2c106eff7db6fc00e4ed9039a8'
'525255ca6874b872540c9967a1d26acfbc7c8230'
'7a5d78fd94fd99dd544816db75a14c326c494e68'
'b92aba28a090f214a650102ad0f0862c37b45e58'
'417b1cdb35c41a08d3ca967c165c0d79588986e9')
_builddir="${srcdir}/build"
build() {
_patch_name="msp430-binutils-${pkgver}-${_mspgcc_ver}.patch"
(cd "${srcdir}/binutils-2.21.1" &&
patch -p1 < "${srcdir}/mspgcc-${_mspgcc_ver}/${_patch_name}" &&
patch -p0 < "${srcdir}/0001_ld_makefile_libdir.patch" &&
patch -p1 < "${srcdir}/0002_binutils-texinfo-5.0-gas-doc.patch" &&
patch -p1 < "${srcdir}/0003-binutils-texinfo-5.0.patch" &&
for patch in ${_patches[@]} ; do
msg "Applying ${patch}"
patch -p1 < "${srcdir}/${patch}"
done)
rm -frv ${_builddir}
mkdir -p ${_builddir} && cd ${_builddir}
"${srcdir}/binutils-2.21.1/configure" \
--prefix=/usr \
--program-prefix="msp430-" \
--disable-multilib \
--disable-nls \
--enable-install-libbfd \
--infodir=/usr/share/info \
--libdir=/usr/msp430/lib \
--mandir=/usr/share/man \
--target=msp430
# This checks the host environment and makes sure all the necessary
# tools are available to compile Binutils.
make configure-host
make tooldir=/usr all
}
check() {
cd ${_builddir}
# do not abort on errors - manually check log files
make -k -j1 check || true
}
package() {
cd ${_builddir}
make DESTDIR=${pkgdir} tooldir=/usr install
rm -f ${pkgdir}/usr/lib/libiberty.a
rm -f ${pkgdir}/usr/man/man1/{dlltool,nlmconv,windres}*
rm -f ${pkgdir}/usr/share/info/dir
cd ${pkgdir}/usr/share/info
for file in as bfd binutils configure gprof ld standards ; do
mv ${file}.info "msp430-${file}.info"
done
for bin in addr2line ar as c++filt gprof ld nm objcopy \
objdump ranlib readelf size strings strip
do
rm -f ${pkgdir}/usr/bin/${bin}
done
install -Dm644 "${srcdir}/binutils-2.21.1/COPYING" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set sts=2 ts=2 sw=2 et:

View file

@ -0,0 +1,101 @@
diff --git c/gcc/doc/cppopts.texi i/gcc/doc/cppopts.texi
index 5212478..52d5997 100644
--- c/gcc/doc/cppopts.texi
+++ i/gcc/doc/cppopts.texi
@@ -769,7 +769,7 @@ Replacement: [ ] @{ @} # \ ^ | ~
Enable special code to work around file systems which only permit very
short file names, such as MS-DOS@.
-@itemx --help
+@item --help
@itemx --target-help
@opindex help
@opindex target-help
diff --git c/gcc/doc/generic.texi i/gcc/doc/generic.texi
index 5874c55..79af22f 100644
--- c/gcc/doc/generic.texi
+++ i/gcc/doc/generic.texi
@@ -1415,13 +1415,13 @@ generate these expressions anyhow, if it can tell that strictness does
not matter. The type of the operands and that of the result are
always of @code{BOOLEAN_TYPE} or @code{INTEGER_TYPE}.
-@itemx POINTER_PLUS_EXPR
+@item POINTER_PLUS_EXPR
This node represents pointer arithmetic. The first operand is always
a pointer/reference type. The second operand is always an unsigned
integer type compatible with sizetype. This is the only binary
arithmetic operand that can operate on pointer types.
-@itemx PLUS_EXPR
+@item PLUS_EXPR
@itemx MINUS_EXPR
@itemx MULT_EXPR
These nodes represent various binary arithmetic operations.
diff --git c/gcc/doc/invoke.texi i/gcc/doc/invoke.texi
index 4ed31b6..c071595 100644
--- c/gcc/doc/invoke.texi
+++ i/gcc/doc/invoke.texi
@@ -165,7 +165,7 @@ in the following sections.
-pipe -pass-exit-codes @gol
-x @var{language} -v -### --help@r{[}=@var{class}@r{[},@dots{}@r{]]} --target-help @gol
--version -wrapper @@@var{file} -fplugin=@var{file} -fplugin-arg-@var{name}=@var{arg} @gol
--fdump-ada-spec@r{[}-slim@r{]}} -fdump-go-spec=@var{file}
+-fdump-ada-spec@r{[}-slim@r{]} -fdump-go-spec=@var{file}}
@item C Language Options
@xref{C Dialect Options,,Options Controlling C Dialect}.
@@ -5085,11 +5085,11 @@ Dump after duplicating the computed gotos.
@option{-fdump-rtl-ce3} enable dumping after the three
if conversion passes.
-@itemx -fdump-rtl-cprop_hardreg
+@item -fdump-rtl-cprop_hardreg
@opindex fdump-rtl-cprop_hardreg
Dump after hard register copy propagation.
-@itemx -fdump-rtl-csa
+@item -fdump-rtl-csa
@opindex fdump-rtl-csa
Dump after combining stack adjustments.
@@ -5100,11 +5100,11 @@ Dump after combining stack adjustments.
@option{-fdump-rtl-cse1} and @option{-fdump-rtl-cse2} enable dumping after
the two common sub-expression elimination passes.
-@itemx -fdump-rtl-dce
+@item -fdump-rtl-dce
@opindex fdump-rtl-dce
Dump after the standalone dead code elimination passes.
-@itemx -fdump-rtl-dbr
+@item -fdump-rtl-dbr
@opindex fdump-rtl-dbr
Dump after delayed branch scheduling.
@@ -5149,7 +5149,7 @@ Dump after the initialization of the registers.
@opindex fdump-rtl-initvals
Dump after the computation of the initial value sets.
-@itemx -fdump-rtl-into_cfglayout
+@item -fdump-rtl-into_cfglayout
@opindex fdump-rtl-into_cfglayout
Dump after converting to cfglayout mode.
@@ -5179,7 +5179,7 @@ Dump after removing redundant mode switches.
@opindex fdump-rtl-rnreg
Dump after register renumbering.
-@itemx -fdump-rtl-outof_cfglayout
+@item -fdump-rtl-outof_cfglayout
@opindex fdump-rtl-outof_cfglayout
Dump after converting from cfglayout mode.
@@ -5191,7 +5191,7 @@ Dump after the peephole pass.
@opindex fdump-rtl-postreload
Dump after post-reload optimizations.
-@itemx -fdump-rtl-pro_and_epilogue
+@item -fdump-rtl-pro_and_epilogue
@opindex fdump-rtl-pro_and_epilogue
Dump after generating the function pro and epilogues.

84
aur/gcc-msp430/PKGBUILD Normal file
View file

@ -0,0 +1,84 @@
# Contributor: Rick W. Chen <stuffcorpse at archlinux dot us>
pkgname=gcc-msp430
pkgver=4.6.3
pkgrel=4
pkgdesc="GNU toolchain for the TI MSP430 processor"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/mspgcc/"
license=('GPL')
makedepends=('binutils-msp430')
depends=('elfutils' 'libmpc')
options=(!strip !emptydirs !libtool)
_mspgcc_ver=20120406
_gnu_mirror="http://ftpmirror.gnu.org"
_sf_base="http://sourceforge.net/projects/mspgcc/files"
_patches_base="${_sf_base}/Patches/LTS/${_mspgcc_ver}"
_patches=(msp430-gcc-${pkgver}-20120406-sf3540953.patch
msp430-gcc-${pkgver}-20120406-sf3559978.patch)
source=("http://sourceforge.net/projects/mspgcc/files/mspgcc/mspgcc-${_mspgcc_ver}.tar.bz2"
"${_gnu_mirror}/gcc/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
"${_patches[0]}::${_patches_base}/${_patches[0]}/download"
"${_patches[1]}::${_patches_base}/${_patches[1]}/download"
"0001_gcc-doc-texinfo-5.0.patch")
sha1sums=('cc96a7233f0b1d2c106eff7db6fc00e4ed9039a8'
'ce317ca5c8185b58bc9300182b534608c578637f'
'9de4e74d8ceb2005409e03bf671e619f2e060082'
'3721d13fd9a19df60fe356e082e6cea4ea637dbc'
'0f5e63dc6a689976014c6cc87d5be28eb4ee922b')
_builddir="${srcdir}/build"
build() {
_patch_name="msp430-gcc-${pkgver}-${_mspgcc_ver}.patch"
(cd "${srcdir}/gcc-${pkgver}" &&
patch -p1 < "${srcdir}/mspgcc-${_mspgcc_ver}/${_patch_name}" &&
patch -p1 < "${srcdir}/0001_gcc-doc-texinfo-5.0.patch" &&
for patch in ${_patches[@]} ; do
msg "Applying ${patch}"
patch -p1 < "${srcdir}/${patch}"
done)
rm -frv ${_builddir}
mkdir -p ${_builddir} && cd ${_builddir}
"${srcdir}/gcc-${pkgver}/configure" \
CFLAGS_FOR_TARGET="-Os" \
--prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--disable-libssp \
--disable-nls \
--target=msp430 \
--enable-languages=c,c++ \
--with-gnu-as \
--with-gnu-ld \
--with-as=/usr/bin/msp430-as \
--with-ld=/usr/bin/msp430-ld \
--with-pkgversion="mspgcc_${_mspgcc_ver}"
make
}
package() {
cd ${_builddir}
make DESTDIR=${pkgdir} install
rm -f ${pkgdir}/usr/lib/libiberty.a
rm -rf ${pkgdir}/usr/share/man/man7
rm -rf ${pkgdir}/usr/share/info
msg "Stripping debugging symbols from binaries"
local binary
find ${pkgdir} -type f 2>/dev/null | while read binary ; do
case "$(file -biz "$binary")" in
*compressed-encoding*) # Skip compressed binarys
;;
*application/x-executable*) # Binaries
/usr/bin/strip "$binary" >/dev/null 2>&1 ;;
esac
done
}
# vim:set sts=2 ts=2 sw=2 et:

View file

@ -0,0 +1,22 @@
diff --git c/bfd/doc/bfd.texinfo i/bfd/doc/bfd.texinfo
index ce1c5af..47a0667 100644
--- c/bfd/doc/bfd.texinfo
+++ i/bfd/doc/bfd.texinfo
@@ -323,7 +323,7 @@ All of BFD lives in one directory.
@printindex cp
@tex
-% I think something like @colophon should be in texinfo. In the
+% I think something like @@colophon should be in texinfo. In the
% meantime:
\long\def\colophon{\hbox to0pt{}\vfill
\centerline{The body of this manual is set in}
@@ -334,7 +334,7 @@ All of BFD lives in one directory.
\centerline{{\sl\fontname\tensl\/}}
\centerline{are used for emphasis.}\vfill}
\page\colophon
-% Blame: doc@cygnus.com, 28mar91.
+% Blame: doc@@cygnus.com, 28mar91.
@end tex
@bye

View file

@ -0,0 +1,34 @@
http://sourceware.org/git/?p=gdb.git;a=commitdiff;h=7f62f13c2b535c6a23035407f1c8a36ad7993dec
From 7f62f13c2b535c6a23035407f1c8a36ad7993dec Mon Sep 17 00:00:00 2001
From: Tom Tromey <tromey@redhat.com>
Date: Thu, 28 Apr 2011 20:36:49 +0000
Subject: [PATCH] * bfdio.c (memory_bstat): Pass correct size to memset.
---
diff --git a/bfd/bfdio.c b/bfd/bfdio.c
index ce92781..dab8e88 100644
--- a/bfd/bfdio.c
+++ b/bfd/bfdio.c
@@ -1,7 +1,7 @@
/* Low-level I/O routines for BFDs.
Copyright 1990, 1991, 1992, 1993, 1994, 1995, 1996, 1997, 1998,
- 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
+ 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2011
Free Software Foundation, Inc.
Written by Cygnus Support.
@@ -577,7 +577,7 @@ memory_bstat (bfd *abfd, struct stat *statbuf)
{
struct bfd_in_memory *bim = (struct bfd_in_memory *) abfd->iostream;
- memset (statbuf, 0, sizeof (statbuf));
+ memset (statbuf, 0, sizeof (*statbuf));
statbuf->st_size = bim->size;
return 0;
--
1.7.1

83
aur/msp430-gdb/PKGBUILD Normal file
View file

@ -0,0 +1,83 @@
# Contributor: Rick W. Chen <stuffcorpse at archlinux dot us>
# Contributor: nboichat <nicolas-aur at boichat.ch>
pkgname=msp430-gdb
pkgver=7.2a
_gdbver=7.2
pkgrel=5
pkgdesc="GNU debugger for MSP430"
arch=('i686' 'x86_64')
url="http://mspgcc4.sourceforge.net/"
license=('GPL')
depends=('gcc-msp430' 'python2')
makedepends=('gcc-msp430')
_mspgcc_ver=20120406
_gdb_patch_ver=20111205
_gnu_mirror="http://ftpmirror.gnu.org"
source=("http://sourceforge.net/projects/mspgcc/files/mspgcc/mspgcc-${_mspgcc_ver}.tar.bz2"
"${_gnu_mirror}/gdb/gdb-${pkgver}.tar.bz2"
"0001_bfd-doc-texinfo-5.0.patch"
"0002_bfdio-pass-correct-size.patch")
sha1sums=('cc96a7233f0b1d2c106eff7db6fc00e4ed9039a8'
'14daf8ccf1307f148f80c8db17f8e43f545c2691'
'1670af85f2b78d794559e81cfcadf6f10e17a032'
'db00a6d342cb5aab00e61fd795de4c499ae0e820')
build() {
_builddir="${srcdir}/build"
_patch_name="msp430-gdb-${_gdbver}a-${_gdb_patch_ver}.patch"
(cd "${srcdir}/gdb-${_gdbver}" &&
patch -p1 < "${srcdir}/mspgcc-${_mspgcc_ver}/${_patch_name}" &&
patch -p1 < "${srcdir}/0001_bfd-doc-texinfo-5.0.patch" &&
patch -p1 < "${srcdir}/0002_bfdio-pass-correct-size.patch")
# Fix configure problem if CPPFLAGS contains "-D_FORTIFY_SOURCE=2"
export CPPFLAGS="$CPPFLAGS -O2"
rm -frv ${_builddir}
mkdir -p ${_builddir} && cd ${_builddir}
"${srcdir}/gdb-${_gdbver}/configure" \
--target=msp430 \
--prefix=/usr \
--program-prefix="msp430-" \
--enable-languages=c,c++ \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-python=python2 \
--disable-nls
make
}
package() {
_builddir="${srcdir}/build"
cd ${_builddir}
make DESTDIR=${pkgdir} install
cd ${pkgdir}/usr/share/info
for file in annotate stabs ; do
mv ${file}.info "msp430-${file}.info"
done
for file in gdb.info* gdbint.info* ; do
mv ${file} "msp430-${file}"
done
rm -fr ${pkgdir}/usr/lib/libiberty.a
rm -fr ${pkgdir}/usr/share/info/dir
rm -fr ${pkgdir}/usr/share/info/bfd.info
rm -fr ${pkgdir}/usr/share/info/configure.info
rm -fr ${pkgdir}/usr/share/info/standards.info
rm -fr ${pkgdir}/usr/share/gdb/syscalls/amd64-linux.xml
rm -fr ${pkgdir}/usr/share/gdb/syscalls/gdb-syscalls.dtd
rm -fr ${pkgdir}/usr/share/gdb/syscalls/i386-linux.xml
rm -fr ${pkgdir}/usr/share/gdb/syscalls/ppc-linux.xml
rm -fr ${pkgdir}/usr/share/gdb/syscalls/ppc64-linux.xml
rm -fr ${pkgdir}/usr/share/gdb/syscalls/sparc-linux.xml
rm -fr ${pkgdir}/usr/share/gdb/syscalls/sparc64-linux.xml
}
# vim:set sts=2 ts=2 sw=2 et:

46
aur/msp430-libc/PKGBUILD Normal file
View file

@ -0,0 +1,46 @@
# Contributor: Rick W. Chen <stuffcorpse at archlinux dot us>
pkgname=msp430-libc
pkgver=20120224
pkgrel=2
pkgdesc="C runtime library for the MSP430 family of microcontrollers"
arch=('i686' 'x86_64')
url="http://mspgcc4.sourceforge.net/"
license=('custom')
depends=('gcc-msp430')
options=(!strip)
_mspgcc_ver=20120406
_sf_base="http://sourceforge.net/projects/mspgcc/files"
_patches_base="${_sf_base}/Patches/LTS/${_mspgcc_ver}"
_patches=("${pkgname}-${pkgver}-sf3522752.patch")
source=("https://sourceforge.net/projects/mspgcc/files/msp430-libc/msp430-libc-${pkgver}.tar.bz2"
"${_patches[0]}::${_patches_base}/${_patches[0]}/download")
sha1sums=('d01cf0db41bff1a0ab50644cbb11bc5a1d5be172'
'2ca4aea9b8dcd6a199303373a8a97c7a2dd4eef6')
_builddir="${srcdir}/build"
build() {
cp -r "${srcdir}/${pkgname}-${pkgver}" ${_builddir} && cd ${_builddir}/src
(cd "${_builddir}" &&
for patch in ${_patches[@]} ; do
msg "Applying ${patch}"
patch -p1 < "${srcdir}/${patch}"
done)
make PREFIX=/usr
}
package() {
cd ${_builddir}/src
mkdir -p ${pkgdir}/usr/msp430/lib
make -j1 install PREFIX=${pkgdir}/usr
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/COPYING" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set sts=2 ts=2 sw=2 et: