mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/vigra to 1.11.1-8
This commit is contained in:
parent
aef39f5a4e
commit
3ca4d51b8f
2 changed files with 148 additions and 4 deletions
|
@ -9,21 +9,26 @@
|
|||
pkgbase=vigra
|
||||
pkgname=('vigra' 'vigra-doc')
|
||||
pkgver=1.11.1
|
||||
pkgrel=6
|
||||
pkgrel=8
|
||||
pkgdesc="Computer vision library"
|
||||
arch=('x86_64')
|
||||
url="https://ukoethe.github.io/vigra/"
|
||||
license=('custom:MIT')
|
||||
makedepends=(# runtime deps
|
||||
'libpng' 'libtiff' 'openexr' 'gcc-libs' 'sh' 'hdf5' 'fftw'
|
||||
# additional makedeps
|
||||
# additional makedeps
|
||||
'cmake' 'boost' 'python-numpy')
|
||||
checkdepends=('python-nose')
|
||||
source=("https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz")
|
||||
sha256sums=('a5564e1083f6af6a885431c1ee718bad77d11f117198b277557f8558fa461aaf')
|
||||
source=("https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz"
|
||||
'fix-incorrect-template-parameter-type.patch')
|
||||
sha256sums=('a5564e1083f6af6a885431c1ee718bad77d11f117198b277557f8558fa461aaf'
|
||||
'f151f902483dfa2b1f3d431f54bb161300cf184158c9f416fa653d19ab363cc4')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
cd ${pkgbase}-${pkgver}
|
||||
# https://github.com/ukoethe/vigra/issues/414
|
||||
patch -Np1 -i ../fix-incorrect-template-parameter-type.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
139
community/vigra/fix-incorrect-template-parameter-type.patch
Normal file
139
community/vigra/fix-incorrect-template-parameter-type.patch
Normal file
|
@ -0,0 +1,139 @@
|
|||
From 81958d302494e137f98a8b1d7869841532f90388 Mon Sep 17 00:00:00 2001
|
||||
From: JaimeIvanCervantes <jimmycc80@hotmail.com>
|
||||
Date: Fri, 16 Jun 2017 13:21:45 -0700
|
||||
Subject: [PATCH] multi_convolution: Fix for incorrect template parameter type
|
||||
when using unsigned int N for TinyVector SIZE. (Fixes #414)
|
||||
|
||||
---
|
||||
include/vigra/multi_convolution.hxx | 28 ++++++++++++++--------------
|
||||
1 file changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/include/vigra/multi_convolution.hxx b/include/vigra/multi_convolution.hxx
|
||||
index 1b5efa740..ec89bcf58 100644
|
||||
--- a/include/vigra/multi_convolution.hxx
|
||||
+++ b/include/vigra/multi_convolution.hxx
|
||||
@@ -1426,7 +1426,7 @@ gaussianSmoothMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
class T2, class S2>
|
||||
void
|
||||
gaussianGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
double sigma,
|
||||
ConvolutionOptions<N> opt = ConvolutionOptions<N>());
|
||||
|
||||
@@ -1435,7 +1435,7 @@ gaussianSmoothMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
class T2, class S2>
|
||||
void
|
||||
gaussianGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
ConvolutionOptions<N> opt);
|
||||
|
||||
// likewise, but execute algorithm in parallel
|
||||
@@ -1443,7 +1443,7 @@ gaussianSmoothMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
class T2, class S2>
|
||||
void
|
||||
gaussianGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
BlockwiseConvolutionOptions<N> opt);
|
||||
}
|
||||
\endcode
|
||||
@@ -1590,7 +1590,7 @@ template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
inline void
|
||||
gaussianGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
ConvolutionOptions<N> opt )
|
||||
{
|
||||
if(opt.to_point != typename MultiArrayShape<N>::type())
|
||||
@@ -1614,7 +1614,7 @@ template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
inline void
|
||||
gaussianGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
double sigma,
|
||||
ConvolutionOptions<N> opt = ConvolutionOptions<N>())
|
||||
{
|
||||
@@ -1653,7 +1653,7 @@ gaussianGradientMagnitudeImpl(MultiArrayView<N+1, T1, S1> const & src,
|
||||
dest.init(0.0);
|
||||
|
||||
typedef typename NumericTraits<T1>::RealPromote TmpType;
|
||||
- MultiArray<N, TinyVector<TmpType, N> > grad(dest.shape());
|
||||
+ MultiArray<N, TinyVector<TmpType, int(N)> > grad(dest.shape());
|
||||
|
||||
using namespace multi_math;
|
||||
|
||||
@@ -1771,7 +1771,7 @@ gaussianGradientMagnitude(MultiArrayView<N+1, Multiband<T1>, S1> const & src,
|
||||
class T2, class S2>
|
||||
void
|
||||
symmetricGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
ConvolutionOptions<N> opt = ConvolutionOptions<N>());
|
||||
|
||||
// execute algorithm in parallel
|
||||
@@ -1779,7 +1779,7 @@ gaussianGradientMagnitude(MultiArrayView<N+1, Multiband<T1>, S1> const & src,
|
||||
class T2, class S2>
|
||||
void
|
||||
symmetricGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
BlockwiseConvolutionOptions<N> opt);
|
||||
}
|
||||
\endcode
|
||||
@@ -1895,7 +1895,7 @@ template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
inline void
|
||||
symmetricGradientMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
- MultiArrayView<N, TinyVector<T2, N>, S2> dest,
|
||||
+ MultiArrayView<N, TinyVector<T2, int(N)>, S2> dest,
|
||||
ConvolutionOptions<N> opt = ConvolutionOptions<N>())
|
||||
{
|
||||
if(opt.to_point != typename MultiArrayShape<N>::type())
|
||||
@@ -2214,14 +2214,14 @@ laplacianOfGaussianMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
void
|
||||
- gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, N>, S1> const & vectorField,
|
||||
+ gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, int(N)>, S1> const & vectorField,
|
||||
MultiArrayView<N, T2, S2> divergence,
|
||||
ConvolutionOptions<N> const & opt);
|
||||
|
||||
template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
void
|
||||
- gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, N>, S1> const & vectorField,
|
||||
+ gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, int(N)>, S1> const & vectorField,
|
||||
MultiArrayView<N, T2, S2> divergence,
|
||||
double sigma,
|
||||
ConvolutionOptions<N> opt = ConvolutionOptions<N>());
|
||||
@@ -2231,7 +2231,7 @@ laplacianOfGaussianMultiArray(MultiArrayView<N, T1, S1> const & source,
|
||||
template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
void
|
||||
- gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, N>, S1> const & vectorField,
|
||||
+ gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, int(N)>, S1> const & vectorField,
|
||||
MultiArrayView<N, T2, S2> divergence,
|
||||
BlockwiseConvolutionOptions<N> const & opt);
|
||||
}
|
||||
@@ -2324,7 +2324,7 @@ gaussianDivergenceMultiArray(Iterator vectorField, Iterator vectorFieldEnd,
|
||||
template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
inline void
|
||||
-gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, N>, S1> const & vectorField,
|
||||
+gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, int(N)>, S1> const & vectorField,
|
||||
MultiArrayView<N, T2, S2> divergence,
|
||||
ConvolutionOptions<N> const & opt)
|
||||
{
|
||||
@@ -2338,7 +2338,7 @@ gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, N>, S1> const & ve
|
||||
template <unsigned int N, class T1, class S1,
|
||||
class T2, class S2>
|
||||
inline void
|
||||
-gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, N>, S1> const & vectorField,
|
||||
+gaussianDivergenceMultiArray(MultiArrayView<N, TinyVector<T1, int(N)>, S1> const & vectorField,
|
||||
MultiArrayView<N, T2, S2> divergence,
|
||||
double sigma,
|
||||
ConvolutionOptions<N> opt = ConvolutionOptions<N>())
|
Loading…
Reference in a new issue