extra/libreoffice-still to 5.4.6-2

This commit is contained in:
Kevin Mihelich 2018-04-28 15:01:24 +00:00
parent 4a0e6d3f6f
commit 3f27059e19
2 changed files with 71 additions and 1 deletions

View file

@ -21,7 +21,7 @@ pkgbase=libreoffice-still
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
_LOver=5.4.6.2
pkgver=5.4.6
pkgrel=1
pkgrel=2
arch=('x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -66,6 +66,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
poppler-0.62.patch
poppler-0.64.patch
libreoffice-still.sh libreoffice-still.csh)
noextract=(boost_1_63_0.tar.bz2
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -112,6 +113,7 @@ sha256sums=('919caa5cde10bae8d16b8549664cbf8e410c3975653463976ee2be2004448d45'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'344f88086b947d53550ef5492e4d61b1e1594067a34c6c4d8ae801ddd0a2fadb'
'944064e8f8fa18beeb348468348d910d365d8a3e36ddb76076a368bd9bd6f894'
'76f62957d0058092b11316357d9d716a62b48a53e5277426ffa87429ab5510e4'
'd24cfcb556ae1db02087c49012bbc4621f9ef7e3465ca832e1410326d260f283')
@ -137,6 +139,9 @@ prepare() {
# upstream fix to build with poppler 0.62 and later
patch -Np0 -i ${srcdir}/poppler-0.62.patch
# fix build with poppler 0.64
patch -Np1 -i ${srcdir}/poppler-0.64.patch
# fix not upstreamable pyuno paths - FS#54250
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff

View file

@ -0,0 +1,65 @@
From 42cebff14f7d486c20f04863681cc5ef4602f4eb Mon Sep 17 00:00:00 2001
From: Rene Engelhard <rene@debian.org>
Date: Tue, 24 Apr 2018 15:56:23 +0200
Subject: [PATCH] fix build with poppler 0.64
GooString became const...
Change-Id: Icc95be2e8603a4e22c6a9ac2008986bacd0bfba5
---
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 10 ++++++++++
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
2 files changed, 14 insertions(+)
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
index 48a735ba54a5..06e4faead383 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
@@ -432,6 +432,9 @@ int PDFOutDev::parseFont( long long nNewId, GfxFont* gfxFont, GfxState* state )
FontAttributes aNewFont;
int nSize = 0;
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+ const
+#endif
GooString* pFamily = gfxFont->getName();
if( pFamily )
{
@@ -728,6 +731,9 @@ void PDFOutDev::updateFont(GfxState *state)
FontAttributes aFont;
int nEmbedSize=0;
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+ const
+#endif
Ref* pID = gfxFont->getID();
// TODO(Q3): Portability problem
long long fontID = static_cast<long long>(pID->gen) << 32 | static_cast<long long>(pID->num);
@@ -918,7 +924,11 @@ void PDFOutDev::drawChar(GfxState *state, double x, double y,
printf( "\n" );
}
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+void PDFOutDev::drawString(GfxState*, const GooString* /*s*/)
+#else
void PDFOutDev::drawString(GfxState*, GooString* /*s*/)
+#endif
{
// TODO(F3): NYI
}
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
index c3367aa6ddf2..7e65f085d288 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
@@ -224,7 +224,11 @@ namespace pdfi
double dx, double dy,
double originX, double originY,
CharCode code, int nBytes, Unicode *u, int uLen) override;
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+ virtual void drawString(GfxState *state, const GooString *s) override;
+#else
virtual void drawString(GfxState *state, GooString *s) override;
+#endif
virtual void endTextObject(GfxState *state) override;
//----- image drawing