mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/calligra to 3.2.1-12
This commit is contained in:
parent
9940506efa
commit
4126ad9ef7
2 changed files with 86 additions and 9 deletions
|
@ -9,7 +9,7 @@
|
|||
pkgname=calligra
|
||||
pkgdesc="A set of applications for productivity and creative usage"
|
||||
pkgver=3.2.1
|
||||
pkgrel=11
|
||||
pkgrel=12
|
||||
arch=(x86_64)
|
||||
url='https://www.calligra-suite.org/'
|
||||
license=(FDL1.2 GPL2 LGPL)
|
||||
|
@ -27,26 +27,26 @@ optdepends=('libwpg: Corel WordPerfect Graphics image importer'
|
|||
'kirigami2: for Calligra Gemini'
|
||||
'qt5-quickcontrols: for Calligra Gemini'
|
||||
'qt5-webengine: for Calligra Gemini')
|
||||
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
|
||||
source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
calligra-openexr3.patch)
|
||||
sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147'
|
||||
'SKIP')
|
||||
'SKIP'
|
||||
'0dec106deff4cff342021da4ca4e9759f0bbe5707ea2d4ee8536eaf863409cec')
|
||||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
||||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
patch -d $pkgname-$pkgver -p1 < calligra-openexr3.patch # Fix build with OpenEXR 3
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
cmake ../$pkgbase-$pkgver \
|
||||
cmake -B build -S $pkgname-$pkgver \
|
||||
-DBUILD_TESTING=OFF
|
||||
make
|
||||
cmake --build build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
make DESTDIR="$pkgdir" install
|
||||
DESTDIR="$pkgdir" cmake --install build
|
||||
|
||||
# Remove utterly broken thumbnailers
|
||||
rm "$pkgdir"/usr/lib/qt/plugins/calligra*thumbnail.so
|
||||
|
|
77
extra/calligra/calligra-openexr3.patch
Normal file
77
extra/calligra/calligra-openexr3.patch
Normal file
|
@ -0,0 +1,77 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 8955357ff97..ea56c84bb11 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -363,8 +363,13 @@ endif ()
|
||||
## Check for OpenEXR
|
||||
##
|
||||
|
||||
-macro_optional_find_package(OpenEXR)
|
||||
-macro_bool_to_01(OPENEXR_FOUND HAVE_OPENEXR)
|
||||
+macro_optional_find_package(OpenEXR 3.0 CONFIG QUIET)
|
||||
+if(TARGET OpenEXR::OpenEXR)
|
||||
+ set(OPENEXR_LIBRARIES OpenEXR::OpenEXR)
|
||||
+else()
|
||||
+ macro_optional_find_package(OpenEXR)
|
||||
+endif()
|
||||
+macro_bool_to_01(OpenEXR_FOUND HAVE_OPENEXR)
|
||||
|
||||
##
|
||||
## Test for GNU Scientific Library
|
||||
diff --git a/libs/pigment/CMakeLists.txt b/libs/pigment/CMakeLists.txt
|
||||
index a039251e2ad..6eb6a8e70b6 100644
|
||||
--- a/libs/pigment/CMakeLists.txt
|
||||
+++ b/libs/pigment/CMakeLists.txt
|
||||
@@ -12,7 +12,7 @@ include_directories( ${PIGMENT_INCLUDES} ${Boost_INCLUDE_DIR})
|
||||
|
||||
set(FILE_OPENEXR_SOURCES)
|
||||
set(LINK_OPENEXR_LIB)
|
||||
-if(OPENEXR_FOUND)
|
||||
+if(OpenEXR_FOUND)
|
||||
include_directories(${OPENEXR_INCLUDE_DIR})
|
||||
set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES})
|
||||
add_definitions(${OPENEXR_DEFINITIONS})
|
||||
diff --git a/plugins/colorengines/lcms2/CMakeLists.txt b/plugins/colorengines/lcms2/CMakeLists.txt
|
||||
index 77807ff9702..920adbeaf87 100644
|
||||
--- a/plugins/colorengines/lcms2/CMakeLists.txt
|
||||
+++ b/plugins/colorengines/lcms2/CMakeLists.txt
|
||||
@@ -31,7 +31,7 @@ include_directories(
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/colorprofiles
|
||||
)
|
||||
|
||||
-if (HAVE_LCMS24 AND OPENEXR_FOUND)
|
||||
+if (HAVE_LCMS24 AND OpenEXR_FOUND)
|
||||
include_directories(
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/colorspaces/gray_f16
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/colorspaces/rgb_f16
|
||||
@@ -41,7 +41,7 @@ endif ()
|
||||
|
||||
set(FILE_OPENEXR_SOURCES)
|
||||
set(LINK_OPENEXR_LIB)
|
||||
-if(OPENEXR_FOUND)
|
||||
+if(OpenEXR_FOUND)
|
||||
include_directories(${OPENEXR_INCLUDE_DIR})
|
||||
set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES})
|
||||
add_definitions(${OPENEXR_DEFINITIONS})
|
||||
@@ -80,7 +80,7 @@ set ( lcmsengine_SRCS
|
||||
LcmsEnginePlugin.cpp
|
||||
)
|
||||
|
||||
-if (HAVE_LCMS24 AND OPENEXR_FOUND)
|
||||
+if (HAVE_LCMS24 AND OpenEXR_FOUND)
|
||||
set ( lcmsengine_SRCS
|
||||
${lcmsengine_SRCS}
|
||||
colorspaces/gray_f16/GrayF16ColorSpace.cpp
|
||||
diff --git a/plugins/colorengines/lcms2/tests/CMakeLists.txt b/plugins/colorengines/lcms2/tests/CMakeLists.txt
|
||||
index 2540acc834c..77bd0b3fe4a 100644
|
||||
--- a/plugins/colorengines/lcms2/tests/CMakeLists.txt
|
||||
+++ b/plugins/colorengines/lcms2/tests/CMakeLists.txt
|
||||
@@ -12,7 +12,7 @@ include_directories( ../colorspaces/cmyk_u16
|
||||
../colorprofiles
|
||||
..
|
||||
)
|
||||
-if(OPENEXR_FOUND)
|
||||
+if(OpenEXR_FOUND)
|
||||
include_directories(${OPENEXR_INCLUDE_DIR})
|
||||
endif()
|
||||
include_directories( ${PIGMENT_INCLUDES} ${LCMS2_INCLUDE_DIR} )
|
Loading…
Reference in a new issue