core/linux-raspberrypi-latest to 3.12.7

This commit is contained in:
moonman 2014-01-15 12:38:24 -07:00
parent 0903bd0f33
commit 426091d325
2 changed files with 52 additions and 5 deletions

View file

@ -4,11 +4,11 @@
buildarch=18
pkgbase=linux-raspberrypi-latest
_commit=8b2af1c65260f579a54b2826d5a364fa22dfac90
_commit=7b3d6227aa8285f7cbd5b8ec767a840b6ac42477
_srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi"
pkgver=3.12.6
pkgver=3.12.7
pkgrel=1
bfqver=v6r2
uksmver="0.1.2.2"
@ -29,9 +29,10 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
"http://kerneldedup.org/download/uksm/${uksmver}/uksm-${uksmver}-for-${uksmname}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver%.*}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver%.*}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver%.*}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver%.*}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver%.*}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver%.*}.0.patch")
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver%.*}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver%.*}.0.patch"
'aufs-sources-3.12.7-mmap-aufs3.patch')
md5sums=('0cb2f0620b1f50294025e7acca23f110'
md5sums=('c18af969521e3149fe1e224f5a43fe7a'
'd7422c17682c2a13c68f6a776b0b67fc'
'c0d63f4d42fd334bf31e4f749d4694f3'
'9335d1263fd426215db69841a380ea26'
@ -41,9 +42,17 @@ md5sums=('0cb2f0620b1f50294025e7acca23f110'
'57cbf7fa8220461f8a052ea0eb9af779'
'2d39966d14fdad1e05679232f97fdb3c'
'2965641038a5aae263722b1ba16b971b'
'9a55951ee4c3741b61e2e159631b5cf2')
'9a55951ee4c3741b61e2e159631b5cf2'
'2dd9dae61c1d0eacda41a17bd13e7f7f')
prepare() {
#Remove after this fix is in the tree
msg2 "Fixing aufs3 for kernel 3.12.7"
cd "${srcdir}/aufs3-standalone"
patch -p1 -i ../aufs-sources-3.12.7-mmap-aufs3.patch
#Evomer
cd "${srcdir}/${_srcname}"
msg "Patches:"

View file

@ -0,0 +1,38 @@
aufs3-mmap.patch | 17 ++++++-----------
1 file changed, 6 insertions(+), 11 deletions(-)
diff --git a/aufs3-mmap.patch b/aufs3-mmap.patch
index acebfa8..8682a6d 100644
--- a/aufs3-mmap.patch
+++ b/aufs3-mmap.patch
@@ -215,24 +215,19 @@ index ae4846f..3f890ee 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/fremap.c b/mm/fremap.c
-index 5bff081..246a9c7 100644
+index bbc4d66..7deee2c 100644
--- a/mm/fremap.c
+++ b/mm/fremap.c
-@@ -207,11 +207,12 @@ get_write_lock:
- */
- if (mapping_cap_account_dirty(mapping)) {
- unsigned long addr;
-- struct file *file = get_file(vma->vm_file);
-+ struct file *file = vma->vm_file;
+@@ -211,7 +211,9 @@ get_write_lock:
+ /* mmap_region may free vma; grab the info now */
+ vm_flags = vma->vm_flags;
+ vma_get_file(vma);
- addr = mmap_region(file, start, size,
- vma->vm_flags, pgoff);
-- fput(file);
+ addr = mmap_region(file, start, size, vm_flags, pgoff);
+ vma_fput(vma);
+ fput(file);
if (IS_ERR_VALUE(addr)) {
err = addr;
- } else {
diff --git a/mm/madvise.c b/mm/madvise.c
index 539eeb9..5e700b1 100644
--- a/mm/madvise.c