mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/jack2: stock
This commit is contained in:
parent
fe2a4cd594
commit
4b0bc304e5
2 changed files with 7 additions and 24 deletions
|
@ -1,11 +1,11 @@
|
|||
# $Id: PKGBUILD 92144 2013-06-01 12:22:16Z schiv $
|
||||
# $Id$
|
||||
# Maintainer: Ray Rashif <schiv@archlinux.org>
|
||||
# Contributor: Daniele Paolella <danielepaolella@email.it>
|
||||
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
|
||||
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
|
||||
# Contributor: Thomas Bahn <thomas-bahn at gmx dot net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for packed structures, arm does not like them
|
||||
|
||||
# Remove when bumped upstream
|
||||
|
||||
pkgbase=jack2
|
||||
pkgname=('jack2' 'jack2-dbus')
|
||||
|
@ -13,19 +13,17 @@ pkgname=('jack2' 'jack2-dbus')
|
|||
_tarname=jack
|
||||
pkgver=1.9.10
|
||||
pkgrel=1
|
||||
arch=('any')
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://jackaudio.org/"
|
||||
backup=(etc/security/limits.d/99-audio.conf)
|
||||
license=('GPL')
|
||||
makedepends=('python2-dbus' 'libffado' 'celt' 'opus' 'libsamplerate')
|
||||
source=("https://dl.dropbox.com/u/28869550/jack-$pkgver.tar.bz2"
|
||||
'99-audio.conf'
|
||||
'40-hpet-permissions.rules'
|
||||
'arm.patch')
|
||||
'40-hpet-permissions.rules')
|
||||
md5sums=('4aeb91d7ae0cabce98355436ed4f217a'
|
||||
'ae65b7c9ebe0fff6c918ba9d97ae342d'
|
||||
'471aad533ff56c5d3cbbf65ce32cadef'
|
||||
'6f394998180bab797fc600d4b8603759')
|
||||
'471aad533ff56c5d3cbbf65ce32cadef')
|
||||
|
||||
_isbuild() {
|
||||
printf "%s\n" ${pkgname[@]} | grep -qx $1
|
||||
|
@ -47,9 +45,6 @@ _wafconf() {
|
|||
|
||||
prepare() {
|
||||
cd "$srcdir"
|
||||
|
||||
# apply patch for ARM
|
||||
patch -d $_tarname-$pkgver -p1 -i ../arm.patch
|
||||
|
||||
# Some optimisation bug exists for current GCC
|
||||
# see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53663
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -urN a/common/jack/systemdeps.h b/common/jack/systemdeps.h
|
||||
--- a/common/jack/systemdeps.h 2014-07-18 06:28:12.000000000 -0600
|
||||
+++ b/common/jack/systemdeps.h 2014-08-24 12:21:17.163543628 -0600
|
||||
@@ -123,6 +123,8 @@
|
||||
#if defined(__arm__)
|
||||
#undef POST_PACKED_STRUCTURE
|
||||
#define POST_PACKED_STRUCTURE
|
||||
+ #undef PRE_PACKED_STRUCTURE
|
||||
+ #define PRE_PACKED_STRUCTURE
|
||||
#endif /* __arm__ */
|
||||
|
||||
#endif /* __jack_systemdeps_h__ */
|
Loading…
Reference in a new issue