mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/java8-openjdk-aarch64 to 8.u312-1
This commit is contained in:
parent
916e175dbe
commit
4b2cf7c86d
2 changed files with 92 additions and 13 deletions
|
@ -14,12 +14,12 @@ buildarch=8
|
|||
pkgname=('jre8-openjdk-headless' 'jre8-openjdk' 'jdk8-openjdk' 'openjdk8-src')
|
||||
pkgbase=java8-openjdk-aarch64
|
||||
_java_ver=8
|
||||
_jdk_update=292
|
||||
_jdk_build=10
|
||||
_jdk_update=312
|
||||
_jdk_build=07
|
||||
pkgver=${_java_ver}.u${_jdk_update}
|
||||
_repo_ver=aarch64-shenandoah-jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
_jdk8u_repo_ver=shenandoah-aarch64-shenandoah-jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
pkgrel=1.1
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
url='https://openjdk.java.net/'
|
||||
license=('custom')
|
||||
|
@ -35,16 +35,18 @@ source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
|||
jaxp-${_repo_ver}.tar.gz::${_url_src}/jaxp/archive/${_repo_ver}.tar.gz
|
||||
langtools-${_repo_ver}.tar.gz::${_url_src}/langtools/archive/${_repo_ver}.tar.gz
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz
|
||||
gcc11.patch
|
||||
8143245-pr3548.patch)
|
||||
|
||||
sha256sums=('de8735553c00b39ca33c01808d2e230723b71f93ed00469a6039aa8758711304'
|
||||
'c7f95d86adcc70faeac923fb044c7aae48280bfe6f53bfb275f1e2d0b5d93d20'
|
||||
'216c88ad55af24a8043c747a0bf0d9e6afd2bf40ad435e5b4148be790e12090d'
|
||||
'4fa0e1f51d8d0dd1181e95a68ebcd4988684d587509f19e373e64f0e8b4ed1f0'
|
||||
'44b559bb615b9a15c49ee5d61cb8feb747e90066ac0f35514e674ce5744309a8'
|
||||
'0b5ebd40b7632094c5616153a48681a75f7bd7453c26c2b0a33ea2b3b5a4a2fb'
|
||||
'a21c62943d2949033143c40092f4a1b2f2e7dbd1313954114678c90c6bafb341'
|
||||
'0cc6591e5545b9b9edfb0e8b57dbb686017603be0161861c75c1dfb8fe0a5dd9'
|
||||
sha256sums=('c8edffa803b996b0f7bc1d544a051142ee451eabad340429af225d3a0bd115c2'
|
||||
'd249ea857042ff8b9637a077ca0cd0f104dae0ac4d158b4bf8d4da463e7046a6'
|
||||
'31ccd5aa4e73282c2cd377e60915e100fa9794a3a8d07c26ba348635c59fa726'
|
||||
'df48c6c7783d1da306734ceb07db27d8c80543257006862722c67a8a58ad1d5c'
|
||||
'53ae91a7a8b75a26687717d651dba12c7c47e2284616eb85b6ac1f5db55e650e'
|
||||
'cef20893caaaa3671c142920c5b43984b20637717f74bfcf916164214f8132bf'
|
||||
'39cba6e6165b61d29a33b336887a7b101dfda4bb3cbd65b7225075364f7097e9'
|
||||
'a8f5f787a197ddba2b3d3df0ef69e6c38bc2688b6a13464c0cbc4eaec7155309'
|
||||
'e1e9452b2078c3e9b45aa73491f3f187e7a9abbc40b6a7fc9239d4e5e525569e'
|
||||
'cebae4e056c738d54833c086e9379d2054ff80887c1f4e4ad14496c7ec65f665')
|
||||
|
||||
case "${CARCH}" in
|
||||
|
@ -64,6 +66,9 @@ _nonheadless=(bin/policytool
|
|||
lib/${_JARCH}/libsplashscreen.so)
|
||||
|
||||
prepare() {
|
||||
# Fix build with C++17 (Fedora)
|
||||
patch -d hotspot-${_repo_ver} -p2 < gcc11.patch
|
||||
|
||||
cd jdk8u-${_jdk8u_repo_ver}
|
||||
for subrepo in corba hotspot jdk jaxws jaxp langtools nashorn; do
|
||||
ln -s ../${subrepo}-${_repo_ver} ${subrepo}
|
||||
|
@ -82,8 +87,8 @@ build() {
|
|||
export MAKEFLAGS=${MAKEFLAGS/-j*}
|
||||
|
||||
# Avoid optimization of HotSpot being lowered from O3 to O2
|
||||
export CFLAGS="${CFLAGS//-O2/-O3} ${CPPFLAGS} -Wno-error=deprecated-declarations -Wno-error=stringop-overflow= -Wno-error=return-type -Wno-error=cpp -fno-lifetime-dse -fno-delete-null-pointer-checks -fcommon -Wno-error=format-overflow="
|
||||
export CXXFLAGS="${CXXFLAGS} ${CPPFLAGS} -fcommon"
|
||||
export CFLAGS="${CFLAGS//-O2/-O3} -Wno-error=deprecated-declarations -Wno-error=stringop-overflow= -Wno-error=return-type -Wno-error=cpp -fno-lifetime-dse -fno-delete-null-pointer-checks -fcommon -Wno-error=format-overflow="
|
||||
export CXXFLAGS="${CXXFLAGS} -fcommon"
|
||||
|
||||
install -d -m 755 "${srcdir}/${_prefix}/"
|
||||
sh configure \
|
||||
|
|
74
extra/java8-openjdk-aarch64/gcc11.patch
Normal file
74
extra/java8-openjdk-aarch64/gcc11.patch
Normal file
|
@ -0,0 +1,74 @@
|
|||
diff --git a/openjdk/hotspot/src/share/vm/adlc/adlparse.cpp b/openjdk/hotspot/src/share/vm/adlc/adlparse.cpp
|
||||
index 31955ff7..6dcd90ac 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/adlparse.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/adlparse.cpp
|
||||
@@ -4564,7 +4564,7 @@ char *ADLParser::get_paren_expr(const char *description, bool include_location)
|
||||
// string(still inside the file buffer). Returns a pointer to the string or
|
||||
// NULL if some other token is found instead.
|
||||
char *ADLParser::get_ident_common(bool do_preproc) {
|
||||
- register char c;
|
||||
+ char c;
|
||||
char *start; // Pointer to start of token
|
||||
char *end; // Pointer to end of token
|
||||
|
||||
@@ -4762,7 +4762,7 @@ char *ADLParser::get_unique_ident(FormDict& dict, const char* nameDescription){
|
||||
// invokes a parse_err if the next token is not an integer.
|
||||
// This routine does not leave the integer null-terminated.
|
||||
int ADLParser::get_int(void) {
|
||||
- register char c;
|
||||
+ char c;
|
||||
char *start; // Pointer to start of token
|
||||
char *end; // Pointer to end of token
|
||||
int result; // Storage for integer result
|
||||
diff --git a/openjdk/hotspot/src/share/vm/adlc/arena.cpp b/openjdk/hotspot/src/share/vm/adlc/arena.cpp
|
||||
index d7e4fc6e..406187ae 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/arena.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/arena.cpp
|
||||
@@ -79,7 +79,7 @@ Arena::Arena( Arena *a )
|
||||
// Total of all Chunks in arena
|
||||
size_t Arena::used() const {
|
||||
size_t sum = _chunk->_len - (_max-_hwm); // Size leftover in this Chunk
|
||||
- register Chunk *k = _first;
|
||||
+ Chunk *k = _first;
|
||||
while( k != _chunk) { // Whilst have Chunks in a row
|
||||
sum += k->_len; // Total size of this Chunk
|
||||
k = k->_next; // Bump along to next Chunk
|
||||
@@ -93,7 +93,7 @@ void* Arena::grow( size_t x ) {
|
||||
// Get minimal required size. Either real big, or even bigger for giant objs
|
||||
size_t len = max(x, Chunk::size);
|
||||
|
||||
- register Chunk *k = _chunk; // Get filled-up chunk address
|
||||
+ Chunk *k = _chunk; // Get filled-up chunk address
|
||||
_chunk = new (len) Chunk(len);
|
||||
|
||||
if( k ) k->_next = _chunk; // Append new chunk to end of linked list
|
||||
diff --git a/openjdk/hotspot/src/share/vm/adlc/dict2.cpp b/openjdk/hotspot/src/share/vm/adlc/dict2.cpp
|
||||
index f341a2b6..2dc60b25 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/dict2.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/dict2.cpp
|
||||
@@ -283,9 +283,9 @@ void Dict::print(PrintKeyOrValue print_key, PrintKeyOrValue print_value) {
|
||||
// limited to MAXID characters in length. Experimental evidence on 150K of
|
||||
// C text shows excellent spreading of values for any size hash table.
|
||||
int hashstr(const void *t) {
|
||||
- register char c, k = 0;
|
||||
- register int sum = 0;
|
||||
- register const char *s = (const char *)t;
|
||||
+ char c, k = 0;
|
||||
+ int sum = 0;
|
||||
+ const char *s = (const char *)t;
|
||||
|
||||
while (((c = s[k]) != '\0') && (k < MAXID-1)) { // Get characters till nul
|
||||
c = (char) ((c << 1) + 1); // Characters are always odd!
|
||||
diff --git a/openjdk/hotspot/src/share/vm/adlc/main.cpp b/openjdk/hotspot/src/share/vm/adlc/main.cpp
|
||||
index 52044f12..40bcda74 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/main.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/main.cpp
|
||||
@@ -58,7 +58,7 @@ int main(int argc, char *argv[])
|
||||
|
||||
// Read command line arguments and file names
|
||||
for( int i = 1; i < argc; i++ ) { // For all arguments
|
||||
- register char *s = argv[i]; // Get option/filename
|
||||
+ char *s = argv[i]; // Get option/filename
|
||||
|
||||
if( *s++ == '-' ) { // It's a flag? (not a filename)
|
||||
if( !*s ) { // Stand-alone `-' means stdin
|
Loading…
Reference in a new issue