mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5-doc to 5.11.0-1
This commit is contained in:
parent
348220fe16
commit
52c581f85d
3 changed files with 5 additions and 85 deletions
|
@ -1,58 +0,0 @@
|
|||
From 95504f7bfc9c85d3148cec9c46084a8ab5e6ce8d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
||||
Subject: [PATCH] ARM toolchain fixes
|
||||
|
||||
---
|
||||
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
|
||||
1 file changed, 10 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
|
||||
index 86cd7dabc6..4b1e73b1ac 100644
|
||||
--- a/chromium/build/toolchain/linux/BUILD.gn
|
||||
+++ b/chromium/build/toolchain/linux/BUILD.gn
|
||||
@@ -22,15 +22,13 @@ clang_toolchain("clang_arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm64") {
|
||||
- toolprefix = "aarch64-linux-gnu-"
|
||||
-
|
||||
- cc = "${toolprefix}gcc"
|
||||
- cxx = "${toolprefix}g++"
|
||||
+ cc = "gcc"
|
||||
+ cxx = "g++"
|
||||
|
||||
- ar = "${toolprefix}ar"
|
||||
+ ar = "ar"
|
||||
ld = cxx
|
||||
- readelf = "${toolprefix}readelf"
|
||||
- nm = "${toolprefix}nm"
|
||||
+ readelf = "readelf"
|
||||
+ nm = "nm"
|
||||
|
||||
toolchain_args = {
|
||||
current_cpu = "arm64"
|
||||
@@ -40,15 +38,13 @@ gcc_toolchain("arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm") {
|
||||
- toolprefix = "arm-linux-gnueabihf-"
|
||||
-
|
||||
- cc = "${toolprefix}gcc"
|
||||
- cxx = "${toolprefix}g++"
|
||||
+ cc = "gcc"
|
||||
+ cxx = "g++"
|
||||
|
||||
- ar = "${toolprefix}ar"
|
||||
+ ar = "ar"
|
||||
ld = cxx
|
||||
- readelf = "${toolprefix}readelf"
|
||||
- nm = "${toolprefix}nm"
|
||||
+ readelf = "readelf"
|
||||
+ nm = "nm"
|
||||
|
||||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
--
|
||||
2.13.2
|
||||
|
|
@ -4,11 +4,10 @@
|
|||
# Contributor: Michael Hansen <zrax0111 gmail com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for chromium GN
|
||||
# - skip qtwebengine on v5
|
||||
|
||||
pkgname=qt5-doc
|
||||
_qtver=5.10.1
|
||||
_qtver=5.11.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=('any')
|
||||
|
@ -16,15 +15,12 @@ url='http://qt-project.org/'
|
|||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
pkgdesc='A cross-platform application and UI framework (Documentation)'
|
||||
depends=('qt5-base')
|
||||
makedepends=('qt5-tools' 'python2' 'pciutils' 'libxtst' 'libxcursor' 'libxrandr' 'libxss' 'libxcomposite' 'gperf' 'nss')
|
||||
makedepends=('qt5-tools' 'python2' 'pciutils' 'libxtst' 'libxcursor' 'libxrandr' 'libxss' 'libxcomposite'
|
||||
'gperf' 'nss' 'clang')
|
||||
groups=('qt' 'qt5')
|
||||
_pkgfqn="qt-everywhere-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfqn}.tar.xz"
|
||||
qt-no-statx.patch
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('05ffba7b811b854ed558abf2be2ddbd3bb6ddd0b60ea4b5da75d277ac15e740a'
|
||||
'5cd1d90622cc53609806a3ce0b2811b28f0e6e20eb835861de4492dddeef6e52'
|
||||
'8202b09a1caa82538a2eacd79b62b61d8661c65cdfb275560d231aa31a362b12')
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfqn}.tar.xz")
|
||||
sha256sums=('67ddb8bf33bbfd19ebc641467ccce2e57fd0b80c6082457f1f5a76e8df83c865')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -36,13 +32,6 @@ prepare() {
|
|||
cd "$srcdir"
|
||||
mkdir -p bin
|
||||
ln -s /usr/bin/python2 bin/python
|
||||
|
||||
# Don't use the statx syscall https://bugs.archlinux.org/task/56289 https://bugreports.qt.io/browse/QTBUG-64490
|
||||
cd ${_pkgfqn}/qtbase
|
||||
patch -p1 -i "$srcdir"/qt-no-statx.patch
|
||||
|
||||
cd ${srcdir}/${_pkgfqn}/qtwebengine/src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- qtbase-everywhere-src-5.10.0-beta4/src/corelib/io/qfilesystemengine_unix.cpp.orig 2017-11-14 12:10:28.156094557 +0000
|
||||
+++ qtbase-everywhere-src-5.10.0-beta4/src/corelib/io/qfilesystemengine_unix.cpp 2017-11-14 12:10:46.156136206 +0000
|
||||
@@ -95,7 +95,7 @@
|
||||
{ return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
|
||||
# endif
|
||||
|
||||
-# if !QT_CONFIG(statx) && defined(SYS_statx) && QT_HAS_INCLUDE(<linux/stat.h>)
|
||||
+# if 0
|
||||
# include <linux/stat.h>
|
||||
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
||||
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|
Loading…
Reference in a new issue