mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/libreoffice-still to 6.0.7-3
This commit is contained in:
parent
230ab2ac27
commit
53b688c2ed
2 changed files with 93 additions and 0 deletions
|
@ -67,6 +67,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
poppler-0.70.patch
|
||||
libreoffice-poppler-0.71.patch
|
||||
libreoffice-poppler-0.72.patch
|
||||
libreoffice-poppler-0.73.patch
|
||||
emfio.patch
|
||||
libreoffice-still.sh libreoffice-still.csh)
|
||||
noextract=(boost_1_65_1.tar.bz2
|
||||
|
@ -113,6 +114,7 @@ sha256sums=('b9633ccbd719fe6ad8142eceed3047eda346fca5d2962567283f350354b64c72'
|
|||
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
|
||||
'ffe1698d3db3320a9213a459e7619f4962c9792a8b256ea0fe2b7e0af1df430a'
|
||||
'dc8b5b0d1a4a1fed4f5cab048cd7ecd78630725458311bcbfe0a660c82357b49'
|
||||
'69337273a8a125be1c9e066b955306659b19066c3c82b61c62bcb62234e2e1ad'
|
||||
'8b4815788be087940750b775690b5890c4cf9e121f11006a72ccab834f212abb'
|
||||
'52e90a5a3d8d5b626caa51675b601aba508463c2b9caa98d07cfa35220fc0b22'
|
||||
'531de4133cb6ff5c841e4251fdafe69521ccd195f5933eb8c113291d3eff183a')
|
||||
|
@ -156,6 +158,8 @@ prepare() {
|
|||
patch -p1 -i ../libreoffice-poppler-0.71.patch
|
||||
# fix build with poppler 0.72
|
||||
patch -p1 -i ../libreoffice-poppler-0.72.patch
|
||||
# fix build with poppler 0.73
|
||||
patch -p1 -i ../libreoffice-poppler-0.73.patch
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
|
|
89
extra/libreoffice-still/libreoffice-poppler-0.73.patch
Normal file
89
extra/libreoffice-still/libreoffice-poppler-0.73.patch
Normal file
|
@ -0,0 +1,89 @@
|
|||
From 50d371ae08c66648d9f32f633b2245e1746e2bb6 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Stahl <Michael.Stahl@cib.de>
|
||||
Date: Mon, 14 Jan 2019 15:08:42 +0100
|
||||
Subject: [PATCH] sdext: fix build with poppler 0.73
|
||||
|
||||
... which has removed Guchar, Gushort, Guint, Gulong...
|
||||
|
||||
Change-Id: Ia54ad378031f167f6779f6ffe574b85c1e72f26d
|
||||
Reviewed-on: https://gerrit.libreoffice.org/66305
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
|
||||
---
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 4 ++--
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 6 +++++-
|
||||
sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx | 6 +++---
|
||||
3 files changed, 10 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
index dab405bc81a1..9842b9734e8d 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
@@ -298,7 +298,7 @@ static void writePpm_( OutputBuffer& o_rOutputBuf,
|
||||
o_rOutputBuf.resize(header_size);
|
||||
|
||||
// initialize stream
|
||||
- Guchar *p;
|
||||
+ unsigned char *p;
|
||||
GfxRGB rgb;
|
||||
std::unique_ptr<ImageStream> imgStr(
|
||||
new ImageStream(str,
|
||||
@@ -401,7 +401,7 @@ static void writeImage_( OutputBuffer& o_rOutputBuf,
|
||||
oneColor = { byteToCol( 0xff ), byteToCol( 0xff ), byteToCol( 0xff ) };
|
||||
if( colorMap->getColorSpace()->getMode() == csIndexed || colorMap->getColorSpace()->getMode() == csDeviceGray )
|
||||
{
|
||||
- Guchar nIndex = 0;
|
||||
+ unsigned char nIndex = 0;
|
||||
colorMap->getRGB( &nIndex, &zeroColor );
|
||||
nIndex = 1;
|
||||
colorMap->getRGB( &nIndex, &oneColor );
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
index 98d8ede6418f..cd091e5d270f 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
@@ -278,9 +278,13 @@ extern FILE* g_binary_out;
|
||||
|
||||
// note: if you ever change Output_t, please keep in mind that the current code
|
||||
// relies on it being of 8 bit size
|
||||
-typedef Guchar Output_t;
|
||||
+typedef unsigned char Output_t;
|
||||
typedef std::vector< Output_t > OutputBuffer;
|
||||
|
||||
+#if !POPPLER_CHECK_VERSION(0, 73, 0)
|
||||
+static_assert(std::is_same_v<Guchar, unsigned char>, "unexpected typedef");
|
||||
+#endif
|
||||
+
|
||||
#endif // INCLUDED_SDEXT_SOURCE_PDFIMPORT_XPDFWRAPPER_PDFIOUTDEV_GPL_HXX
|
||||
|
||||
/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx b/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
|
||||
index 4d9e3bb46b61..b5828561b7eb 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
|
||||
@@ -242,7 +242,7 @@ void PngHelper::createPng( OutputBuffer& o_rOutputBuf,
|
||||
appendIHDR( o_rOutputBuf, width, height, 8, 6 ); // RGBA image
|
||||
|
||||
// initialize stream
|
||||
- Guchar *p, *pm;
|
||||
+ unsigned char *p, *pm;
|
||||
GfxRGB rgb;
|
||||
GfxGray alpha;
|
||||
std::unique_ptr<ImageStream> imgStr(
|
||||
@@ -328,7 +328,7 @@ void PngHelper::createPng( OutputBuffer& o_rOutputBuf,
|
||||
appendIHDR( o_rOutputBuf, width, height, 8, 6 ); // RGBA image
|
||||
|
||||
// initialize stream
|
||||
- Guchar *p;
|
||||
+ unsigned char *p;
|
||||
GfxRGB rgb;
|
||||
std::unique_ptr<ImageStream> imgStr(
|
||||
new ImageStream(str,
|
||||
@@ -374,7 +374,7 @@ void PngHelper::createPng( OutputBuffer& o_rOutputBuf,
|
||||
{
|
||||
for( int x = 0; x < maskWidth; ++x )
|
||||
{
|
||||
- Guchar aPixel = 0;
|
||||
+ unsigned char aPixel = 0;
|
||||
imgStrMask->getPixel( &aPixel );
|
||||
int nIndex = (y*height/maskHeight) * (width*4+1) + // mapped line
|
||||
(x*width/maskWidth)*4 + 1 + 3 // mapped column
|
Loading…
Reference in a new issue