mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed community/lash
This commit is contained in:
parent
67b9b42820
commit
57e686d638
3 changed files with 0 additions and 91 deletions
|
@ -1,29 +0,0 @@
|
||||||
Description: Don't print the stacktrace on segfaults.
|
|
||||||
Fixes FTBFS on armel,powerpc,ia64,alpha.
|
|
||||||
Origin: Ubuntu, https://launchpad.net/bugs/647091
|
|
||||||
Bug-Ubuntu: https://launchpad.net/bugs/647091
|
|
||||||
---
|
|
||||||
lashd/sigsegv.c | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
--- lash.orig/lashd/sigsegv.c
|
|
||||||
+++ lash/lashd/sigsegv.c
|
|
||||||
@@ -90,6 +90,10 @@ static void signal_segv(int signum, sigi
|
|
||||||
lash_error("info.si_errno = %d", info->si_errno);
|
|
||||||
lash_error("info.si_code = %d (%s)", info->si_code, si_codes[info->si_code]);
|
|
||||||
lash_error("info.si_addr = %p", info->si_addr);
|
|
||||||
+
|
|
||||||
+#if defined(__arm__) || defined(__aarch64__) || defined(__powerpc__) || defined (__ia64__) || defined (__alpha__) || defined (__FreeBSD_kernel__)
|
|
||||||
+ lash_error("No stack trace");
|
|
||||||
+#else
|
|
||||||
for(i = 0; i < NGREG; i++)
|
|
||||||
lash_error("reg[%02d] = 0x" REGFORMAT, i, ucontext->uc_mcontext.gregs[i]);
|
|
||||||
|
|
||||||
@@ -143,6 +147,7 @@ static void signal_segv(int signum, sigi
|
|
||||||
lash_error("%s", strings[i]);
|
|
||||||
#endif
|
|
||||||
lash_error("End of stack trace");
|
|
||||||
+#endif
|
|
||||||
exit (-1);
|
|
||||||
}
|
|
||||||
|
|
|
@ -1,48 +0,0 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: David Runge <dave@sleepmap.de>
|
|
||||||
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
|
||||||
# Contributor: DonVla <donvla@users.sourceforge.net>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - patch to fix FTBFS on ARM
|
|
||||||
|
|
||||||
pkgname=lash
|
|
||||||
pkgver=0.6.0~rc2
|
|
||||||
_relver=0.6.0.594
|
|
||||||
pkgrel=12
|
|
||||||
pkgdesc="A session management system for JACK and ALSA"
|
|
||||||
arch=('x86_64')
|
|
||||||
url="http://lash.nongnu.org/"
|
|
||||||
license=('GPL2')
|
|
||||||
depends=('jack' 'python2')
|
|
||||||
makedepends=('gtk2')
|
|
||||||
optdepends=('gtk2: For lash_panel, lash_save_button and lash_synth')
|
|
||||||
source=("https://download.savannah.gnu.org/releases/lash/${pkgname}-${pkgver}.tar.bz2"
|
|
||||||
"fix-manual-generation.patch"
|
|
||||||
'04_disable_stacktrace.patch')
|
|
||||||
sha512sums=('704e24ccadccb469e820be5fb58dd4d953a8fc2903cd857a290267a87dda596639ec381d5cb7cdfcd715df7d98d6570e52731bddd17f8a3425edd8b699632401'
|
|
||||||
'25bb9f97bc6ff7543fea39242bc321b40cd35ba042248671e958348f9e250f810ea1e4753918aceba799b0fdd886184af57a7c497796034b999ca8d6b85e1252')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${pkgname}-${_relver}"
|
|
||||||
patch -Np0 -i "../fix-manual-generation.patch"
|
|
||||||
patch -p1 -i ../04_disable_stacktrace.patch
|
|
||||||
# Python2 fixes
|
|
||||||
export PYTHON="python2"
|
|
||||||
sed -i "s#env python#&2#" clients/lash_control
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "${pkgname}-${_relver}"
|
|
||||||
export LDFLAGS="-ldl -lm"
|
|
||||||
./configure --prefix=/usr
|
|
||||||
make
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd "${pkgname}-${_relver}"
|
|
||||||
make DESTDIR="${pkgdir}" install
|
|
||||||
# docs
|
|
||||||
install -vDm 644 {AUTHORS,ChangeLog,NEWS,README,TODO} \
|
|
||||||
-t "${pkgdir}/usr/share/doc/${pkgname}/"
|
|
||||||
}
|
|
|
@ -1,14 +0,0 @@
|
||||||
--- docs/Makefile.in.orig 2008-11-09 22:45:28.000000000 +0100
|
|
||||||
+++ docs/Makefile.in 2011-07-23 17:12:26.000000000 +0200
|
|
||||||
@@ -527,9 +527,9 @@
|
|
||||||
@HAVE_TEXI2HTML_TRUE@ mkdir -lash-manual-html-split; \
|
|
||||||
@HAVE_TEXI2HTML_TRUE@ fi
|
|
||||||
@HAVE_TEXI2HTML_TRUE@ cd lash-manual-html-one-page && \
|
|
||||||
-@HAVE_TEXI2HTML_TRUE@ texi2html --number ../$(top_srcdir)/docs/lash-manual.texi
|
|
||||||
+@HAVE_TEXI2HTML_TRUE@ texi2html --number-footnotes --number-sections ../$(top_srcdir)/docs/lash-manual.texi
|
|
||||||
@HAVE_TEXI2HTML_TRUE@ cd lash-manual-html-split && \
|
|
||||||
-@HAVE_TEXI2HTML_TRUE@ texi2html --number --split=chapter ../$(top_srcdir)/docs/lash-manual.texi
|
|
||||||
+@HAVE_TEXI2HTML_TRUE@ texi2html --number-footnotes --number-sections --split=chapter ../$(top_srcdir)/docs/lash-manual.texi
|
|
||||||
@HAVE_TEXI2HTML_TRUE@ touch html-manual-stamp
|
|
||||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
||||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
Loading…
Reference in a new issue