mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/kodi-rpi-git to 20.x.59845.f9c3a6e04c-1
This commit is contained in:
parent
9af5591f71
commit
5bd255bdd4
2 changed files with 10 additions and 10 deletions
|
@ -1,6 +1,6 @@
|
||||||
From 5e0e966976fe08314b8a28eb53583563986f8c9d Mon Sep 17 00:00:00 2001
|
From b06428ed9945f818095f1b8e725850b2d3b8551b Mon Sep 17 00:00:00 2001
|
||||||
From: graysky <graysky@archlinux.us>
|
From: graysky <graysky@archlinux.us>
|
||||||
Date: Mon, 7 Mar 2022 18:05:02 -0500
|
Date: Thu, 10 Mar 2022 17:36:13 -0500
|
||||||
Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
|
Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
|
||||||
|
|
||||||
Get build system to patch ffmpeg source removing the -march= flag
|
Get build system to patch ffmpeg source removing the -march= flag
|
||||||
|
@ -10,17 +10,17 @@ Get build system to patch ffmpeg source removing the -march= flag
|
||||||
1 file changed, 1 insertion(+)
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
||||||
index ee600d0d83..5a7fd2e70f 100644
|
index 6b957f760e..296ed09968 100644
|
||||||
--- a/cmake/modules/FindFFMPEG.cmake
|
--- a/cmake/modules/FindFFMPEG.cmake
|
||||||
+++ b/cmake/modules/FindFFMPEG.cmake
|
+++ b/cmake/modules/FindFFMPEG.cmake
|
||||||
@@ -89,6 +89,7 @@ macro(buildFFMPEG)
|
@@ -97,6 +97,7 @@ macro(buildFFMPEG)
|
||||||
${CMAKE_SOURCE_DIR}/cmake/modules/FindGnuTLS.cmake
|
${CMAKE_SOURCE_DIR}/cmake/modules/FindGnuTLS.cmake
|
||||||
<SOURCE_DIR> &&
|
<SOURCE_DIR> &&
|
||||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
||||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
||||||
echo "########################################## patched ffmpeg ##############################"
|
echo "########################################## patched ffmpeg ##############################")
|
||||||
)
|
|
||||||
|
|
||||||
|
BUILD_DEP_TARGET()
|
||||||
--
|
--
|
||||||
2.35.1
|
2.35.1
|
||||||
|
|
||||||
|
|
|
@ -13,8 +13,8 @@ pkgname=(
|
||||||
'kodi-rpi-git-eventclients' 'kodi-rpi-git-tools-texturepacker' 'kodi-rpi-git-dev'
|
'kodi-rpi-git-eventclients' 'kodi-rpi-git-tools-texturepacker' 'kodi-rpi-git-dev'
|
||||||
)
|
)
|
||||||
|
|
||||||
_commitnumber=59836
|
_commitnumber=59845
|
||||||
_commit=343136d090c0e5bc0262f08093aaac5e33948e82
|
_commit=f9c3a6e04c3f8cd5002128a74c3441dd58c9455c
|
||||||
|
|
||||||
# set this to anything to build with clang
|
# set this to anything to build with clang
|
||||||
# recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
|
# recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
|
||||||
|
@ -81,7 +81,7 @@ noextract=(
|
||||||
"flatbuffers-$_flatbuffers_version.tar.gz"
|
"flatbuffers-$_flatbuffers_version.tar.gz"
|
||||||
"libudfread-$_libudfread_version.tar.gz"
|
"libudfread-$_libudfread_version.tar.gz"
|
||||||
)
|
)
|
||||||
sha256sums=('029f25dc0f6b230239653a218fca7e12cdbbdd017af4698abe45aaeb0d1e5116'
|
sha256sums=('401a600a73a6d606e0b2caefb9f9007901dc9660b123b0a0f2d904fa541546d6'
|
||||||
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
|
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
|
||||||
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
|
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
|
||||||
'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
|
'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
|
||||||
|
@ -95,7 +95,7 @@ sha256sums=('029f25dc0f6b230239653a218fca7e12cdbbdd017af4698abe45aaeb0d1e5116'
|
||||||
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
|
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
|
||||||
'23f105f914f3372afa432251b69c7601e50c22d1a88168185105ee859005f5cd'
|
'23f105f914f3372afa432251b69c7601e50c22d1a88168185105ee859005f5cd'
|
||||||
'16d6c79ff3a3d3653f21d77a36326a0335c8cec49a9c06dbc2de0ed143e50a9f'
|
'16d6c79ff3a3d3653f21d77a36326a0335c8cec49a9c06dbc2de0ed143e50a9f'
|
||||||
'c187f597020bad875d893bfe4cf094ee31de824bdc4af9b6ce9d7700487a3c8c')
|
'7b9ac44b29462418a3e4bb038995960e5122840048a6f592a7d6a39bbc74a4a6')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||||
|
|
Loading…
Reference in a new issue