mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/gnuradio to 3.7.11-2
This commit is contained in:
parent
491d4c2eb0
commit
5f6dfcb421
2 changed files with 77 additions and 3 deletions
|
@ -9,7 +9,7 @@
|
|||
pkgbase=gnuradio
|
||||
pkgname=(gnuradio gnuradio-companion)
|
||||
pkgver=3.7.11
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="General purpose DSP and SDR toolkit. With drivers for usrp and fcd."
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://gnuradio.org"
|
||||
|
@ -34,11 +34,12 @@ makedepends=('boost' 'cmake' 'python2-lxml' 'python2-cheetah' 'glu' 'swig'
|
|||
#source=("http://s3-dist.gnuradio.org/gnuradio-$pkgver.tar.gz"
|
||||
source=("http://gnuradio.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz"
|
||||
"http://gnuradio.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz.asc"
|
||||
"21-fcd.rules")
|
||||
"21-fcd.rules" "gnuradio-gcc7.patch")
|
||||
validpgpkeys=('B90DDFAC56989BF62262EB812987C77CBB8ED9B2') # GNU Radio Project
|
||||
md5sums=('7b7b871237ae6fc109d203f78c4654ef'
|
||||
'SKIP'
|
||||
'465e12c454c6a22ebec9849181af7bdc')
|
||||
'465e12c454c6a22ebec9849181af7bdc'
|
||||
'c510104fa2ad9852a683c265c42ae1da')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgbase-$pkgver"
|
||||
|
@ -48,6 +49,8 @@ prepare() {
|
|||
$(find ./ -name 'gnuradio-companion' -o -name 'flow_graph.tmpl')
|
||||
sed -i -e "s|#![ ]*/usr/bin/env /usr/bin/python$|#!/usr/bin/env python2|" \
|
||||
$(find ./ -name '*.py')
|
||||
# fix build with GCC 7 (Fedora)
|
||||
patch -p1 -i ../gnuradio-gcc7.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
71
community/gnuradio/gnuradio-gcc7.patch
Normal file
71
community/gnuradio/gnuradio-gcc7.patch
Normal file
|
@ -0,0 +1,71 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 0ac65fe..71378aa 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -62,7 +62,7 @@ ENDIF()
|
||||
# set(CMAKE_CXX_STANDARD 98)
|
||||
|
||||
IF(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
||||
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
||||
+# SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
||||
ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
|
||||
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
||||
ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
|
||||
@@ -72,7 +72,7 @@ ELSE()
|
||||
ENDIF()
|
||||
|
||||
IF(CMAKE_C_COMPILER_ID STREQUAL "GNU")
|
||||
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
||||
+# SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
||||
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
|
||||
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
||||
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "MSVC")
|
||||
diff --git a/gnuradio-runtime/lib/math/qa_fxpt.h b/gnuradio-runtime/lib/math/qa_fxpt.h
|
||||
index 58a6f02..6020e47 100644
|
||||
--- a/gnuradio-runtime/lib/math/qa_fxpt.h
|
||||
+++ b/gnuradio-runtime/lib/math/qa_fxpt.h
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include <cppunit/extensions/HelperMacros.h>
|
||||
#include <cppunit/TestCase.h>
|
||||
+#include <memory>
|
||||
|
||||
class qa_fxpt : public CppUnit::TestCase
|
||||
{
|
||||
diff --git a/gnuradio-runtime/lib/math/qa_fxpt_nco.h b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
||||
index 1b2cdae..1755904 100644
|
||||
--- a/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
||||
+++ b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include <cppunit/extensions/HelperMacros.h>
|
||||
#include <cppunit/TestCase.h>
|
||||
+#include <memory>
|
||||
|
||||
class qa_fxpt_nco : public CppUnit::TestCase
|
||||
{
|
||||
diff --git a/gnuradio-runtime/lib/math/qa_fxpt_vco.h b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
||||
index 72693f3..76e0b6d 100644
|
||||
--- a/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
||||
+++ b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include <cppunit/extensions/HelperMacros.h>
|
||||
#include <cppunit/TestCase.h>
|
||||
+#include <memory>
|
||||
|
||||
class qa_fxpt_vco : public CppUnit::TestCase
|
||||
{
|
||||
diff --git a/gr-fec/include/gnuradio/fec/polar_decoder_common.h b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
||||
index 13b25ea..8a3d65d 100644
|
||||
--- a/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
||||
+++ b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
||||
@@ -68,7 +68,7 @@ namespace gr {
|
||||
bool set_frame_size(unsigned int frame_size){return false;};
|
||||
|
||||
private:
|
||||
- static BOOST_CONSTEXPR_OR_CONST float D_LLR_FACTOR;
|
||||
+ static const float D_LLR_FACTOR;
|
||||
unsigned int d_frozen_bit_counter;
|
||||
|
||||
protected:
|
Loading…
Reference in a new issue