extra/krita to 4.2.9-1

This commit is contained in:
Kevin Mihelich 2020-03-23 16:10:21 +00:00
parent 27095373bd
commit 63f54e4236
2 changed files with 30 additions and 11 deletions

View file

@ -4,35 +4,32 @@
# - remove makedepend on vc
pkgname=krita
pkgver=4.2.8.2
pkgrel=2
pkgver=4.2.9
pkgrel=1
pkgdesc="Edit and paint images"
arch=(x86_64)
url="https://krita.org"
license=(GPL3)
depends=(kitemviews kitemmodels ki18n kcompletion karchive kguiaddons kcrash qt5-svg qt5-multimedia quazip
gsl libraw exiv2 openexr fftw curl boost-libs giflib hicolor-icon-theme desktop-file-utils)
gsl libraw exiv2 openexr fftw boost-libs giflib hicolor-icon-theme)
makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 opencolorio python-pyqt5 libheif
qt5-tools sip python-sip)
optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio: for the LUT docker'
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter')
conflicts=(calligra-krita krita-l10n)
replaces=(calligra-krita krita-l10n)
source=("https://download.kde.org/stable/krita/${pkgver%.*}/$pkgname-$pkgver.tar.gz"{,.sig}
kdebug-410867.patch::"https://invent.kde.org/kde/krita/commit/ca07d42c.patch"
kdebug-414672.patch::"https://invent.kde.org/kde/krita/commit/2dc2ed5f.patch")
sha256sums=('80f741fa11245ff20a99f529f5f62def17791f3ad2c9aec5c5cf5440ae1fcba7'
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig}
krita-pyqt5-sip5.patch)
sha256sums=('9f85bb81eaf4976af57352a482af1fdb86f338051a991f6f43976e0b65956da8'
'SKIP'
'cfc9c7b2accbb730be3d9e2c92e5d501d2e3465841c97efae84602987e8cae3b'
'181802a9273133a654f6aac2b1760b91beffa8e631b2aa162b5b10d342d5f712')
'ab2f33843d8cad31bc13e0eca7dc732cdbfed054924f25ed61102c0d0971c1d8')
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
cd $pkgname-$pkgver
patch -p1 -i ../kdebug-410867.patch # Fix crash on close
patch -p1 -i ../kdebug-414672.patch # Fix crash on transform tool
patch -p1 -i ../krita-pyqt5-sip5.patch # Fix sip include dir when PyQt5 is compiled with SIP 5
}
build() {

View file

@ -0,0 +1,22 @@
diff --git a/cmake/modules/FindPyQt5.py b/cmake/modules/FindPyQt5.py
index 5849f40868..a42ba6c624 100644
--- a/cmake/modules/FindPyQt5.py
+++ b/cmake/modules/FindPyQt5.py
@@ -2,7 +2,7 @@
# Redistribution and use is allowed according to the terms of the BSD license.
# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
-import sys
+import sys, site
import os
try:
@@ -41,7 +41,7 @@ except ValueError:
pass
# FIXME This next line is just a little bit too crude.
-pyqt_sip_dir = os.path.join(sys.prefix, "share", "sip", "PyQt5")
+pyqt_sip_dir = os.path.join(site.getsitepackages()[0], "PyQt5", "bindings")
print("pyqt_sip_dir:%s" % pyqt_sip_dir)
print("pyqt_sip_flags:%s" % PyQt5.QtCore.PYQT_CONFIGURATION["sip_flags"])