mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/x265: update ARM patch
This commit is contained in:
parent
7bf3cd21d3
commit
65ec19ee49
2 changed files with 13 additions and 13 deletions
|
@ -17,7 +17,7 @@ url='https://bitbucket.org/multicoreware/x265'
|
|||
source=($url/get/$pkgver.tar.bz2
|
||||
arm.patch)
|
||||
md5sums=('0cc0b0189cf9ed7422aad98633c6de8f'
|
||||
'9e90fdd64e551be7b76922606d0c8210')
|
||||
'84b4f95a14040711d298c1abfc4e373a')
|
||||
|
||||
prepare() {
|
||||
cd multicoreware-x265-*
|
||||
|
|
|
@ -1,29 +1,29 @@
|
|||
diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
||||
--- a/source/CMakeLists.txt 2014-03-03 14:43:00.000000000 -0700
|
||||
+++ b/source/CMakeLists.txt 2014-03-29 22:29:24.983771019 -0600
|
||||
@@ -37,10 +37,18 @@
|
||||
--- a/source/CMakeLists.txt 2014-04-03 00:00:44.000000000 -0600
|
||||
+++ b/source/CMakeLists.txt 2014-04-10 07:32:36.022010974 -0600
|
||||
@@ -39,10 +39,18 @@
|
||||
set(X64 1)
|
||||
add_definitions(-DX86_64=1)
|
||||
endif()
|
||||
+elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "armv5.*")
|
||||
+elseif(${SYSPROC} STREQUAL "armv5.*")
|
||||
+ message(STATUS "Detected ARMV5 system processor")
|
||||
+ set(ARMV5 1)
|
||||
+ add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=0 -DHAVE_NEON=0)
|
||||
elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "armv6l")
|
||||
elseif(${SYSPROC} STREQUAL "armv6l")
|
||||
- message(STATUS "Detected ARM system processor")
|
||||
- set(ARM 1)
|
||||
- add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=1)
|
||||
+ message(STATUS "Detected ARMV6 system processor")
|
||||
+ set(ARMV6 1)
|
||||
+ add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=1 -DHAVE_NEON=0)
|
||||
+elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "armv7l")
|
||||
+elseif(${SYSPROC} STREQUAL "armv7l")
|
||||
+ message(STATUS "Detected ARMV7 system processor")
|
||||
+ set(ARMV7 1)
|
||||
+ add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=1 -DHAVE_NEON=0)
|
||||
else()
|
||||
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
|
||||
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
|
||||
@@ -121,8 +129,8 @@
|
||||
@@ -122,8 +130,8 @@
|
||||
if(X86 AND NOT X64)
|
||||
add_definitions(-march=i686)
|
||||
endif()
|
||||
|
@ -35,9 +35,9 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
|||
endif(GCC)
|
||||
|
||||
diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
|
||||
--- a/source/common/cpu.cpp 2014-03-03 14:43:00.000000000 -0700
|
||||
+++ b/source/common/cpu.cpp 2014-03-29 22:50:44.303843187 -0600
|
||||
@@ -40,7 +40,7 @@
|
||||
--- a/source/common/cpu.cpp 2014-04-03 00:00:44.000000000 -0600
|
||||
+++ b/source/common/cpu.cpp 2014-04-10 07:28:51.937129997 -0600
|
||||
@@ -37,7 +37,7 @@
|
||||
#include <machine/cpu.h>
|
||||
#endif
|
||||
|
||||
|
@ -46,7 +46,7 @@ diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
|
|||
#include <signal.h>
|
||||
#include <setjmp.h>
|
||||
static sigjmp_buf jmpbuf;
|
||||
@@ -343,7 +343,6 @@
|
||||
@@ -340,7 +340,6 @@
|
||||
}
|
||||
|
||||
canjump = 1;
|
||||
|
@ -54,7 +54,7 @@ diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
|
|||
canjump = 0;
|
||||
signal(SIGILL, oldsig);
|
||||
#endif // if !HAVE_NEON
|
||||
@@ -359,7 +358,7 @@
|
||||
@@ -356,7 +355,7 @@
|
||||
// which may result in incorrect detection and the counters stuck enabled.
|
||||
// right now Apple does not seem to support performance counters for this test
|
||||
#ifndef __MACH__
|
||||
|
|
Loading…
Reference in a new issue