mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/chromium to 78.0.3904.97-2
This commit is contained in:
parent
f84415cb99
commit
680714a079
2 changed files with 70 additions and 1 deletions
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=78.0.3904.97
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('x86_64')
|
||||
|
@ -37,6 +37,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
add-missing-include-for-unique_ptr.patch
|
||||
dns_util-make-DohUpgradeEntry-non-const.patch
|
||||
fix-shutdown-crash-in-ProfileManager.patch
|
||||
icu65.patch
|
||||
chromium-system-icu.patch
|
||||
chromium-system-zlib.patch
|
||||
fix-spammy-unique-font-matching-log.patch
|
||||
|
@ -48,6 +49,7 @@ sha256sums=('d1f49ab9f4f973536166f587114553c21a29977bdc350dd407a89d34e22a9d07'
|
|||
'49052e8aa630c4aa57bf46823edc32b7b309493275163c3bb3f9fd390c73356e'
|
||||
'69694ab12a5ced389916c0c5e8c7bdc191544f576b134ddfb2fe9d4ed9ec4494'
|
||||
'4f81612c28957987f7344d8ce2b95a4a63136a8319c9751819436b11c62df057'
|
||||
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
|
||||
'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
|
||||
'eb67eda4945a89c3b90473fa8dc20637511ca4dcb58879a8ed6bf403700ca9c8'
|
||||
'6fbffe59b886195b92c9a55137cef83021c16593f49714acb20023633e3ebb19'
|
||||
|
@ -122,6 +124,9 @@ prepare() {
|
|||
# https://crbug.com/1005244
|
||||
patch -Np1 -i ../fix-shutdown-crash-in-ProfileManager.patch
|
||||
|
||||
# https://crbug.com/1014272
|
||||
patch -Np1 -i ../icu65.patch
|
||||
|
||||
# Fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-system-icu.patch
|
||||
patch -Np1 -i ../chromium-system-zlib.patch
|
||||
|
|
64
extra/chromium/icu65.patch
Normal file
64
extra/chromium/icu65.patch
Normal file
|
@ -0,0 +1,64 @@
|
|||
From 5679c3c191ed62b62d8db22f1657a296ee9bfe8e Mon Sep 17 00:00:00 2001
|
||||
From: Frank Tang <ftang@chromium.org>
|
||||
Date: Wed, 30 Oct 2019 22:49:47 +0000
|
||||
Subject: [PATCH] Update ICU to 65.1 from 64 and fix broken tests
|
||||
|
||||
ICU 65-1 release note
|
||||
http://site.icu-project.org/download/65
|
||||
|
||||
CLDR 36 release blog
|
||||
http://blog.unicode.org/2019/10/unicode-cldr-version-36-languagelocale.html
|
||||
|
||||
Most of the test expectation change is due to CLDR 36 update
|
||||
of Grapheme Cluster for Indic languages
|
||||
See the following for related changes in ICU 65.1 in this area:
|
||||
https://unicode-org.atlassian.net/browse/CLDR-10994
|
||||
https://unicode-org.atlassian.net/browse/ICU-13637
|
||||
https://github.com/unicode-org/cldr/blob/master/common/properties/segments/readme.txt
|
||||
|
||||
Bug: chromium:1014272, chromium:1017047
|
||||
Change-Id: I9fc6d4620bf2a4c189940d06d8c79893502db3dd
|
||||
Cq-Include-Trybots: luci.chromium.try:linux_layout_tests_layout_ng_disabled
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1866059
|
||||
Reviewed-by: Jungshik Shin <jshin@chromium.org>
|
||||
Reviewed-by: Doug Turner <dougt@chromium.org>
|
||||
Reviewed-by: Michael Wasserman <msw@chromium.org>
|
||||
Reviewed-by: Kent Tamura <tkent@chromium.org>
|
||||
Reviewed-by: Trent Apted <tapted@chromium.org>
|
||||
Reviewed-by: Mason Freed <masonfreed@chromium.org>
|
||||
Commit-Queue: Frank Tang <ftang@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#711027}
|
||||
---
|
||||
third_party/blink/renderer/core/dom/document.cc | 2 +-
|
||||
ui/gfx/render_text_harfbuzz.cc | 5 ++++-
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/third_party/blink/renderer/core/dom/document.cc b/third_party/blink/renderer/core/dom/document.cc
|
||||
index 511aac29086..f188cf548a6 100644
|
||||
--- a/third_party/blink/renderer/core/dom/document.cc
|
||||
+++ b/third_party/blink/renderer/core/dom/document.cc
|
||||
@@ -6191,7 +6191,7 @@ static ParseQualifiedNameResult ParseQualifiedNameInternal(
|
||||
|
||||
for (unsigned i = 0; i < length;) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (c == ':') {
|
||||
if (saw_colon)
|
||||
return ParseQualifiedNameResult(kQNMultipleColons);
|
||||
diff --git a/ui/gfx/render_text_harfbuzz.cc b/ui/gfx/render_text_harfbuzz.cc
|
||||
index 50e86af6b97..0339ff3ff8e 100644
|
||||
--- a/ui/gfx/render_text_harfbuzz.cc
|
||||
+++ b/ui/gfx/render_text_harfbuzz.cc
|
||||
@@ -971,7 +971,10 @@ RangeF TextRunHarfBuzz::GetGraphemeBounds(RenderTextHarfBuzz* render_text,
|
||||
++total;
|
||||
}
|
||||
}
|
||||
- DCHECK_GT(total, 0);
|
||||
+ // With ICU 65.1, DCHECK_GT() below fails.
|
||||
+ // See https://crbug.com/1017047 for more details.
|
||||
+ //
|
||||
+ // DCHECK_GT(total, 0);
|
||||
|
||||
// It's possible for |text_index| to point to a diacritical mark, at the end
|
||||
// of |chars|. In this case all the grapheme boundaries come before it. Just
|
Loading…
Reference in a new issue