mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/qt to 4.8.2-2
This commit is contained in:
parent
3421e590f4
commit
6f964249b2
2 changed files with 19 additions and 3 deletions
|
@ -9,13 +9,14 @@
|
|||
# - make -j1 for v5, -j2 for v7 (pandaboard builder)
|
||||
# - added -fno-strict-volatile-bitfields to CXXFLAGS to fix ARM bug
|
||||
# - disabled gcc47.patch since we're not on that yet
|
||||
# - no libfbclient/ibase, issues building on ARM
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgbase=qt
|
||||
pkgname=('qt' 'qt-private-headers')
|
||||
pkgver=4.8.2
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL')
|
||||
|
@ -28,13 +29,15 @@ _pkgfqn="${pkgbase}-everywhere-opensource-src-${pkgver}"
|
|||
source=("http://releases.qt-project.org/qt4/source/${_pkgfqn}.tar.gz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'qtconfig.desktop'
|
||||
'improve-cups-support.patch')
|
||||
'improve-cups-support.patch'
|
||||
'fix-assistant-crash.patch')
|
||||
md5sums=('3c1146ddf56247e16782f96910a8423b'
|
||||
'fc211414130ab2764132e7370f8e5caa'
|
||||
'85179f5e0437514f8639957e1d8baf62'
|
||||
'f11852b97583610f3dbb669ebc3e21bc'
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd'
|
||||
'b9fb6b953cec428d59c026b1ef370e86')
|
||||
'b9fb6b953cec428d59c026b1ef370e86'
|
||||
'e9c11e4606b7f55ae405e3e76f863dc1')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}"/${_pkgfqn}
|
||||
|
@ -42,6 +45,8 @@ build() {
|
|||
# (FS#28381) (KDEBUG#180051)
|
||||
patch -p1 -i "${srcdir}"/improve-cups-support.patch
|
||||
|
||||
patch -p1 -i "${srcdir}"/fix-assistant-crash.patch
|
||||
|
||||
export QT4DIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||
|
||||
|
|
11
extra/qt/fix-assistant-crash.patch
Normal file
11
extra/qt/fix-assistant-crash.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp 2012-06-26 17:37:47.334536023 +0000
|
||||
+++ qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp~ 2012-06-26 17:37:08.531487286 +0000
|
||||
@@ -944,8 +944,7 @@
|
||||
if (helpEngine.usesAppFont())
|
||||
font = helpEngine.appFont();
|
||||
|
||||
- const QWidgetList &widgets = qApp->allWidgets();
|
||||
- foreach (QWidget* widget, widgets)
|
||||
+ foreach (QWidget* widget, QApplication::allWidgets())
|
||||
widget->setFont(font);
|
||||
}
|
Loading…
Reference in a new issue