mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added core/linux-armv5-rc
This commit is contained in:
parent
d8d40b0575
commit
7470b8b27d
8 changed files with 8678 additions and 0 deletions
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1,54 @@
|
|||
From a68d3fb3c79b2860a230532c178ed7685db535f7 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Nelson <robertcnelson@gmail.com>
|
||||
Date: Mon, 12 Aug 2013 11:27:22 -0500
|
||||
Subject: [PATCH 2/2] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
|
||||
|
||||
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
||||
---
|
||||
arch/arm/boot/dts/imx23-olinuxino.dts | 25 +++++++++++++++++++++++++
|
||||
1 file changed, 25 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
index fc766ae..4a96623 100644
|
||||
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
@@ -88,6 +88,25 @@
|
||||
usbphy0: usbphy@8007c000 {
|
||||
status = "okay";
|
||||
};
|
||||
+
|
||||
+ codec: mxs-builtin-codec {
|
||||
+ compatible = "fsl,mxs-builtin-codec";
|
||||
+ reg = <0x80048000 0x2000>, <0x8004c000 0x2000>,
|
||||
+ <0x8005c000 0x2000>;
|
||||
+ reg-names = "audioout", "audioin", "rtc";
|
||||
+ clocks = <&clks 31>;
|
||||
+ clock-names = "filt";
|
||||
+ };
|
||||
+
|
||||
+ platform_dai: mxs-builtin-cpu-dai {
|
||||
+ compatible = "fsl,mxs-builtin-cpu-dai";
|
||||
+ reg = <0x80048000 0x2000>, <0x8004c000 0x2000>,
|
||||
+ <0x8005c000 0x2000>;
|
||||
+ reg-names = "audioout", "audioin", "rtc";
|
||||
+ interrupts = <8 6 4>;
|
||||
+ dmas = <&dma_apbx 0>, <&dma_apbx 1>;
|
||||
+ dma-names = "rx", "tx";
|
||||
+ };
|
||||
};
|
||||
};
|
||||
|
||||
@@ -122,4 +141,10 @@
|
||||
gpios = <&gpio2 1 1>;
|
||||
};
|
||||
};
|
||||
+
|
||||
+ mxs-builtin-audio {
|
||||
+ compatible = "fsl,mxs-builtin-audio";
|
||||
+ audio-codec = <&codec>;
|
||||
+ cpu-dai = <&platform_dai>;
|
||||
+ };
|
||||
};
|
||||
--
|
||||
1.7.10.4
|
||||
|
126
core/linux-armv5-rc/0001-imx23-I2C-fixes.patch
Normal file
126
core/linux-armv5-rc/0001-imx23-I2C-fixes.patch
Normal file
|
@ -0,0 +1,126 @@
|
|||
From 96f0b63db8df533cc619212f41e134cdf112b853 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 18 Jun 2014 21:55:51 -0600
|
||||
Subject: [PATCH] imx23 I2C fixes
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/imx23-olinuxino.dts | 35 ++++++++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/imx23.dtsi | 41 ++++++++++++++++++++++++++++++++++-
|
||||
2 files changed, 75 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
index 7e6eef2..5caef60 100644
|
||||
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
@@ -73,6 +73,25 @@
|
||||
status = "okay";
|
||||
};
|
||||
|
||||
+ i2c0: i2c@80058000 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&i2c1_pins_a>;
|
||||
+ status = "okay";
|
||||
+
|
||||
+ sgtl5000: codec@0a {
|
||||
+ compatible = "fsl,sgtl5000";
|
||||
+ reg = <0x0a>;
|
||||
+ VDDA-supply = <®_3p3v>;
|
||||
+ VDDIO-supply = <®_3p3v>;
|
||||
+ };
|
||||
+
|
||||
+ at24@51 {
|
||||
+ compatible = "at24,24c32";
|
||||
+ pagesize = <32>;
|
||||
+ reg = <0x51>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
duart: serial@80070000 {
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&duart_pins_a>;
|
||||
@@ -113,6 +132,22 @@
|
||||
startup-delay-us = <300>; /* LAN9215 requires a POR of 200us minimum */
|
||||
gpio = <&gpio0 17 0>;
|
||||
};
|
||||
+
|
||||
+ reg_3p3v: 3p3v {
|
||||
+ compatible = "regulator-fixed";
|
||||
+ regulator-name = "3P3V";
|
||||
+ regulator-min-microvolt = <3300000>;
|
||||
+ regulator-max-microvolt = <3300000>;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sound {
|
||||
+ compatible = "fsl,imx28-evk-sgtl5000",
|
||||
+ "fsl,mxs-audio-sgtl5000";
|
||||
+ model = "imx28-evk-sgtl5000";
|
||||
+ saif-controllers = <&saif0 &saif1>;
|
||||
+ audio-codec = <&sgtl5000>;
|
||||
};
|
||||
|
||||
leds {
|
||||
diff --git a/arch/arm/boot/dts/imx23.dtsi b/arch/arm/boot/dts/imx23.dtsi
|
||||
index bbcfb5a..54b6a83 100644
|
||||
--- a/arch/arm/boot/dts/imx23.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx23.dtsi
|
||||
@@ -308,6 +308,39 @@
|
||||
fsl,voltage = <MXS_VOLTAGE_HIGH>;
|
||||
fsl,pull-up = <MXS_PULL_ENABLE>;
|
||||
};
|
||||
+
|
||||
+ i2c0_pins_a: i2c0@0 {
|
||||
+ reg = <0>;
|
||||
+ fsl,pinmux-ids = <
|
||||
+ 0x01e0 /* MX23_PAD_I2C_SCL__I2C_SCL */
|
||||
+ 0x01f0 /* MX23_PAD_I2C_SDA__I2C_SDA */
|
||||
+ >;
|
||||
+ fsl,drive-strength = <1>;
|
||||
+ fsl,voltage = <1>;
|
||||
+ fsl,pull-up = <1>;
|
||||
+ };
|
||||
+
|
||||
+ i2c1_pins_a: i2c1@0 {
|
||||
+ reg = <0>;
|
||||
+ fsl,pinmux-ids = <
|
||||
+ 0x1171 /* MX23_PAD_LCD_ENABLE__I2C_SCL */
|
||||
+ 0x1181 /* MX23_PAD_LCD_HSYNC__I2C_SDA */
|
||||
+ >;
|
||||
+ fsl,drive-strength = <1>;
|
||||
+ fsl,voltage = <1>;
|
||||
+ fsl,pull-up = <1>;
|
||||
+ };
|
||||
+
|
||||
+ i2c2_pins_a: i2c2@0 {
|
||||
+ reg = <0>;
|
||||
+ fsl,pinmux-ids = <
|
||||
+ 0x2031 /* MX23_PAD_SSP1_DATA1__I2C_SCL */
|
||||
+ 0x2041 /* MX23_PAD_SSP1_DATA2__I2C_SDA */
|
||||
+ >;
|
||||
+ fsl,drive-strength = <1>;
|
||||
+ fsl,voltage = <1>;
|
||||
+ fsl,pull-up = <1>;
|
||||
+ };
|
||||
};
|
||||
|
||||
digctl@8001c000 {
|
||||
@@ -444,8 +477,14 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
- i2c@80058000 {
|
||||
+ i2c0: i2c@80058000 {
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+ compatible = "fsl,imx23-i2c";
|
||||
reg = <0x80058000 0x2000>;
|
||||
+ interrupts = <27 26>;
|
||||
+ clock-frequency = <100000>;
|
||||
+ fsl,i2c-dma-channel = <3>;
|
||||
dmas = <&dma_apbx 3>;
|
||||
dma-names = "rx-tx";
|
||||
status = "disabled";
|
||||
--
|
||||
1.9.0
|
||||
|
|
@ -0,0 +1,173 @@
|
|||
From 2edc71fc799c4fb2661a4b69767f2e28a096954b Mon Sep 17 00:00:00 2001
|
||||
From: Michal Ulianko <info@itserve.cz>
|
||||
Date: Tue, 30 Jul 2013 14:28:17 +0200
|
||||
Subject: [PATCH 2/2] Added DTS with mxs-builtin-* entries for testing the
|
||||
audio driver.
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/imx23-audio.dts | 153 +++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 153 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx23-audio.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx23-audio.dts b/arch/arm/boot/dts/imx23-audio.dts
|
||||
new file mode 100644
|
||||
index 0000000..1555896
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx23-audio.dts
|
||||
@@ -0,0 +1,153 @@
|
||||
+/*
|
||||
+ * Copyright 2012 Freescale Semiconductor, Inc.
|
||||
+ *
|
||||
+ * Author: Fabio Estevam <fabio.estevam@freescale.com>
|
||||
+ *
|
||||
+ * The code contained herein is licensed under the GNU General Public
|
||||
+ * License. You may obtain a copy of the GNU General Public License
|
||||
+ * Version 2 or later at the following locations:
|
||||
+ *
|
||||
+ * http://www.opensource.org/licenses/gpl-license.html
|
||||
+ * http://www.gnu.org/copyleft/gpl.html
|
||||
+ */
|
||||
+
|
||||
+/*
|
||||
+ * DTS for testing mxs-builtin-audio.
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+/include/ "imx23.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "i.MX23 Olinuxino Low Cost Board";
|
||||
+ compatible = "olimex,imx23-olinuxino", "fsl,imx23";
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x40000000 0x04000000>;
|
||||
+ };
|
||||
+
|
||||
+ apb@80000000 {
|
||||
+ apbh@80000000 {
|
||||
+ ssp0: ssp@80010000 {
|
||||
+ compatible = "fsl,imx23-mmc";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&mmc0_4bit_pins_a &mmc0_pins_fixup>;
|
||||
+ bus-width = <4>;
|
||||
+ broken-cd;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ pinctrl@80018000 {
|
||||
+ pinctrl-names = "default";
|
||||
+ // TODO Can gpio_keys use pinctrl?
|
||||
+ pinctrl-0 = <&hog_pins_a &btns_pins_a>;
|
||||
+
|
||||
+ hog_pins_a: hog@0 {
|
||||
+ reg = <0>;
|
||||
+ fsl,pinmux-ids = <
|
||||
+ 0x0113 /* MX23_PAD_GPMI_ALE__GPIO_0_17 */
|
||||
+ >;
|
||||
+ fsl,drive-strength = <0>;
|
||||
+ fsl,voltage = <1>;
|
||||
+ fsl,pull-up = <0>;
|
||||
+ };
|
||||
+
|
||||
+ led_pin_gpio2_1: led_gpio2_1@0 {
|
||||
+ reg = <0>;
|
||||
+ fsl,pinmux-ids = <
|
||||
+ 0x2013 /* MX23_PAD_SSP1_DETECT__GPIO_2_1 */
|
||||
+ >;
|
||||
+ fsl,drive-strength = <0>;
|
||||
+ fsl,voltage = <1>;
|
||||
+ fsl,pull-up = <0>;
|
||||
+ };
|
||||
+
|
||||
+ btns_pins_a: btns@0 {
|
||||
+ reg = <0>;
|
||||
+ fsl,pinmux-ids = <
|
||||
+ 0x0033 /* MX23_PAD_GPMI_D03__GPIO_0_3 */
|
||||
+ 0x0043 /* MX23_PAD_GPMI_D04__GPIO_0_4 */
|
||||
+ 0x0053 /* MX23_PAD_GPMI_D05__GPIO_0_5 */
|
||||
+ 0x0063 /* MX23_PAD_GPMI_D06__GPIO_0_6 */
|
||||
+ 0x0073 /* MX23_PAD_GPMI_D07__GPIO_0_7 */
|
||||
+ >;
|
||||
+ fsl,voltage = <1>;
|
||||
+ fsl,pull-up = <1>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ ssp1: ssp@80034000 {
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+ compatible = "fsl,imx23-spi";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&spi2_pins_a>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ apbx@80040000 {
|
||||
+ duart: serial@80070000 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&duart_pins_a>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ auart0: serial@8006c000 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&auart0_2pins_a>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ usbphy0: usbphy@8007c000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ codec: mxs-builtin-codec {
|
||||
+ compatible = "fsl,mxs-builtin-codec";
|
||||
+ reg = <0x80048000 0x2000>, <0x8004c000 0x2000>,
|
||||
+ <0x8005c000 0x2000>;
|
||||
+ reg-names = "audioout", "audioin", "rtc";
|
||||
+ clocks = <&clks 31>;
|
||||
+ clock-names = "filt";
|
||||
+ };
|
||||
+
|
||||
+ platform_dai: mxs-builtin-cpu-dai {
|
||||
+ compatible = "fsl,mxs-builtin-cpu-dai";
|
||||
+ reg = <0x80048000 0x2000>, <0x8004c000 0x2000>,
|
||||
+ <0x8005c000 0x2000>;
|
||||
+ reg-names = "audioout", "audioin", "rtc";
|
||||
+ interrupts = <8 6 4>;
|
||||
+ dmas = <&dma_apbx 0>, <&dma_apbx 1>;
|
||||
+ dma-names = "rx", "tx";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ ahb@80080000 {
|
||||
+ usb0: usb@80080000 {
|
||||
+ vbus-supply = <®_usb0_vbus>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ regulators {
|
||||
+ compatible = "simple-bus";
|
||||
+
|
||||
+ reg_usb0_vbus: usb0_vbus {
|
||||
+ compatible = "regulator-fixed";
|
||||
+ regulator-name = "usb0_vbus";
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ enable-active-high;
|
||||
+ startup-delay-us = <300>; /* LAN9215 requires a POR of 200us minimum */
|
||||
+ gpio = <&gpio0 17 0>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ mxs-builtin-audio {
|
||||
+ compatible = "fsl,mxs-builtin-audio";
|
||||
+ audio-codec = <&codec>;
|
||||
+ cpu-dai = <&platform_dai>;
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
1.7.10.4
|
||||
|
265
core/linux-armv5-rc/PKGBUILD
Normal file
265
core/linux-armv5-rc/PKGBUILD
Normal file
|
@ -0,0 +1,265 @@
|
|||
# ARMv5 based platforms
|
||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
buildarch=2
|
||||
|
||||
pkgbase=linux-armv5-rc
|
||||
_srcname=linux-3.16-rc1
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv5 based platforms"
|
||||
pkgver=3.16.0
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v3.x/testing/${_srcname}.tar.xz"
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
||||
'0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch'
|
||||
'0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
|
||||
'0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
|
||||
'0001-imx23-I2C-fixes.patch'
|
||||
'archlinuxarm.patch'
|
||||
'config')
|
||||
md5sums=('661a618eb12bc437dc47aa59163e6667'
|
||||
'SKIP'
|
||||
'5add8cc8a029016f05270f73c7863931'
|
||||
'3a1e689563354c2f9f2d2764e1baa334'
|
||||
'a88071c80e1c2b22637894ae148c74b8'
|
||||
'e64077ce856769fc3af2a15ae95d8310'
|
||||
'e319a8e1a596a39a8951fc6454664b15'
|
||||
'22887aa80347177e105f06b511003ecc')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch
|
||||
git apply ../0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
|
||||
git apply ../0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
|
||||
git apply ../0001-imx23-I2C-fixes.patch
|
||||
patch -p1 -i ../archlinuxarm.patch
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||
cp -ru "${srcdir}/aufs3-standalone/fs" .
|
||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/linux
|
||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/uapi/linux
|
||||
|
||||
git apply ../aufs3-standalone/aufs3-kbuild.patch
|
||||
git apply ../aufs3-standalone/aufs3-base.patch
|
||||
git apply ../aufs3-standalone/aufs3-mmap.patch
|
||||
git apply ../aufs3-standalone/aufs3-standalone.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
||||
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
||||
sed -i '2iexit 0' scripts/depmod.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# get kernel version
|
||||
make prepare
|
||||
|
||||
# load configuration
|
||||
# Configure the kernel. Replace the line below with one of your choice.
|
||||
#make menuconfig # CLI menu for configuration
|
||||
#make nconfig # new CLI menu for configuration
|
||||
#make xconfig # X-based configuration
|
||||
#make oldconfig # using old config from previous kernel version
|
||||
# ... or manually edit .config
|
||||
|
||||
# Copy back our configuration (use with new kernel version)
|
||||
#cp ./.config ../${pkgbase}.config
|
||||
|
||||
####################
|
||||
# stop here
|
||||
# this is useful to configure the kernel
|
||||
#msg "Stopping build"
|
||||
#return 1
|
||||
####################
|
||||
|
||||
#yes "" | make config
|
||||
|
||||
# build!
|
||||
make ${MAKEFLAGS} zImage modules dtbs
|
||||
}
|
||||
|
||||
_package() {
|
||||
pkgdesc="The Linux Kernel and modules - ${_desc}"
|
||||
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
provides=('kernel26' 'linux=${pkgver}' 'aufs_friendly')
|
||||
conflicts=('linux')
|
||||
install=${pkgname}.install
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
KARCH=arm
|
||||
|
||||
# get kernel version
|
||||
_kernver="$(make kernelrelease)"
|
||||
_basekernel=${_kernver%%-*}
|
||||
_basekernel=${_basekernel%.*}
|
||||
|
||||
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot/dtbs}
|
||||
make INSTALL_MOD_PATH="${pkgdir}" modules_install
|
||||
cp arch/$KARCH/boot/zImage "${pkgdir}/boot/zImage"
|
||||
cp arch/$KARCH/boot/dts/*.dtb "${pkgdir}/boot/dtbs"
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
||||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||
-i "${startdir}/${pkgname}.install"
|
||||
|
||||
# remove build and source links
|
||||
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
rm -rf "${pkgdir}/lib/firmware"
|
||||
# gzip -9 all modules to save 100MB of space
|
||||
find "${pkgdir}" -name '*.ko' |xargs -P 2 -n 1 gzip -9
|
||||
# make room for external modules
|
||||
ln -s "../extramodules-${_basekernel}-${_kernelname:-ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
|
||||
# add real version for building modules and running depmod from post_install/upgrade
|
||||
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}"
|
||||
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}/version"
|
||||
|
||||
# Now we call depmod...
|
||||
depmod -b "$pkgdir" -F System.map "$_kernver"
|
||||
|
||||
# move module tree /lib -> /usr/lib
|
||||
mkdir -p "${pkgdir}/usr"
|
||||
mv "$pkgdir/lib" "$pkgdir/usr"
|
||||
}
|
||||
|
||||
_package-headers() {
|
||||
pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
|
||||
provides=('linux-headers=${pkgver}')
|
||||
conflicts=('linux-headers')
|
||||
|
||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
install -D -m644 Makefile \
|
||||
"${pkgdir}/usr/lib/modules/${_kernver}/build/Makefile"
|
||||
install -D -m644 kernel/Makefile \
|
||||
"${pkgdir}/usr/lib/modules/${_kernver}/build/kernel/Makefile"
|
||||
install -D -m644 .config \
|
||||
"${pkgdir}/usr/lib/modules/${_kernver}/build/.config"
|
||||
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/include"
|
||||
|
||||
for i in acpi asm-generic config crypto drm generated keys linux math-emu \
|
||||
media net pcmcia scsi sound trace uapi video xen; do
|
||||
cp -a include/${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/include/"
|
||||
done
|
||||
|
||||
# copy arch includes for external modules
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
||||
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-kirkwood
|
||||
cp -a arch/$KARCH/mach-kirkwood/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-kirkwood/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/plat-orion
|
||||
cp -a arch/$KARCH/plat-orion/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/plat-orion/
|
||||
|
||||
# copy files necessary for later builds, like nvidia and vmware
|
||||
cp Module.symvers "${pkgdir}/usr/lib/modules/${_kernver}/build"
|
||||
cp -a scripts "${pkgdir}/usr/lib/modules/${_kernver}/build"
|
||||
|
||||
# fix permissions on scripts dir
|
||||
chmod og-w -R "${pkgdir}/usr/lib/modules/${_kernver}/build/scripts"
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/.tmp_versions"
|
||||
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/arch/${KARCH}/kernel"
|
||||
|
||||
cp arch/${KARCH}/Makefile "${pkgdir}/usr/lib/modules/${_kernver}/build/arch/${KARCH}/"
|
||||
|
||||
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/lib/modules/${_kernver}/build/arch/${KARCH}/kernel/"
|
||||
|
||||
# add docbook makefile
|
||||
install -D -m644 Documentation/DocBook/Makefile \
|
||||
"${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
|
||||
|
||||
# add dm headers
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/md"
|
||||
cp drivers/md/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/md"
|
||||
|
||||
# add inotify.h
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/include/linux"
|
||||
cp include/linux/inotify.h "${pkgdir}/usr/lib/modules/${_kernver}/build/include/linux/"
|
||||
|
||||
# add wireless headers
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/net/mac80211/"
|
||||
cp net/mac80211/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/net/mac80211/"
|
||||
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/9912
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-core"
|
||||
cp drivers/media/dvb-core/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-core/"
|
||||
# and...
|
||||
# http://bugs.archlinux.org/task/11194
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/include/config/dvb/"
|
||||
cp include/config/dvb/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/include/config/dvb/"
|
||||
|
||||
# add dvb headers for http://mcentral.de/hg/~mrec/em28xx-new
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/13146
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-frontends/"
|
||||
cp drivers/media/dvb-frontends/lgdt330x.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-frontends/"
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/"
|
||||
cp drivers/media/i2c/msp3400-driver.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/"
|
||||
|
||||
# add dvb headers
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/20402
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/usb/dvb-usb"
|
||||
cp drivers/media/usb/dvb-usb/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/usb/dvb-usb/"
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-frontends"
|
||||
cp drivers/media/dvb-frontends/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-frontends/"
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/tuners"
|
||||
cp drivers/media/tuners/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/tuners/"
|
||||
|
||||
# add xfs and shmem for aufs building
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs"
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/mm"
|
||||
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs/xfs_sb.h"
|
||||
|
||||
# copy in Kconfig files
|
||||
for i in $(find . -name "Kconfig*"); do
|
||||
mkdir -p "${pkgdir}"/usr/lib/modules/${_kernver}/build/`echo ${i} | sed 's|/Kconfig.*||'`
|
||||
cp ${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/${i}"
|
||||
done
|
||||
|
||||
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
|
||||
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
|
||||
|
||||
# strip scripts directory
|
||||
find "${pkgdir}/usr/lib/modules/${_kernver}/build/scripts" -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||
case "$(file -bi "${binary}")" in
|
||||
*application/x-sharedlib*) # Libraries (.so)
|
||||
/usr/bin/strip ${STRIP_SHARED} "${binary}";;
|
||||
*application/x-archive*) # Libraries (.a)
|
||||
/usr/bin/strip ${STRIP_STATIC} "${binary}";;
|
||||
*application/x-executable*) # Binaries
|
||||
/usr/bin/strip ${STRIP_BINARIES} "${binary}";;
|
||||
esac
|
||||
done
|
||||
|
||||
# remove unneeded architectures
|
||||
rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,x86,xtensa}
|
||||
}
|
||||
|
||||
pkgname=("${pkgbase}" "${pkgbase}-headers")
|
||||
for _p in ${pkgname[@]}; do
|
||||
eval "package_${_p}() {
|
||||
_package${_p#${pkgbase}}
|
||||
}"
|
||||
done
|
80
core/linux-armv5-rc/archlinuxarm.patch
Normal file
80
core/linux-armv5-rc/archlinuxarm.patch
Normal file
|
@ -0,0 +1,80 @@
|
|||
diff -ruN a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
|
||||
--- a/drivers/ata/sata_mv.c 2013-11-03 16:41:51.000000000 -0700
|
||||
+++ b/drivers/ata/sata_mv.c 2013-11-08 01:39:48.868014917 -0700
|
||||
@@ -71,6 +71,7 @@
|
||||
#include <scsi/scsi_cmnd.h>
|
||||
#include <scsi/scsi_device.h>
|
||||
#include <linux/libata.h>
|
||||
+#include <linux/leds.h>
|
||||
|
||||
#define DRV_NAME "sata_mv"
|
||||
#define DRV_VERSION "1.28"
|
||||
@@ -1161,6 +1162,8 @@
|
||||
{
|
||||
int want_ncq = (protocol == ATA_PROT_NCQ);
|
||||
|
||||
+ ledtrig_ide_activity();
|
||||
+
|
||||
if (pp->pp_flags & MV_PP_FLAG_EDMA_EN) {
|
||||
int using_ncq = ((pp->pp_flags & MV_PP_FLAG_NCQ_EN) != 0);
|
||||
if (want_ncq != using_ncq)
|
||||
diff -ruN a/drivers/leds/trigger/Kconfig b/drivers/leds/trigger/Kconfig
|
||||
--- a/drivers/leds/trigger/Kconfig 2013-11-03 16:41:51.000000000 -0700
|
||||
+++ b/drivers/leds/trigger/Kconfig 2013-11-08 01:39:48.958018410 -0700
|
||||
@@ -35,7 +35,6 @@
|
||||
|
||||
config LEDS_TRIGGER_IDE_DISK
|
||||
bool "LED IDE Disk Trigger"
|
||||
- depends on IDE_GD_ATA
|
||||
depends on LEDS_TRIGGERS
|
||||
help
|
||||
This allows LEDs to be controlled by IDE disk activity.
|
||||
diff -ruN a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
|
||||
--- a/drivers/mmc/core/core.c 2013-11-03 16:41:51.000000000 -0700
|
||||
+++ b/drivers/mmc/core/core.c 2013-11-08 01:39:49.008020351 -0700
|
||||
@@ -805,7 +805,7 @@
|
||||
*/
|
||||
limit_us = 3000000;
|
||||
else
|
||||
- limit_us = 100000;
|
||||
+ limit_us = 200000;
|
||||
|
||||
/*
|
||||
* SDHC cards always use these fixed values.
|
||||
diff -ruN a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
|
||||
--- a/drivers/mmc/core/sd.c 2013-11-03 16:41:51.000000000 -0700
|
||||
+++ b/drivers/mmc/core/sd.c 2013-11-08 01:39:49.008020351 -0700
|
||||
@@ -358,6 +358,15 @@
|
||||
return -ENOMEM;
|
||||
}
|
||||
|
||||
+ /*
|
||||
+ * Some SDHC cards, notably those with a Sandisk SD controller
|
||||
+ * (also found in Kingston products) need a bit of slack
|
||||
+ * before successfully handling the SWITCH command. So far,
|
||||
+ * cards identifying themselves as "SD04G" and "SD08G" are
|
||||
+ * affected
|
||||
+ */
|
||||
+ udelay(100);
|
||||
+
|
||||
err = mmc_sd_switch(card, 1, 0, 1, status);
|
||||
if (err)
|
||||
goto out;
|
||||
diff -ruN a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
--- a/drivers/mmc/host/mvsdio.c 2013-11-03 16:41:51.000000000 -0700
|
||||
+++ b/drivers/mmc/host/mvsdio.c 2013-11-08 01:39:49.028021127 -0700
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <linux/of_irq.h>
|
||||
#include <linux/mmc/host.h>
|
||||
#include <linux/mmc/slot-gpio.h>
|
||||
+#include <linux/mmc/sd.h>
|
||||
#include <linux/pinctrl/consumer.h>
|
||||
|
||||
#include <asm/sizes.h>
|
||||
@@ -148,6 +149,7 @@
|
||||
|
||||
dev_dbg(host->dev, "cmd %d (hw state 0x%04x)\n",
|
||||
cmd->opcode, mvsd_read(MVSD_HW_STATE));
|
||||
+ if (cmd->opcode == SD_SWITCH) mdelay(1); /* Voodoo */
|
||||
|
||||
cmdreg = MVSD_CMD_INDEX(cmd->opcode);
|
5071
core/linux-armv5-rc/config
Normal file
5071
core/linux-armv5-rc/config
Normal file
File diff suppressed because it is too large
Load diff
14
core/linux-armv5-rc/linux-armv5-rc.install
Normal file
14
core/linux-armv5-rc/linux-armv5-rc.install
Normal file
|
@ -0,0 +1,14 @@
|
|||
KERNEL_NAME=-armv5-rc
|
||||
KERNEL_VERSION=3.16.0-1-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
echo ">>> Updating module dependencies. Please wait ..."
|
||||
depmod ${KERNEL_VERSION}
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
# updating module dependencies
|
||||
echo ">>> Updating module dependencies. Please wait ..."
|
||||
depmod ${KERNEL_VERSION}
|
||||
}
|
Loading…
Reference in a new issue