core/linux to 3.0.6-1, excuse the mess, kernel.org is still down

This commit is contained in:
Kevin Mihelich 2011-10-18 18:47:58 -04:00
parent b5515b1a47
commit 78e3984cdb
3 changed files with 49 additions and 36 deletions

View file

@ -9,32 +9,28 @@ pkgname=('linux' 'linux-headers')
# pkgname=linux-custom # Build kernel with a different name
_kernelname=${pkgname#linux}
_basekernel=3.0
pkgver=${_basekernel}.3
pkgver=${_basekernel}.6
pkgrel=1
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage')
options=('!strip')
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-${_basekernel}.tar.bz2"
"ftp://ftp.kernel.org/pub/linux/kernel/v3.0/patch-${pkgver}.bz2"
source=(#"ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-${_basekernel}.tar.bz2"
#"ftp://ftp.kernel.org/pub/linux/kernel/v3.0/patch-${pkgver}.bz2"
"linux-3.0.6.tar.gz"
'archlinuxarm.patch'
'config'
'change-default-console-loglevel.patch'
# patches exporting symbols for the aufs module
aufs3-base.patch aufs3-standalone.patch)
md5sums=('398e95866794def22b12dfbc15ce89c0'
'1757786b9a9ffbd48ad9642199ff5bd7'
'77e8e011485c2061616214d07356132e'
'a6753f9fa6ca818b87ea817106e01566'
'9d3c56a4b999c8bfbd4018089a62f662'
'b9248a75a3fe415a18d4730887daa339'
'd961e5dc52b4e4f98a6268b6dc4340fa')
'change-default-console-loglevel.patch')
md5sums=('6d0affbfe07192a2f323d41bb707ba68'
'2b2b459c34e55e68fc53ac30766ed139'
'f9e6664ddda72f2bb4932267780d1959'
'9d3c56a4b999c8bfbd4018089a62f662')
build() {
cd "${srcdir}/linux-${_basekernel}"
patch -p1 -i "${srcdir}/patch-${pkgver}"
#patch -p1 -i "${srcdir}/patch-${pkgver}"
# Add Arch Linux ARM patch for ARMv5te plug computers
patch -Np1 -i ${srcdir}/archlinuxarm.patch
@ -47,10 +43,6 @@ build() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
msg 'AUFS3 patches'
patch -p1 -i "${srcdir}/aufs3-base.patch"
patch -p1 -i "${srcdir}/aufs3-standalone.patch"
cat "${srcdir}/config" > ./.config
# remove the sublevel from Makefile
@ -91,7 +83,7 @@ package_linux() {
groups=('base')
depends=('coreutils' 'linux-firmware' 'module-init-tools>=3.16' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
provides=('kernel26' 'aufs_friendly')
provides=('kernel26')
conflicts=('kernel26')
replaces=('kernel26')
backup=("etc/mkinitcpio.d/${pkgname}.preset")

View file

@ -1,6 +1,6 @@
diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/dockstar-setup.c
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2011-05-18 22:06:34.000000000 -0600
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2011-07-01 13:18:36.000000000 -0600
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2011-10-03 14:25:23.000000000 -0600
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2011-10-17 15:00:50.000000000 -0600
@@ -19,7 +19,6 @@
#include <asm/mach-types.h>
#include <asm/mach/arch.h>
@ -54,7 +54,7 @@ diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/doc
diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/goflexhome-setup.c
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2011-07-01 13:25:34.000000000 -0600
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2011-10-17 15:00:50.000000000 -0600
@@ -0,0 +1,123 @@
+/*
+ * arch/arm/mach-kirkwood/goflexhome-setup.c
@ -181,7 +181,7 @@ diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/g
+
diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/goflexnet-setup.c
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2011-07-01 13:25:49.000000000 -0600
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2011-10-17 15:00:50.000000000 -0600
@@ -0,0 +1,176 @@
+/*
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
@ -360,8 +360,8 @@ diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/go
+MACHINE_END
+
diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/guruplug-setup.c
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2011-05-18 22:06:34.000000000 -0600
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2011-07-01 13:18:36.000000000 -0600
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2011-10-03 14:25:23.000000000 -0600
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2011-10-17 15:00:50.000000000 -0600
@@ -57,22 +57,24 @@
static struct gpio_led guruplug_led_pins[] = {
@ -392,8 +392,8 @@ diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/gur
.active_low = 1,
},
diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
--- a/arch/arm/mach-kirkwood/Kconfig 2011-05-18 22:06:34.000000000 -0600
+++ b/arch/arm/mach-kirkwood/Kconfig 2011-07-01 13:18:36.000000000 -0600
--- a/arch/arm/mach-kirkwood/Kconfig 2011-10-03 14:25:23.000000000 -0600
+++ b/arch/arm/mach-kirkwood/Kconfig 2011-10-17 15:00:50.000000000 -0600
@@ -64,6 +64,18 @@
Say 'Y' here if you want your kernel to support the
Seagate FreeAgent DockStar.
@ -414,8 +414,8 @@ diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
bool
diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
--- a/arch/arm/mach-kirkwood/Makefile 2011-05-18 22:06:34.000000000 -0600
+++ b/arch/arm/mach-kirkwood/Makefile 2011-07-01 13:18:36.000000000 -0600
--- a/arch/arm/mach-kirkwood/Makefile 2011-10-03 14:25:23.000000000 -0600
+++ b/arch/arm/mach-kirkwood/Makefile 2011-10-17 15:00:50.000000000 -0600
@@ -8,6 +8,8 @@
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
@ -426,8 +426,8 @@ diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-05-18 22:06:34.000000000 -0600
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-07-01 13:22:51.000000000 -0600
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-10-03 14:25:23.000000000 -0600
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-10-17 15:00:50.000000000 -0600
@@ -64,7 +64,13 @@
.active_low = 1,
},

View file

@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
# Linux/arm 3.0.3 Kernel Configuration
# Linux/arm 3.0.6 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@ -877,7 +877,7 @@ CONFIG_VLSI_FIR=m
CONFIG_MCS_FIR=m
CONFIG_BT=m
CONFIG_BT_L2CAP=y
# CONFIG_BT_SCO is not set
CONFIG_BT_SCO=y
CONFIG_BT_RFCOMM=m
CONFIG_BT_RFCOMM_TTY=y
CONFIG_BT_BNEP=m
@ -2351,7 +2351,24 @@ CONFIG_VIDEO_TLG2300=m
# CONFIG_USB_STKWEBCAM is not set
# CONFIG_USB_S2255 is not set
# CONFIG_V4L_MEM2MEM_DRIVERS is not set
# CONFIG_RADIO_ADAPTERS is not set
CONFIG_RADIO_ADAPTERS=y
# CONFIG_RADIO_MAXIRADIO is not set
# CONFIG_I2C_SI4713 is not set
# CONFIG_RADIO_SI4713 is not set
CONFIG_USB_DSBR=m
CONFIG_RADIO_SI470X=y
CONFIG_USB_SI470X=m
# CONFIG_I2C_SI470X is not set
CONFIG_USB_MR800=m
# CONFIG_RADIO_TEA5764 is not set
# CONFIG_RADIO_SAA7706H is not set
# CONFIG_RADIO_TEF6862 is not set
# CONFIG_RADIO_WL1273 is not set
#
# Texas Instruments WL128x FM driver (ST based)
#
# CONFIG_RADIO_WL128X is not set
CONFIG_DVB_MAX_ADAPTERS=8
# CONFIG_DVB_DYNAMIC_MINORS is not set
CONFIG_DVB_CAPTURE_DRIVERS=y
@ -3253,11 +3270,15 @@ CONFIG_SQUASHFS_LZO=y
CONFIG_SQUASHFS_EMBEDDED=y
CONFIG_SQUASHFS_FRAGMENT_CACHE_SIZE=3
# CONFIG_VXFS_FS is not set
# CONFIG_MINIX_FS is not set
CONFIG_MINIX_FS=m
# CONFIG_OMFS_FS is not set
# CONFIG_HPFS_FS is not set
# CONFIG_QNX4FS_FS is not set
# CONFIG_ROMFS_FS is not set
CONFIG_ROMFS_FS=m
CONFIG_ROMFS_BACKED_BY_BLOCK=y
# CONFIG_ROMFS_BACKED_BY_MTD is not set
# CONFIG_ROMFS_BACKED_BY_BOTH is not set
CONFIG_ROMFS_ON_BLOCK=y
# CONFIG_PSTORE is not set
# CONFIG_SYSV_FS is not set
# CONFIG_UFS_FS is not set