mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/firefox fix
This commit is contained in:
parent
fa8c5fffd9
commit
7acc154b76
3 changed files with 135 additions and 4 deletions
|
@ -2,7 +2,9 @@
|
|||
# Maintainer : Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
|
||||
|
||||
# remove when bumped upstream
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - mozconfig changes for ARM
|
||||
# - patch to remove NEON/SIMD checks from configure
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=39.0.3
|
||||
|
@ -28,13 +30,15 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
firefox.desktop
|
||||
firefox-install-dir.patch
|
||||
vendor.js
|
||||
firefox-fixed-loading-icon.png)
|
||||
firefox-fixed-loading-icon.png
|
||||
no-neon.patch)
|
||||
sha256sums=('8c16df4ce94b30f1308655f9ed6ac3e76aaa2eb3643739b9263226c086d0177b'
|
||||
'4704798b46be00712a87443be8ed6184dfb5d337e8cc74dbe029c0a25a47add6'
|
||||
'11a16ea86073de5a6e7c1c665c954f0cf184932abbb55fc906ba1671e5b7162e'
|
||||
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
|
||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
||||
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
|
||||
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213')
|
||||
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
|
||||
'6d0c1c9ca28b20d206ce24ca84f4d4e3f5d062a2e9cb7445fcb6c2cfea959b4a')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -81,6 +85,8 @@ prepare() {
|
|||
# https://bugzilla.mozilla.org/show_bug.cgi?id=841734
|
||||
cp "$srcdir/firefox-fixed-loading-icon.png" \
|
||||
browser/themes/linux/tabbrowser/loading.png
|
||||
|
||||
patch -Np0 -i ../no-neon.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -6,6 +6,8 @@ ac_add_options --enable-pie
|
|||
|
||||
ac_add_options --enable-official-branding
|
||||
|
||||
ac_add_options --disable-neon
|
||||
|
||||
# System libraries
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
|
|
123
extra/firefox/no-neon.patch
Normal file
123
extra/firefox/no-neon.patch
Normal file
|
@ -0,0 +1,123 @@
|
|||
--- configure.orig 2015-08-07 06:32:41.988366320 -0600
|
||||
+++ configure 2015-08-08 18:23:31.316475879 -0600
|
||||
@@ -7137,14 +7137,7 @@
|
||||
rm -f conftest*
|
||||
echo "$ac_t"""$result"" 1>&6
|
||||
if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
+ HAVE_ARM_SIMD=
|
||||
fi
|
||||
|
||||
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
@@ -7176,27 +7169,13 @@
|
||||
rm -f conftest*
|
||||
echo "$ac_t"""$result"" 1>&6
|
||||
if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
+ HAVE_ARM_NEON=
|
||||
|
||||
- HAVE_ARM_NEON=1
|
||||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
+ if test -n "$ARM_ARCH"; then
|
||||
if test "$ARM_ARCH" -lt 7; then
|
||||
BUILD_ARM_NEON=
|
||||
else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
+ BUILD_ARM_NEON=
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
--- js/src/configure.orig 2015-08-07 06:33:02.108365042 -0600
|
||||
+++ js/src/configure 2015-08-08 18:24:00.676479200 -0600
|
||||
@@ -6267,14 +6267,7 @@
|
||||
rm -f conftest*
|
||||
echo "$ac_t"""$result"" 1>&6
|
||||
if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
+ HAVE_ARM_SIMD=
|
||||
fi
|
||||
|
||||
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
@@ -6306,27 +6299,13 @@
|
||||
rm -f conftest*
|
||||
echo "$ac_t"""$result"" 1>&6
|
||||
if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_NEON=1
|
||||
+ HAVE_ARM_NEON=
|
||||
|
||||
if test -n "$ARM_ARCH"; then
|
||||
if test "$ARM_ARCH" -lt 7; then
|
||||
BUILD_ARM_NEON=
|
||||
else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
+ BUILD_ARM_NEON=
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
--- mozglue/build/arm.h.orig 2015-08-08 18:21:03.686458059 -0600
|
||||
+++ mozglue/build/arm.h 2015-08-08 18:21:16.781459724 -0600
|
||||
@@ -69,12 +69,6 @@
|
||||
# endif
|
||||
# endif
|
||||
|
||||
- // When using -mfpu=neon, gcc generates neon instructions.
|
||||
-
|
||||
-# if defined(__ARM_NEON__)
|
||||
-# define MOZILLA_PRESUME_NEON 1
|
||||
-# endif
|
||||
-
|
||||
// Currently we only have CPU detection for Linux via /proc/cpuinfo
|
||||
# if defined(__linux__) || defined(ANDROID)
|
||||
# define MOZILLA_ARM_HAVE_CPUID_DETECTION 1
|
||||
--- build/gyp.mozbuild.orig 2015-08-08 20:00:38.026946903 -0600
|
||||
+++ build/gyp.mozbuild 2015-08-08 20:00:45.321915167 -0600
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
# turn off mandatory use of NEON and instead use NEON detection
|
||||
'arm_neon': 0,
|
||||
- 'arm_neon_optional': 1,
|
||||
+ 'arm_neon_optional': 0,
|
||||
|
||||
'moz_widget_toolkit_gonk': 0,
|
||||
'moz_webrtc_omx': 0,
|
Loading…
Reference in a new issue