extra/calligra to 2.9.5-2

This commit is contained in:
Kevin Mihelich 2015-06-12 00:42:48 +00:00
parent 3dd74621fb
commit 7b29ec2e6a
2 changed files with 59 additions and 3 deletions

View file

@ -24,7 +24,7 @@ pkgname=('calligra-braindump'
'calligra-stage'
'calligra-words')
pkgver=2.9.5
pkgrel=1
pkgrel=2
arch=('i686' 'x86_64')
url='http://www.calligra-suite.org/'
license=('FDL1.2' 'GPL2' 'LGPL')
@ -34,11 +34,16 @@ makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs' 'eigen' 'kdeedu-marble'
'openjpeg' 'kdegraphics-okular' 'pstoedit' 'libvisio'
'libetonyek' 'libpqxx' 'libspnav' 'postgresql') # 'libqgit2'
groups=('calligra')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz")
md5sums=('9469c373206ec0d98d80efe8d722930d')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'libwps-0.4.patch')
md5sums=('9469c373206ec0d98d80efe8d722930d'
'6ea15f8b3938838d89ea0aa08921afd1')
prepare() {
mkdir build
# Fix build against libwps 0.4
cd $pkgbase-$pkgver
patch -p1 -i "$srcdir"/libwps-0.4.patch
}
build() {

View file

@ -0,0 +1,51 @@
From e81fe84405bc635dfa93e54fb8a3c8e6065dbf10 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 6 Jun 2015 18:27:24 +0200
Subject: [PATCH] adapt to libwps 0.4
---
cmake/modules/FindLibWps.cmake | 6 +++---
filters/words/works/import/WPSImport.cpp | 4 +++-
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/cmake/modules/FindLibWps.cmake b/cmake/modules/FindLibWps.cmake
index f8c8225..58ef2b5 100644
--- a/cmake/modules/FindLibWps.cmake
+++ b/cmake/modules/FindLibWps.cmake
@@ -10,16 +10,16 @@
include(LibFindMacros)
libfind_package(LIBWPS LibWpd)
-libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.3)
+libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.4)
find_path(LIBWPS_INCLUDE_DIR
NAMES libwps/libwps.h
HINTS ${LIBWPS_PKGCONF_INCLUDE_DIRS} ${LIBWPS_PKGCONF_INCLUDEDIR}
- PATH_SUFFIXES libwps-0.3
+ PATH_SUFFIXES libwps-0.4
)
find_library(LIBWPS_LIBRARY
- NAMES wps wps-0.3
+ NAMES wps wps-0.4
HINTS ${LIBWPS_PKGCONF_LIBRARY_DIRS} ${LIBWPS_PKGCONF_LIBDIR}
)
diff --git a/filters/words/works/import/WPSImport.cpp b/filters/words/works/import/WPSImport.cpp
index eea2cc9..94b859d 100644
--- a/filters/words/works/import/WPSImport.cpp
+++ b/filters/words/works/import/WPSImport.cpp
@@ -91,7 +91,9 @@ public:
bool isSupportedFormat(librevenge::RVNGInputStream &input)
{
WPSKind kind = WPS_TEXT;
- WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind);
+ WPSCreator creator = WPS_MSWORKS;
+ bool needsEncoding = false;
+ WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind, creator, needsEncoding);
if (confidence == WPS_CONFIDENCE_NONE || kind != WPS_TEXT)
return false;
return true;
--
2.4.2