mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/binutils to 2.24-3
This commit is contained in:
parent
0a2f7706ac
commit
7c4efbd7a5
3 changed files with 61 additions and 165 deletions
|
@ -11,7 +11,7 @@ noautobuild=1
|
|||
|
||||
pkgname=binutils
|
||||
pkgver=2.24
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="A set of programs to assemble and manipulate binary and object files"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/binutils/"
|
||||
|
@ -21,9 +21,11 @@ depends=('glibc>=2.19' 'zlib')
|
|||
checkdepends=('dejagnu')
|
||||
options=('staticlibs' '!distcc' '!ccache')
|
||||
install=binutils.install
|
||||
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig})
|
||||
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig}
|
||||
binutils-2.24-lto-testsuite.patch)
|
||||
md5sums=('e0f71a7b2ddab0f8612336ac81d9636b'
|
||||
'SKIP')
|
||||
'SKIP'
|
||||
'b16e895c24ff80acd98a21021eccefad')
|
||||
|
||||
prepare() {
|
||||
cd ${srcdir}/binutils-${pkgver}
|
||||
|
@ -31,6 +33,9 @@ prepare() {
|
|||
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
|
||||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
|
||||
|
||||
# fix lto testsuite with gcc-4.9 - commit b35d44f1
|
||||
patch -p1 -i $srcdir/binutils-2.24-lto-testsuite.patch
|
||||
|
||||
mkdir ${srcdir}/binutils-build
|
||||
}
|
||||
|
||||
|
|
|
@ -1,162 +0,0 @@
|
|||
diff --git a/bfd/doc/bfd.texinfo b/bfd/doc/bfd.texinfo
|
||||
index 45ffa73..3aa3300 100644
|
||||
--- a/bfd/doc/bfd.texinfo
|
||||
+++ b/bfd/doc/bfd.texinfo
|
||||
@@ -322,7 +324,7 @@ All of BFD lives in one directory.
|
||||
@printindex cp
|
||||
|
||||
@tex
|
||||
-% I think something like @colophon should be in texinfo. In the
|
||||
+% I think something like @@colophon should be in texinfo. In the
|
||||
% meantime:
|
||||
\long\def\colophon{\hbox to0pt{}\vfill
|
||||
\centerline{The body of this manual is set in}
|
||||
@@ -333,7 +335,7 @@ All of BFD lives in one directory.
|
||||
\centerline{{\sl\fontname\tensl\/}}
|
||||
\centerline{are used for emphasis.}\vfill}
|
||||
\page\colophon
|
||||
-% Blame: doc@cygnus.com, 28mar91.
|
||||
+% Blame: doc@@cygnus.com, 28mar91.
|
||||
@end tex
|
||||
|
||||
@bye
|
||||
diff --git a/binutils/doc/binutils.texi b/binutils/doc/binutils.texi
|
||||
index 56a0510..fb1802b 100644
|
||||
--- a/binutils/doc/binutils.texi
|
||||
+++ b/binutils/doc/binutils.texi
|
||||
@@ -148,18 +148,18 @@ in the section entitled ``GNU Free Documentation License''.
|
||||
* objcopy:: Copy and translate object files
|
||||
* objdump:: Display information from object files
|
||||
* ranlib:: Generate index to archive contents
|
||||
-* readelf:: Display the contents of ELF format files
|
||||
* size:: List section sizes and total size
|
||||
* strings:: List printable strings from files
|
||||
* strip:: Discard symbols
|
||||
-* elfedit:: Update the ELF header of ELF files
|
||||
* c++filt:: Filter to demangle encoded C++ symbols
|
||||
* cxxfilt: c++filt. MS-DOS name for c++filt
|
||||
* addr2line:: Convert addresses to file and line
|
||||
* nlmconv:: Converts object code into an NLM
|
||||
-* windres:: Manipulate Windows resources
|
||||
* windmc:: Generator for Windows message resources
|
||||
+* windres:: Manipulate Windows resources
|
||||
* dlltool:: Create files needed to build and use DLLs
|
||||
+* readelf:: Display the contents of ELF format files
|
||||
+* elfedit:: Update the ELF header of ELF files
|
||||
* Common Options:: Command-line options for all utilities
|
||||
* Selecting the Target System:: How these utilities determine the target
|
||||
* Reporting Bugs:: Reporting Bugs
|
||||
@@ -2907,7 +2907,7 @@ the Info entries for @file{binutils}.
|
||||
@c man end
|
||||
@end ignore
|
||||
|
||||
-@node c++filt, addr2line, elfedit, Top
|
||||
+@node c++filt, addr2line, strip, Top
|
||||
@chapter c++filt
|
||||
|
||||
@kindex c++filt
|
||||
@@ -4384,7 +4384,7 @@ equivalent. At least one of the @option{--output-mach},
|
||||
|
||||
@table @env
|
||||
|
||||
-@itemx --input-mach=@var{machine}
|
||||
+@item --input-mach=@var{machine}
|
||||
Set the matching input ELF machine type to @var{machine}. If
|
||||
@option{--input-mach} isn't specified, it will match any ELF
|
||||
machine types.
|
||||
@@ -4392,21 +4392,21 @@ machine types.
|
||||
The supported ELF machine types are, @var{L1OM}, @var{K1OM} and
|
||||
@var{x86-64}.
|
||||
|
||||
-@itemx --output-mach=@var{machine}
|
||||
+@item --output-mach=@var{machine}
|
||||
Change the ELF machine type in the ELF header to @var{machine}. The
|
||||
supported ELF machine types are the same as @option{--input-mach}.
|
||||
|
||||
-@itemx --input-type=@var{type}
|
||||
+@item --input-type=@var{type}
|
||||
Set the matching input ELF file type to @var{type}. If
|
||||
@option{--input-type} isn't specified, it will match any ELF file types.
|
||||
|
||||
The supported ELF file types are, @var{rel}, @var{exec} and @var{dyn}.
|
||||
|
||||
-@itemx --output-type=@var{type}
|
||||
+@item --output-type=@var{type}
|
||||
Change the ELF file type in the ELF header to @var{type}. The
|
||||
supported ELF types are the same as @option{--input-type}.
|
||||
|
||||
-@itemx --input-osabi=@var{osabi}
|
||||
+@item --input-osabi=@var{osabi}
|
||||
Set the matching input ELF file OSABI to @var{osabi}. If
|
||||
@option{--input-osabi} isn't specified, it will match any ELF OSABIs.
|
||||
|
||||
@@ -4416,7 +4416,7 @@ The supported ELF OSABIs are, @var{none}, @var{HPUX}, @var{NetBSD},
|
||||
@var{FreeBSD}, @var{TRU64}, @var{Modesto}, @var{OpenBSD}, @var{OpenVMS},
|
||||
@var{NSK}, @var{AROS} and @var{FenixOS}.
|
||||
|
||||
-@itemx --output-osabi=@var{osabi}
|
||||
+@item --output-osabi=@var{osabi}
|
||||
Change the ELF OSABI in the ELF header to @var{osabi}. The
|
||||
supported ELF OSABI are the same as @option{--input-osabi}.
|
||||
|
||||
diff --git a/ld/ld.texinfo b/ld/ld.texinfo
|
||||
index c7ae2a5..4777ad5 100644
|
||||
--- a/ld/ld.texinfo
|
||||
+++ b/ld/ld.texinfo
|
||||
@@ -142,12 +144,12 @@ in the section entitled ``GNU Free Documentation License''.
|
||||
@ifset ARM
|
||||
* ARM:: ld and the ARM family
|
||||
@end ifset
|
||||
-@ifset HPPA
|
||||
-* HPPA ELF32:: ld and HPPA 32-bit ELF
|
||||
-@end ifset
|
||||
@ifset M68HC11
|
||||
* M68HC11/68HC12:: ld and the Motorola 68HC11 and 68HC12 families
|
||||
@end ifset
|
||||
+@ifset HPPA
|
||||
+* HPPA ELF32:: ld and HPPA 32-bit ELF
|
||||
+@end ifset
|
||||
@ifset M68K
|
||||
* M68K:: ld and Motorola 68K family
|
||||
@end ifset
|
||||
@@ -6012,6 +6014,9 @@ functionality are not listed.
|
||||
@ifset I960
|
||||
* i960:: @command{ld} and the Intel 960 family
|
||||
@end ifset
|
||||
+@ifset M68HC11
|
||||
+* M68HC11/68HC12:: @code{ld} and the Motorola 68HC11 and 68HC12 families
|
||||
+@end ifset
|
||||
@ifset ARM
|
||||
* ARM:: @command{ld} and the ARM family
|
||||
@end ifset
|
||||
@@ -6027,9 +6032,6 @@ functionality are not listed.
|
||||
@ifset MSP430
|
||||
* MSP430:: @command{ld} and MSP430
|
||||
@end ifset
|
||||
-@ifset M68HC11
|
||||
-* M68HC11/68HC12:: @code{ld} and the Motorola 68HC11 and 68HC12 families
|
||||
-@end ifset
|
||||
@ifset POWERPC
|
||||
* PowerPC ELF32:: @command{ld} and PowerPC 32-bit ELF Support
|
||||
@end ifset
|
||||
@@ -7877,7 +7879,7 @@ If you have more than one @code{SECT} statement for the same
|
||||
@printindex cp
|
||||
|
||||
@tex
|
||||
-% I think something like @colophon should be in texinfo. In the
|
||||
+% I think something like @@colophon should be in texinfo. In the
|
||||
% meantime:
|
||||
\long\def\colophon{\hbox to0pt{}\vfill
|
||||
\centerline{The body of this manual is set in}
|
||||
@@ -7888,7 +7890,7 @@ If you have more than one @code{SECT} statement for the same
|
||||
\centerline{{\sl\fontname\tensl\/}}
|
||||
\centerline{are used for emphasis.}\vfill}
|
||||
\page\colophon
|
||||
-% Blame: doc@cygnus.com, 28mar91.
|
||||
+% Blame: doc@@cygnus.com, 28mar91.
|
||||
@end tex
|
||||
|
||||
@bye
|
||||
--
|
||||
1.7.1
|
||||
|
53
core/binutils/binutils-2.24-lto-testsuite.patch
Normal file
53
core/binutils/binutils-2.24-lto-testsuite.patch
Normal file
|
@ -0,0 +1,53 @@
|
|||
index c5249f0..69946de 100644
|
||||
--- a/ld/testsuite/ld-plugin/lto.exp
|
||||
+++ b/ld/testsuite/ld-plugin/lto.exp
|
||||
@@ -57,7 +57,7 @@ set lto_link_tests {
|
||||
"" "-O2"
|
||||
{lto-3c.c} {} "libdummy.a"}
|
||||
{"Build liblto-3.a"
|
||||
- "" "-flto"
|
||||
+ "" "-flto -ffat-lto-objects"
|
||||
{lto-3b.c} {} "liblto-3.a"}
|
||||
{"Build libdummy.a 5a"
|
||||
"" "-flto"
|
||||
@@ -111,7 +111,7 @@ set lto_link_tests {
|
||||
"" ""
|
||||
{pr12758a.s} {} "libdummy.a"}
|
||||
{"Build libpr12758.a"
|
||||
- "" "-flto -O2"
|
||||
+ "" "-flto -O2 -ffat-lto-objects"
|
||||
{pr12758b.c} {} "libpr12758.a"}
|
||||
{"PR ld/12758"
|
||||
"-O2 -Wl,-e,foo -nostdlib -flto -fuse-linker-plugin tmpdir/pr12758a.o -Wl,--start-group tmpdir/libpr12758.a -Wl,--end-group" ""
|
||||
@@ -120,13 +120,13 @@ set lto_link_tests {
|
||||
"" ""
|
||||
{pr12760a.c} {} "libdummy.a"}
|
||||
{"Build libpr12760.a"
|
||||
- "" "-flto -O2"
|
||||
+ "" "-flto -O2 -ffat-lto-objects"
|
||||
{pr12760b.c} {} "libpr12760.a"}
|
||||
{"PR ld/12760"
|
||||
"-O2 -Wl,-e,foo -nostdlib -flto -fuse-linker-plugin tmpdir/pr12760a.o -Wl,--start-group tmpdir/libpr12760.a -Wl,--end-group" ""
|
||||
{dummy.c} {} "pr12760.exe" "c" "warning: Bad bar"}
|
||||
{"Build libpr13183.a"
|
||||
- "-T" "-flto -O2"
|
||||
+ "-T" "-flto -O2 -ffat-lto-objects"
|
||||
{pr13183a.c} {} "libpr13183.a"}
|
||||
{"Build libdummy.a PR ld/13183"
|
||||
"" "-flto -O2"
|
||||
diff --git a/ld/testsuite/lib/ld-lib.exp b/ld/testsuite/lib/ld-lib.exp
|
||||
index 8df42ae..175449a 100644
|
||||
--- a/ld/testsuite/lib/ld-lib.exp
|
||||
+++ b/ld/testsuite/lib/ld-lib.exp
|
||||
@@ -1643,7 +1643,7 @@ proc check_lto_available { } {
|
||||
set f [open $src "w"]
|
||||
puts $f ""
|
||||
close $f
|
||||
- set status [remote_exec host $CC "-shared -B[pwd]/tmpdir/ld/ -flto -fuse-linker-plugin $src -o $output"]
|
||||
+ set status [remote_exec host $CC "-shared -B[pwd]/tmpdir/ld/ -flto -ffat-lto-objects -fuse-linker-plugin $src -o $output"]
|
||||
if { [lindex $status 0] == 0 } {
|
||||
set lto_available_saved 1
|
||||
} else {
|
||||
--
|
||||
1.7.1
|
||||
|
Loading…
Reference in a new issue