core/gcc to 4.9.0-1

This commit is contained in:
Kevin Mihelich 2014-05-02 12:15:51 +00:00
parent 7c4efbd7a5
commit 7dedb7cf8e
2 changed files with 18 additions and 59 deletions

View file

@ -14,10 +14,10 @@
noautobuild=1
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-go')
pkgver=4.8.2
_pkgver=4.8
pkgrel=8
_snapshot=4.8-20140206
pkgver=4.9.0
_pkgver=4.9
pkgrel=1
_snapshot=4.9.0-RC-20140411
pkgdesc="The GNU Compiler Collection"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
@ -25,13 +25,11 @@ url="http://gcc.gnu.org"
makedepends=('binutils>=2.24' 'libmpc' 'cloog' 'doxygen')
checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs' '!distcc')
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
gcc-4.8-filename-output.patch
gcc-4.8-lambda-ICE.patch)
md5sums=('9d35549404a2326540fb88301ebd1977'
'40cb437805e2f7a006aa0d0c3098ab0f'
'6eb6e080dbf7bc6825f53a0aaa6c4ef9')
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
gcc-4.8-filename-output.patch)
md5sums=('9709b49ae0e904cbb0a6a1b62853b556'
'40cb437805e2f7a006aa0d0c3098ab0f')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@ -55,18 +53,11 @@ prepare() {
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57653
patch -p0 -i ${srcdir}/gcc-4.8-filename-output.patch
# http://gcc.gnu.org/bugzilla//show_bug.cgi?id=56710 - commit 3d1f8279
patch -p1 -i ${srcdir}/gcc-4.8-lambda-ICE.patch
# ALARM: Specify build host types, triplet patch
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi"
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16"
# installing libiberty headers is broken
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56780#c6
sed -i 's#@target_header_dir@#libiberty#' libiberty/Makefile.in
mkdir ${srcdir}/gcc-build
}
@ -124,13 +115,14 @@ package_gcc-libs()
make -C $CHOST/libgcc DESTDIR=${pkgdir} install-shared
rm ${pkgdir}/${_libdir}/libgcc_eh.a
for lib in libmudflap \
for lib in libatomic \
libcilkrts \
libgfortran \
libgomp \
libitm \
libatomic \
libstdc++-v3/src \
libquadmath \
libgfortran; do
libstdc++-v3/src \
libvtv; do
make -C $CHOST/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
done
@ -182,13 +174,16 @@ package_gcc()
make -C gcc DESTDIR=${pkgdir} install-mkheaders
make -C lto-plugin DESTDIR=${pkgdir} install
make -C $CHOST/libcilkrts DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
install-nodist_cilkincludeHEADERS
make -C $CHOST/libgomp DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
install-nodist_libsubincludeHEADERS
make -C $CHOST/libitm DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
make -C $CHOST/libmudflap DESTDIR=${pkgdir} install-nobase_libsubincludeHEADERS
make -C $CHOST/libquadmath DESTDIR=${pkgdir} install-nodist_libsubincludeHEADERS
make -C libiberty DESTDIR=${pkgdir} install
# install PIC version of libiberty
install -m644 ${srcdir}/gcc-build/libiberty/pic/libiberty.a ${pkgdir}/usr/lib
make -C gcc DESTDIR=${pkgdir} install-man install-info
rm ${pkgdir}/usr/share/man/man1/{gccgo,gfortran}.1
@ -198,7 +193,6 @@ package_gcc()
make -C gcc DESTDIR=${pkgdir} install-po
# many packages expect this symlink
#install -dm755 ${pkgdir}/lib
ln -s gcc ${pkgdir}/usr/bin/cc
# POSIX conformance launcher scripts for c89 and c99

View file

@ -1,35 +0,0 @@
diff --git a/gcc/cp/semantics.c b/gcc/cp/semantics.c
index 0b8e2f7..ad1c209 100644
--- a/gcc/cp/semantics.c
+++ b/gcc/cp/semantics.c
@@ -2719,8 +2719,10 @@ finish_member_declaration (tree decl)
/*friend_p=*/0);
}
}
- /* Enter the DECL into the scope of the class. */
- else if (pushdecl_class_level (decl))
+ /* Enter the DECL into the scope of the class, if the class
+ isn't a closure (whose fields are supposed to be unnamed). */
+ else if (CLASSTYPE_LAMBDA_EXPR (current_class_type)
+ || pushdecl_class_level (decl))
{
if (TREE_CODE (decl) == USING_DECL)
{
diff --git a/gcc/testsuite/g++.dg/cpp0x/lambda/lambda-names1.C b/gcc/testsuite/g++.dg/cpp0x/lambda/lambda-names1.C
new file mode 100644
index 0000000..df2b037
--- /dev/null
+++ b/gcc/testsuite/g++.dg/cpp0x/lambda/lambda-names1.C
@@ -0,0 +1,9 @@
+// PR c++/56710
+// { dg-options "-std=c++11 -Wall" }
+
+int main()
+{
+ int t = 0;
+ return [&]() -> int {int __t; __t = t; return __t; }();
+ return [&t]() -> int {int __t; __t = t; return __t; }();
+}
--
1.8.4.2