mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
Added experimental php by pepedog and minidlna from kmihelich
This commit is contained in:
parent
a3eb8f022b
commit
7ea57f2c54
6 changed files with 856 additions and 0 deletions
323
extra/php-pepedog/PKGBUILD
Normal file
323
extra/php-pepedog/PKGBUILD
Normal file
|
@ -0,0 +1,323 @@
|
|||
# $Id: PKGBUILD 86064 2010-07-25 11:20:29Z pierre $
|
||||
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
|
||||
|
||||
pkgbase=php
|
||||
pkgname=('php'
|
||||
'php-cgi'
|
||||
'php-apache'
|
||||
'php-embed'
|
||||
'php-curl'
|
||||
'php-enchant'
|
||||
'php-gd'
|
||||
'php-gmp'
|
||||
'php-intl'
|
||||
'php-ldap'
|
||||
'php-mcrypt'
|
||||
'php-odbc'
|
||||
'php-pgsql'
|
||||
'php-pspell'
|
||||
'php-snmp'
|
||||
'php-sqlite'
|
||||
'php-tidy'
|
||||
'php-xsl')
|
||||
pkgver=5.3.3
|
||||
pkgrel=1
|
||||
_suhosinver=${pkgver}-0.9.10
|
||||
arch=('i686' 'x86_64')
|
||||
license=('PHP')
|
||||
url='http://www.php.net'
|
||||
makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' 'postfix'
|
||||
'sqlite3' 'unixodbc' 'net-snmp' 'libzip' 'enchant' 'file'
|
||||
'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'gd' 'icu'
|
||||
'curl' 'libxslt' 'openssl' 'bzip2' 'db' 'gmp' 'libevent')
|
||||
options=('!makeflags')
|
||||
source=("http://www.php.net/distributions/${pkgbase}-${pkgver}.tar.bz2"
|
||||
"http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz"
|
||||
'php.ini.patch' 'apache.conf' 'rc.d.php-fpm' 'php-fpm.conf')
|
||||
md5sums=('21ceeeb232813c10283a5ca1b4c87b48'
|
||||
'b66b27c43b1332400ef8982944c3b95b'
|
||||
'd6f94150f47047882c6716575e12e99b'
|
||||
'96ca078be6729b665be8a865535a97bf'
|
||||
'ff8346d57f0bd67c7a383c1561dcd7c1'
|
||||
'0ac88ff88ae951118201d6424eaa426a')
|
||||
|
||||
build() {
|
||||
# ldap-sasl does not compile with --as-needed
|
||||
export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
|
||||
export LDFLAGS="${LDFLAGS//,--as-needed}"
|
||||
|
||||
phpconfig="--srcdir=../${pkgbase}-${pkgver} \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc/php \
|
||||
--localstatedir=/var \
|
||||
--with-layout=GNU \
|
||||
--with-config-file-path=/etc/php \
|
||||
--with-config-file-scan-dir=/etc/php/conf.d \
|
||||
--enable-inline-optimization \
|
||||
--disable-debug \
|
||||
--disable-rpath \
|
||||
--disable-static \
|
||||
--enable-shared \
|
||||
--mandir=/usr/share/man \
|
||||
--disable-cli \
|
||||
--without-pear \
|
||||
"
|
||||
|
||||
phpextensions="--enable-bcmath=shared \
|
||||
--enable-calendar=shared \
|
||||
--enable-dba=shared \
|
||||
--enable-exif=shared \
|
||||
--enable-ftp=shared \
|
||||
--enable-gd-native-ttf \
|
||||
--enable-intl=shared \
|
||||
--enable-json=shared \
|
||||
--enable-mbregex \
|
||||
--enable-mbstring \
|
||||
--enable-pdo=shared \
|
||||
--enable-phar=shared \
|
||||
--enable-posix=shared \
|
||||
--enable-session \
|
||||
--enable-shmop=shared \
|
||||
--enable-soap=shared \
|
||||
--enable-sockets=shared \
|
||||
--enable-sqlite-utf8 \
|
||||
--enable-sysvmsg=shared \
|
||||
--enable-sysvsem=shared \
|
||||
--enable-sysvshm=shared \
|
||||
--enable-xml \
|
||||
--enable-zip=shared \
|
||||
--with-bz2=shared \
|
||||
--with-curl=shared \
|
||||
--with-db4=/usr \
|
||||
--with-enchant=shared,/usr \
|
||||
--with-freetype-dir=shared,/usr \
|
||||
--with-gd=shared,/usr \
|
||||
--with-gdbm=shared \
|
||||
--with-gettext=shared \
|
||||
--with-gmp=shared \
|
||||
--with-iconv=shared \
|
||||
--with-icu-dir=/usr \
|
||||
--with-imap-ssl=shared \
|
||||
--with-imap=shared \
|
||||
--with-jpeg-dir=shared,/usr \
|
||||
--with-ldap=shared \
|
||||
--with-ldap-sasl \
|
||||
--with-mcrypt=shared \
|
||||
--with-mhash \
|
||||
--with-mysql-sock=/var/run/mysqld/mysqld.sock \
|
||||
--with-mysql=shared,mysqlnd \
|
||||
--with-mysqli=shared,mysqlnd \
|
||||
--with-openssl=shared \
|
||||
--with-pcre-regex=/usr \
|
||||
--with-pdo-mysql=shared,mysqlnd \
|
||||
--with-pdo-odbc=shared,unixODBC,/usr \
|
||||
--with-pdo-pgsql=shared \
|
||||
--with-pdo-sqlite=shared,/usr \
|
||||
--with-pgsql=shared \
|
||||
--with-png-dir=shared,/usr \
|
||||
--with-pspell=shared \
|
||||
--with-regex=php \
|
||||
--with-snmp=shared \
|
||||
--with-sqlite3=shared,/usr \
|
||||
--with-sqlite=shared \
|
||||
--with-tidy=shared \
|
||||
--with-unixODBC=shared,/usr \
|
||||
--with-xmlrpc=shared \
|
||||
--with-xsl=shared \
|
||||
--with-zlib \
|
||||
--without-db2 \
|
||||
--without-db3 \
|
||||
"
|
||||
|
||||
EXTENSION_DIR=/usr/lib/php/modules
|
||||
export EXTENSION_DIR
|
||||
PEAR_INSTALLDIR=/usr/share/pear
|
||||
export PEAR_INSTALLDIR
|
||||
|
||||
cd ${srcdir}/${pkgbase}-${pkgver}
|
||||
|
||||
# apply suhosin patch
|
||||
patch -p1 -i ${srcdir}/suhosin-patch-${_suhosinver}.patch
|
||||
|
||||
# adjust paths
|
||||
patch -p0 -i ${srcdir}/php.ini.patch
|
||||
|
||||
# php
|
||||
mkdir ${srcdir}/build-php
|
||||
cd ${srcdir}/build-php
|
||||
ln -s ../${pkgbase}-${pkgver}/configure
|
||||
./configure ${phpconfig} \
|
||||
--with-readline \
|
||||
--enable-pcntl \
|
||||
${phpextensions}
|
||||
make
|
||||
|
||||
# cgi and fcgi
|
||||
# reuse the previous run; this will save us a lot of time
|
||||
cp -a ${srcdir}/build-php ${srcdir}/build-cgi
|
||||
cd ${srcdir}/build-cgi
|
||||
./configure ${phpconfig} \
|
||||
--disable-cli \
|
||||
--enable-cgi \
|
||||
${phpextensions}
|
||||
make
|
||||
|
||||
# apache
|
||||
cp -a ${srcdir}/build-php ${srcdir}/build-apache
|
||||
cd ${srcdir}/build-apache
|
||||
./configure ${phpconfig} \
|
||||
--disable-cli \
|
||||
--with-apxs2 \
|
||||
${phpextensions}
|
||||
make
|
||||
|
||||
|
||||
# embed
|
||||
cp -a ${srcdir}/build-php ${srcdir}/build-embed
|
||||
cd ${srcdir}/build-embed
|
||||
./configure ${phpconfig} \
|
||||
--disable-cli \
|
||||
--enable-embed=shared \
|
||||
${phpextensions}
|
||||
make
|
||||
|
||||
|
||||
}
|
||||
|
||||
package_php() {
|
||||
pkgdesc='An HTML-embedded scripting language'
|
||||
depends=('pcre' 'libxml2' 'bzip2' 'openssl')
|
||||
replaces=('php-fileinfo')
|
||||
provides=('php-fileinfo')
|
||||
conflicts=('php-fileinfo')
|
||||
backup=('etc/php/php.ini')
|
||||
|
||||
cd ${srcdir}/build-php
|
||||
make INSTALL_ROOT=${pkgdir} install
|
||||
install -d -m755 ${pkgdir}/usr/share/pear
|
||||
# fix broken link
|
||||
ln -sf phar.phar $pkgdir/usr/bin/phar
|
||||
# install php.ini
|
||||
install -D -m644 ${srcdir}/${pkgbase}-${pkgver}/php.ini-production ${pkgdir}/etc/php/php.ini
|
||||
install -d -m755 ${pkgdir}/etc/php/conf.d/
|
||||
|
||||
# remove static modules
|
||||
rm -f ${pkgdir}/usr/lib/php/modules/*.a
|
||||
# remove modules provided by sub packages
|
||||
rm -f ${pkgdir}/usr/lib/php/modules/{curl,enchant,gd,gmp,intl,ldap,mcrypt,odbc,pdo_odbc,pgsql,pdo_pgsql,pspell,snmp,sqlite3,pdo_sqlite,tidy,xsl}.so
|
||||
}
|
||||
|
||||
package_php-cgi() {
|
||||
pkgdesc='CGI and FCGI SAPI for PHP'
|
||||
depends=('php' 'pcre' 'libxml2')
|
||||
|
||||
install -D -m755 ${srcdir}/build-cgi/sapi/cgi/php-cgi ${pkgdir}/usr/bin/php-cgi
|
||||
}
|
||||
|
||||
package_php-apache() {
|
||||
pkgdesc='Apache SAPI for PHP'
|
||||
depends=('php' 'apache' 'pcre' 'libxml2')
|
||||
backup=('etc/httpd/conf/extra/php5_module.conf')
|
||||
|
||||
install -D -m755 ${srcdir}/build-apache/libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so
|
||||
install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf
|
||||
}
|
||||
|
||||
|
||||
|
||||
package_php-embed() {
|
||||
pkgdesc='Embed SAPI for PHP'
|
||||
depends=('php' 'pcre' 'libxml2')
|
||||
|
||||
install -D -m755 ${srcdir}/build-embed/libs/libphp5.so ${pkgdir}/usr/lib/libphp5.so
|
||||
install -D -m644 ${srcdir}/${pkgbase}-${pkgver}/sapi/embed/php_embed.h ${pkgdir}/usr/include/php/sapi/embed/php_embed.h
|
||||
}
|
||||
|
||||
|
||||
|
||||
package_php-curl() {
|
||||
depends=('php' 'curl')
|
||||
pkgdesc='curl module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/curl.so ${pkgdir}/usr/lib/php/modules/curl.so
|
||||
}
|
||||
|
||||
package_php-enchant() {
|
||||
depends=('php' 'enchant')
|
||||
pkgdesc='enchant module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/enchant.so ${pkgdir}/usr/lib/php/modules/enchant.so
|
||||
}
|
||||
|
||||
package_php-gd() {
|
||||
depends=('php' 'gd')
|
||||
pkgdesc='gd module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/gd.so ${pkgdir}/usr/lib/php/modules/gd.so
|
||||
}
|
||||
|
||||
package_php-gmp() {
|
||||
depends=('php' 'gmp')
|
||||
pkgdesc='gmp module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/gmp.so ${pkgdir}/usr/lib/php/modules/gmp.so
|
||||
}
|
||||
|
||||
package_php-intl() {
|
||||
depends=('php' 'icu')
|
||||
pkgdesc='intl module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/intl.so ${pkgdir}/usr/lib/php/modules/intl.so
|
||||
}
|
||||
|
||||
package_php-ldap() {
|
||||
depends=('php' 'libldap')
|
||||
pkgdesc='ldap module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/ldap.so ${pkgdir}/usr/lib/php/modules/ldap.so
|
||||
}
|
||||
|
||||
package_php-mcrypt() {
|
||||
depends=('php' 'libmcrypt' 'libtool')
|
||||
pkgdesc='mcrypt module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/mcrypt.so ${pkgdir}/usr/lib/php/modules/mcrypt.so
|
||||
}
|
||||
|
||||
package_php-odbc() {
|
||||
depends=('php' 'unixodbc')
|
||||
pkgdesc='ODBC modules for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/odbc.so ${pkgdir}/usr/lib/php/modules/odbc.so
|
||||
install -D -m755 ${srcdir}/build-php/modules/pdo_odbc.so ${pkgdir}/usr/lib/php/modules/pdo_odbc.so
|
||||
}
|
||||
|
||||
package_php-pgsql() {
|
||||
depends=('php' 'postgresql-libs')
|
||||
pkgdesc='PostgreSQL modules for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/pgsql.so ${pkgdir}/usr/lib/php/modules/pgsql.so
|
||||
install -D -m755 ${srcdir}/build-php/modules/pdo_pgsql.so ${pkgdir}/usr/lib/php/modules/pdo_pgsql.so
|
||||
}
|
||||
|
||||
package_php-pspell() {
|
||||
depends=('php' 'aspell')
|
||||
pkgdesc='pspell module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/pspell.so ${pkgdir}/usr/lib/php/modules/pspell.so
|
||||
}
|
||||
|
||||
package_php-snmp() {
|
||||
depends=('php' 'net-snmp')
|
||||
pkgdesc='snmp module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/snmp.so ${pkgdir}/usr/lib/php/modules/snmp.so
|
||||
}
|
||||
|
||||
package_php-sqlite() {
|
||||
depends=('php' 'sqlite3')
|
||||
pkgdesc='sqlite3 module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/sqlite3.so ${pkgdir}/usr/lib/php/modules/sqlite3.so
|
||||
install -D -m755 ${srcdir}/build-php/modules/pdo_sqlite.so ${pkgdir}/usr/lib/php/modules/pdo_sqlite.so
|
||||
}
|
||||
|
||||
package_php-tidy() {
|
||||
depends=('php' 'tidyhtml')
|
||||
pkgdesc='tidy module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/tidy.so ${pkgdir}/usr/lib/php/modules/tidy.so
|
||||
}
|
||||
|
||||
package_php-xsl() {
|
||||
depends=('php' 'libxslt')
|
||||
pkgdesc='xsl module for PHP'
|
||||
install -D -m755 ${srcdir}/build-php/modules/xsl.so ${pkgdir}/usr/lib/php/modules/xsl.so
|
||||
}
|
9
extra/php-pepedog/apache.conf
Normal file
9
extra/php-pepedog/apache.conf
Normal file
|
@ -0,0 +1,9 @@
|
|||
# Required modules: dir_module, php5_module
|
||||
|
||||
<IfModule dir_module>
|
||||
<IfModule php5_module>
|
||||
DirectoryIndex index.php index.html
|
||||
AddHandler application/x-httpd-php .php
|
||||
AddHandler application/x-httpd-php-source .phps
|
||||
</IfModule>
|
||||
</IfModule>
|
274
extra/php-pepedog/php-fpm.conf
Normal file
274
extra/php-pepedog/php-fpm.conf
Normal file
|
@ -0,0 +1,274 @@
|
|||
;;;;;;;;;;;;;;;;;;;;;
|
||||
; FPM Configuration ;
|
||||
;;;;;;;;;;;;;;;;;;;;;
|
||||
|
||||
; All relative paths in this configuration file are relative to PHP's install
|
||||
; prefix.
|
||||
|
||||
; Include one or more files. If glob(3) exists, it is used to include a bunch of
|
||||
; files from a glob(3) pattern. This directive can be used everywhere in the
|
||||
; file.
|
||||
;include=/etc/php/fpm.d/*.conf
|
||||
|
||||
;;;;;;;;;;;;;;;;;;
|
||||
; Global Options ;
|
||||
;;;;;;;;;;;;;;;;;;
|
||||
|
||||
[global]
|
||||
; Pid file
|
||||
; Default Value: none
|
||||
pid = /var/run/php-fpm/php-fpm.pid
|
||||
|
||||
; Error log file
|
||||
; Default Value: /var/log/php-fpm.log
|
||||
;error_log = /var/log/php-fpm.log
|
||||
|
||||
; Log level
|
||||
; Possible Values: alert, error, warning, notice, debug
|
||||
; Default Value: notice
|
||||
;log_level = notice
|
||||
|
||||
; If this number of child processes exit with SIGSEGV or SIGBUS within the time
|
||||
; interval set by emergency_restart_interval then FPM will restart. A value
|
||||
; of '0' means 'Off'.
|
||||
; Default Value: 0
|
||||
;emergency_restart_threshold = 0
|
||||
|
||||
; Interval of time used by emergency_restart_interval to determine when
|
||||
; a graceful restart will be initiated. This can be useful to work around
|
||||
; accidental corruptions in an accelerator's shared memory.
|
||||
; Available Units: s(econds), m(inutes), h(ours), or d(ays)
|
||||
; Default Unit: seconds
|
||||
; Default Value: 0
|
||||
;emergency_restart_interval = 0
|
||||
|
||||
; Time limit for child processes to wait for a reaction on signals from master.
|
||||
; Available units: s(econds), m(inutes), h(ours), or d(ays)
|
||||
; Default Unit: seconds
|
||||
; Default Value: 0
|
||||
;process_control_timeout = 0
|
||||
|
||||
; Send FPM to background. Set to 'no' to keep FPM in foreground for debugging.
|
||||
; Default Value: yes
|
||||
;daemonize = yes
|
||||
|
||||
;;;;;;;;;;;;;;;;;;;;
|
||||
; Pool Definitions ;
|
||||
;;;;;;;;;;;;;;;;;;;;
|
||||
|
||||
; Multiple pools of child processes may be started with different listening
|
||||
; ports and different management options. The name of the pool will be
|
||||
; used in logs and stats. There is no limitation on the number of pools which
|
||||
; FPM can handle. Your system will tell you anyway :)
|
||||
|
||||
; Start a new pool named 'www'.
|
||||
[www]
|
||||
|
||||
; The address on which to accept FastCGI requests.
|
||||
; Valid syntaxes are:
|
||||
; 'ip.add.re.ss:port' - to listen on a TCP socket to a specific address on
|
||||
; a specific port;
|
||||
; 'port' - to listen on a TCP socket to all addresses on a
|
||||
; specific port;
|
||||
; '/path/to/unix/socket' - to listen on a unix socket.
|
||||
; Note: This value is mandatory.
|
||||
;listen = 127.0.0.1:9000
|
||||
listen = /var/run/php-fpm/php-fpm.sock
|
||||
|
||||
; Set listen(2) backlog. A value of '-1' means unlimited.
|
||||
; Default Value: -1
|
||||
;listen.backlog = -1
|
||||
|
||||
; List of ipv4 addresses of FastCGI clients which are allowed to connect.
|
||||
; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
|
||||
; PHP FCGI (5.2.2+). Makes sense only with a tcp listening socket. Each address
|
||||
; must be separated by a comma. If this value is left blank, connections will be
|
||||
; accepted from any ip address.
|
||||
; Default Value: any
|
||||
;listen.allowed_clients = 127.0.0.1
|
||||
|
||||
; Set permissions for unix socket, if one is used. In Linux, read/write
|
||||
; permissions must be set in order to allow connections from a web server. Many
|
||||
; BSD-derived systems allow connections regardless of permissions.
|
||||
; Default Values: user and group are set as the running user
|
||||
; mode is set to 0666
|
||||
listen.owner = http
|
||||
listen.group = http
|
||||
listen.mode = 0660
|
||||
|
||||
; Unix user/group of processes
|
||||
; Note: The user is mandatory. If the group is not set, the default user's group
|
||||
; will be used.
|
||||
user = http
|
||||
group = http
|
||||
|
||||
; Choose how the process manager will control the number of child processes.
|
||||
; Possible Values:
|
||||
; static - a fixed number (pm.max_children) of child processes;
|
||||
; dynamic - the number of child processes are set dynamically based on the
|
||||
; following directives:
|
||||
; pm.max_children - the maximum number of children that can
|
||||
; be alive at the same time.
|
||||
; pm.start_servers - the number of children created on startup.
|
||||
; pm.min_spare_servers - the minimum number of children in 'idle'
|
||||
; state (waiting to process). If the number
|
||||
; of 'idle' processes is less than this
|
||||
; number then some children will be created.
|
||||
; pm.max_spare_servers - the maximum number of children in 'idle'
|
||||
; state (waiting to process). If the number
|
||||
; of 'idle' processes is greater than this
|
||||
; number then some children will be killed.
|
||||
; Note: This value is mandatory.
|
||||
pm = dynamic
|
||||
|
||||
; The number of child processes to be created when pm is set to 'static' and the
|
||||
; maximum number of child processes to be created when pm is set to 'dynamic'.
|
||||
; This value sets the limit on the number of simultaneous requests that will be
|
||||
; served. Equivalent to the ApacheMaxClients directive with mpm_prefork.
|
||||
; Equivalent to the PHP_FCGI_CHILDREN environment variable in the original PHP
|
||||
; CGI.
|
||||
; Note: Used when pm is set to either 'static' or 'dynamic'
|
||||
; Note: This value is mandatory.
|
||||
pm.max_children = 50
|
||||
|
||||
; The number of child processes created on startup.
|
||||
; Note: Used only when pm is set to 'dynamic'
|
||||
; Default Value: min_spare_servers + (max_spare_servers - min_spare_servers) / 2
|
||||
pm.start_servers = 20
|
||||
|
||||
; The desired minimum number of idle server processes.
|
||||
; Note: Used only when pm is set to 'dynamic'
|
||||
; Note: Mandatory when pm is set to 'dynamic'
|
||||
pm.min_spare_servers = 5
|
||||
|
||||
; The desired maximum number of idle server processes.
|
||||
; Note: Used only when pm is set to 'dynamic'
|
||||
; Note: Mandatory when pm is set to 'dynamic'
|
||||
pm.max_spare_servers = 35
|
||||
|
||||
; The number of requests each child process should execute before respawning.
|
||||
; This can be useful to work around memory leaks in 3rd party libraries. For
|
||||
; endless request processing specify '0'. Equivalent to PHP_FCGI_MAX_REQUESTS.
|
||||
; Default Value: 0
|
||||
pm.max_requests = 500
|
||||
|
||||
; The URI to view the FPM status page. If this value is not set, no URI will be
|
||||
; recognized as a status page. By default, the status page shows the following
|
||||
; information:
|
||||
; accepted conn - the number of request accepted by the pool;
|
||||
; pool - the name of the pool;
|
||||
; process manager - static or dynamic;
|
||||
; idle processes - the number of idle processes;
|
||||
; active processes - the number of active processes;
|
||||
; total processes - the number of idle + active processes.
|
||||
; The values of 'idle processes', 'active processes' and 'total processes' are
|
||||
; updated each second. The value of 'accepted conn' is updated in real time.
|
||||
; Example output:
|
||||
; accepted conn: 12073
|
||||
; pool: www
|
||||
; process manager: static
|
||||
; idle processes: 35
|
||||
; active processes: 65
|
||||
; total processes: 100
|
||||
; By default the status page output is formatted as text/plain. Passing either
|
||||
; 'html' or 'json' as a query string will return the corresponding output
|
||||
; syntax. Example:
|
||||
; http://www.foo.bar/status
|
||||
; http://www.foo.bar/status?json
|
||||
; http://www.foo.bar/status?html
|
||||
; Note: The value must start with a leading slash (/). The value can be
|
||||
; anything, but it may not be a good idea to use the .php extension or it
|
||||
; may conflict with a real PHP file.
|
||||
; Default Value: not set
|
||||
;pm.status_path = /status
|
||||
|
||||
; The ping URI to call the monitoring page of FPM. If this value is not set, no
|
||||
; URI will be recognized as a ping page. This could be used to test from outside
|
||||
; that FPM is alive and responding, or to
|
||||
; - create a graph of FPM availability (rrd or such);
|
||||
; - remove a server from a group if it is not responding (load balancing);
|
||||
; - trigger alerts for the operating team (24/7).
|
||||
; Note: The value must start with a leading slash (/). The value can be
|
||||
; anything, but it may not be a good idea to use the .php extension or it
|
||||
; may conflict with a real PHP file.
|
||||
; Default Value: not set
|
||||
;ping.path = /ping
|
||||
|
||||
; This directive may be used to customize the response of a ping request. The
|
||||
; response is formatted as text/plain with a 200 response code.
|
||||
; Default Value: pong
|
||||
;ping.response = pong
|
||||
|
||||
; The timeout for serving a single request after which the worker process will
|
||||
; be killed. This option should be used when the 'max_execution_time' ini option
|
||||
; does not stop script execution for some reason. A value of '0' means 'off'.
|
||||
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
|
||||
; Default Value: 0
|
||||
;request_terminate_timeout = 0
|
||||
|
||||
; The timeout for serving a single request after which a PHP backtrace will be
|
||||
; dumped to the 'slowlog' file. A value of '0s' means 'off'.
|
||||
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
|
||||
; Default Value: 0
|
||||
;request_slowlog_timeout = 0
|
||||
|
||||
; The log file for slow requests
|
||||
; Default Value: /var/log/php-fpm.log.slow
|
||||
;slowlog = /var/log/php-fpm.log.slow
|
||||
|
||||
; Set open file descriptor rlimit.
|
||||
; Default Value: system defined value
|
||||
;rlimit_files = 1024
|
||||
|
||||
; Set max core size rlimit.
|
||||
; Possible Values: 'unlimited' or an integer greater or equal to 0
|
||||
; Default Value: system defined value
|
||||
;rlimit_core = 0
|
||||
|
||||
; Chroot to this directory at the start. This value must be defined as an
|
||||
; absolute path. When this value is not set, chroot is not used.
|
||||
; Note: chrooting is a great security feature and should be used whenever
|
||||
; possible. However, all PHP paths will be relative to the chroot
|
||||
; (error_log, sessions.save_path, ...).
|
||||
; Default Value: not set
|
||||
;chroot =
|
||||
|
||||
; Chdir to this directory at the start. This value must be an absolute path.
|
||||
; Default Value: current directory or / when chroot
|
||||
;chdir = /srv/http
|
||||
|
||||
; Redirect worker stdout and stderr into main error log. If not set, stdout and
|
||||
; stderr will be redirected to /dev/null according to FastCGI specs.
|
||||
; Default Value: no
|
||||
;catch_workers_output = yes
|
||||
|
||||
; Pass environment variables like LD_LIBRARY_PATH. All $VARIABLEs are taken from
|
||||
; the current environment.
|
||||
; Default Value: clean env
|
||||
;env[HOSTNAME] = $HOSTNAME
|
||||
;env[PATH] = /usr/local/bin:/usr/bin:/bin
|
||||
;env[TMP] = /tmp
|
||||
;env[TMPDIR] = /tmp
|
||||
;env[TEMP] = /tmp
|
||||
|
||||
; Additional php.ini defines, specific to this pool of workers. These settings
|
||||
; overwrite the values previously defined in the php.ini. The directives are the
|
||||
; same as the PHP SAPI:
|
||||
; php_value/php_flag - you can set classic ini defines which can
|
||||
; be overwritten from PHP call 'ini_set'.
|
||||
; php_admin_value/php_admin_flag - these directives won't be overwritten by
|
||||
; PHP call 'ini_set'
|
||||
; For php_*flag, valid values are on, off, 1, 0, true, false, yes or no.
|
||||
|
||||
; Defining 'extension' will load the corresponding shared extension from
|
||||
; extension_dir. Defining 'disable_functions' or 'disable_classes' will not
|
||||
; overwrite previously defined php.ini values, but will append the new value
|
||||
; instead.
|
||||
|
||||
; Default Value: nothing is defined by default except the values in php.ini and
|
||||
; specified at startup with the -d argument
|
||||
;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
|
||||
;php_flag[display_errors] = off
|
||||
;php_admin_value[error_log] = /var/log/fpm-php.www.log
|
||||
;php_admin_flag[log_errors] = on
|
||||
;php_admin_value[memory_limit] = 32M
|
126
extra/php-pepedog/php.ini.patch
Normal file
126
extra/php-pepedog/php.ini.patch
Normal file
|
@ -0,0 +1,126 @@
|
|||
--- php.ini-production 2009-11-12 18:20:01.000000000 +0100
|
||||
+++ php.ini 2009-11-19 12:39:03.305274757 +0100
|
||||
@@ -376,7 +376,7 @@
|
||||
; or per-virtualhost web server configuration file. This directive is
|
||||
; *NOT* affected by whether Safe Mode is turned On or Off.
|
||||
; http://php.net/open-basedir
|
||||
-;open_basedir =
|
||||
+open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/
|
||||
|
||||
; This directive allows you to disable certain functions for security reasons.
|
||||
; It receives a comma-delimited list of function names. This directive is
|
||||
@@ -781,7 +781,7 @@
|
||||
;;;;;;;;;;;;;;;;;;;;;;;;;
|
||||
|
||||
; UNIX: "/path1:/path2"
|
||||
-;include_path = ".:/php/includes"
|
||||
+include_path = ".:/usr/share/pear"
|
||||
;
|
||||
; Windows: "\path1;\path2"
|
||||
;include_path = ".;c:\php\includes"
|
||||
@@ -804,7 +804,7 @@
|
||||
|
||||
; Directory in which the loadable extensions (modules) reside.
|
||||
; http://php.net/extension-dir
|
||||
-; extension_dir = "./"
|
||||
+extension_dir = "/usr/lib/php/modules/"
|
||||
; On windows:
|
||||
; extension_dir = "ext"
|
||||
|
||||
@@ -938,53 +938,49 @@
|
||||
; If you only provide the name of the extension, PHP will look for it in its
|
||||
; default extension directory.
|
||||
;
|
||||
-; Windows Extensions
|
||||
-; Note that ODBC support is built in, so no dll is needed for it.
|
||||
-; Note that many DLL files are located in the extensions/ (PHP 4) ext/ (PHP 5)
|
||||
-; extension folders as well as the separate PECL DLL download (PHP 5).
|
||||
-; Be sure to appropriately set the extension_dir directive.
|
||||
-;
|
||||
-;extension=php_bz2.dll
|
||||
-;extension=php_curl.dll
|
||||
-;extension=php_dba.dll
|
||||
-;extension=php_exif.dll
|
||||
-;extension=php_fileinfo.dll
|
||||
-;extension=php_gd2.dll
|
||||
-;extension=php_gettext.dll
|
||||
-;extension=php_gmp.dll
|
||||
-;extension=php_intl.dll
|
||||
-;extension=php_imap.dll
|
||||
-;extension=php_interbase.dll
|
||||
-;extension=php_ldap.dll
|
||||
-;extension=php_mbstring.dll
|
||||
-;extension=php_ming.dll
|
||||
-;extension=php_mssql.dll
|
||||
-;extension=php_mysql.dll
|
||||
-;extension=php_mysqli.dll
|
||||
-;extension=php_oci8.dll ; Use with Oracle 10gR2 Instant Client
|
||||
-;extension=php_oci8_11g.dll ; Use with Oracle 11g Instant Client
|
||||
-;extension=php_openssl.dll
|
||||
-;extension=php_pdo_firebird.dll
|
||||
-;extension=php_pdo_mssql.dll
|
||||
-;extension=php_pdo_mysql.dll
|
||||
-;extension=php_pdo_oci.dll
|
||||
-;extension=php_pdo_odbc.dll
|
||||
-;extension=php_pdo_pgsql.dll
|
||||
-;extension=php_pdo_sqlite.dll
|
||||
-;extension=php_pgsql.dll
|
||||
-;extension=php_phar.dll
|
||||
-;extension=php_pspell.dll
|
||||
-;extension=php_shmop.dll
|
||||
-;extension=php_snmp.dll
|
||||
-;extension=php_soap.dll
|
||||
-;extension=php_sockets.dll
|
||||
-;extension=php_sqlite.dll
|
||||
-;extension=php_sqlite3.dll
|
||||
-;extension=php_sybase_ct.dll
|
||||
-;extension=php_tidy.dll
|
||||
-;extension=php_xmlrpc.dll
|
||||
-;extension=php_xsl.dll
|
||||
-;extension=php_zip.dll
|
||||
+;extension=bcmath.so
|
||||
+;extension=bz2.so
|
||||
+;extension=calendar.so
|
||||
+;extension=curl.so
|
||||
+;extension=dba.so
|
||||
+;extension=enchant.so
|
||||
+;extension=exif.so
|
||||
+;extension=ftp.so
|
||||
+;extension=gd.so
|
||||
+extension=gettext.so
|
||||
+;extension=gmp.so
|
||||
+;extension=iconv.so
|
||||
+;extension=imap.so
|
||||
+;extension=intl.so
|
||||
+;extension=json.so
|
||||
+;extension=ldap.so
|
||||
+;extension=mcrypt.so
|
||||
+;extension=mysql.so
|
||||
+;extension=mysqli.so
|
||||
+;extension=odbc.so
|
||||
+;extension=openssl.so
|
||||
+;extension=pdo.so
|
||||
+;extension=pdo_mysql.so
|
||||
+;extension=pdo_odbc.so
|
||||
+;extension=pdo_pgsql.so
|
||||
+;extension=pdo_sqlite.so
|
||||
+;extension=pgsql.so
|
||||
+;extension=phar.so
|
||||
+;extension=posix.so
|
||||
+;extension=pspell.so
|
||||
+;extension=shmop.so
|
||||
+;extension=snmp.so
|
||||
+;extension=soap.so
|
||||
+;extension=sockets.so
|
||||
+;extension=sqlite.so
|
||||
+;extension=sqlite3.so
|
||||
+;extension=sysvmsg.so
|
||||
+;extension=sysvsem.so
|
||||
+;extension=sysvshm.so
|
||||
+;extension=tidy.so
|
||||
+;extension=xmlrpc.so
|
||||
+;extension=xsl.so
|
||||
+;extension=zip.so
|
||||
|
||||
;;;;;;;;;;;;;;;;;;;
|
||||
; Module Settings ;
|
124
extra/php-pepedog/rc.d.php-fpm
Normal file
124
extra/php-pepedog/rc.d.php-fpm
Normal file
|
@ -0,0 +1,124 @@
|
|||
#!/bin/bash
|
||||
|
||||
. /etc/rc.conf
|
||||
. /etc/rc.d/functions
|
||||
|
||||
|
||||
wait_for_pid () {
|
||||
try=0
|
||||
|
||||
while test $try -lt 35 ; do
|
||||
|
||||
case "$1" in
|
||||
'created')
|
||||
if [ -f "$2" ] ; then
|
||||
try=''
|
||||
break
|
||||
fi
|
||||
;;
|
||||
|
||||
'removed')
|
||||
if [ ! -f "$2" ] ; then
|
||||
try=''
|
||||
break
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
|
||||
stat_append '.'
|
||||
try=`expr $try + 1`
|
||||
sleep 1
|
||||
|
||||
done
|
||||
|
||||
}
|
||||
|
||||
[ -d /var/run/php-fpm ] || install -d -m755 /var/run/php-fpm
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
stat_busy 'Starting php-fpm'
|
||||
|
||||
/usr/sbin/php-fpm
|
||||
|
||||
if [ "$?" != 0 ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
|
||||
wait_for_pid created /var/run/php-fpm/php-fpm.pid
|
||||
|
||||
if [ -n "$try" ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
else
|
||||
add_daemon php-fpm
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
|
||||
stop)
|
||||
stat_busy 'Gracefully shutting down php-fpm'
|
||||
|
||||
if [ ! -r /var/run/php-fpm/php-fpm.pid ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
|
||||
kill -QUIT `cat /var/run/php-fpm/php-fpm.pid`
|
||||
|
||||
wait_for_pid removed /var/run/php-fpm.pid
|
||||
|
||||
if [ -n "$try" ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
else
|
||||
rm_daemon php-fpm
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
|
||||
force-quit)
|
||||
stat_busy 'Terminating php-fpm'
|
||||
|
||||
if [ ! -r /var/run/php-fpm/php-fpm.pid ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
|
||||
kill -TERM `cat /var/run/php-fpm/php-fpm.pid`
|
||||
|
||||
wait_for_pid removed /var/run/php-fpm/php-fpm.pid
|
||||
|
||||
if [ -n "$try" ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
else
|
||||
rm_daemon php-fpm
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
|
||||
restart)
|
||||
$0 stop
|
||||
$0 start
|
||||
;;
|
||||
|
||||
reload)
|
||||
stat_busy 'Reload service php-fpm'
|
||||
|
||||
if [ ! -r /var/run/php-fpm/php-fpm.pid ] ; then
|
||||
stat_fail
|
||||
exit 1
|
||||
fi
|
||||
|
||||
kill -USR2 `cat /var/run/php-fpm/php-fpm.pid`
|
||||
stat_done
|
||||
;;
|
||||
|
||||
*)
|
||||
echo "usage: $0 {start|stop|force-quit|restart|reload}"
|
||||
exit 1
|
||||
;;
|
||||
|
||||
esac
|
BIN
extra/php-pepedog/suhosin-patch-5.3.3-0.9.10.patch.gz
Normal file
BIN
extra/php-pepedog/suhosin-patch-5.3.3-0.9.10.patch.gz
Normal file
Binary file not shown.
Loading…
Reference in a new issue