mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
aur/omxplayer-git: fix rpitardedness
This commit is contained in:
parent
9b36fe8016
commit
7fc1fcb814
2 changed files with 64 additions and 3 deletions
|
@ -10,16 +10,18 @@ pkgdesc="omxplayer is a command line media player for the RaspberryPi"
|
||||||
arch=('arm' 'armv6h')
|
arch=('arm' 'armv6h')
|
||||||
url="https://github.com/popcornmix/omxplayer"
|
url="https://github.com/popcornmix/omxplayer"
|
||||||
license=(GPL2)
|
license=(GPL2)
|
||||||
depends=(ffmpeg-compat raspberrypi-firmware-tools fbset)
|
depends=(ffmpeg raspberrypi-firmware-tools fbset)
|
||||||
makedepends=(git boost)
|
makedepends=(git boost)
|
||||||
optdepends=(ttf-freefont)
|
optdepends=(ttf-freefont)
|
||||||
provides=(omxplayer)
|
provides=(omxplayer)
|
||||||
conflicts=(omxplayer omxplayer-bin)
|
conflicts=(omxplayer omxplayer-bin)
|
||||||
source=(git://github.com/popcornmix/omxplayer.git
|
source=(git://github.com/popcornmix/omxplayer.git
|
||||||
omxplayer.arch Makefile.arch Makefile.include.arch)
|
omxplayer.arch Makefile.arch Makefile.include.arch
|
||||||
|
gen_version.patch)
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd omxplayer
|
cd omxplayer
|
||||||
|
patch -p1 -i ../gen_version.patch
|
||||||
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
|
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -46,4 +48,5 @@ package() {
|
||||||
md5sums=('SKIP'
|
md5sums=('SKIP'
|
||||||
'305f8fedbc4638434475c4a83ee78578'
|
'305f8fedbc4638434475c4a83ee78578'
|
||||||
'cfd349a05cd8c456c6df25eec3fa6d86'
|
'cfd349a05cd8c456c6df25eec3fa6d86'
|
||||||
'ef4586f5e8b042e4940c0e43f3185bf1')
|
'ef4586f5e8b042e4940c0e43f3185bf1'
|
||||||
|
'da0a86d33865c0f93dbf226ec397f488')
|
||||||
|
|
58
aur/omxplayer-git/gen_version.patch
Normal file
58
aur/omxplayer-git/gen_version.patch
Normal file
|
@ -0,0 +1,58 @@
|
||||||
|
From d865922e7de11ae33618954f16888303b39ec7b3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Sergio Conde <skgsergio@gmail.com>
|
||||||
|
Date: Wed, 7 Aug 2013 23:19:57 +0200
|
||||||
|
Subject: [PATCH] Converted gen_version.sh to bash script. Fixes
|
||||||
|
popcornmix/omxplayer#26
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
gen_version.sh | 16 ++++++++--------
|
||||||
|
2 files changed, 9 insertions(+), 9 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index a77f369..7878bc8 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -44,7 +44,7 @@ all: omxplayer.bin
|
||||||
|
$(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
|
||||||
|
|
||||||
|
version:
|
||||||
|
- sh gen_version.sh > version.h
|
||||||
|
+ bash gen_version.sh > version.h
|
||||||
|
|
||||||
|
omxplayer.bin: version $(OBJS)
|
||||||
|
$(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
|
||||||
|
diff --git a/gen_version.sh b/gen_version.sh
|
||||||
|
index da810cd..fd4660f 100755
|
||||||
|
--- a/gen_version.sh
|
||||||
|
+++ b/gen_version.sh
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/bin/sh
|
||||||
|
+#!/bin/bash
|
||||||
|
#
|
||||||
|
# Author:
|
||||||
|
# Sergio Conde <skgsergio@gmail.com>
|
||||||
|
@@ -24,12 +24,12 @@ if [ x"$?" = x"0" ]; then
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
-echo "#ifndef __VERSION_H__"
|
||||||
|
-echo "#define __VERSION_H__\n"
|
||||||
|
+echo -e "#ifndef __VERSION_H__"
|
||||||
|
+echo -e "#define __VERSION_H__\n"
|
||||||
|
|
||||||
|
-echo "#define VERSION_DATE \"$date\""
|
||||||
|
-echo "#define VERSION_HASH \"$hash\""
|
||||||
|
-echo "#define VERSION_BRANCH \"$branch\""
|
||||||
|
-echo "#define VERSION_REPO \"$repo\""
|
||||||
|
+echo -e "#define VERSION_DATE \"$date\""
|
||||||
|
+echo -e "#define VERSION_HASH \"$hash\""
|
||||||
|
+echo -e "#define VERSION_BRANCH \"$branch\""
|
||||||
|
+echo -e "#define VERSION_REPO \"$repo\""
|
||||||
|
|
||||||
|
-echo "\n#endif"
|
||||||
|
\ No newline at end of file
|
||||||
|
+echo -e "\n#endif"
|
||||||
|
--
|
||||||
|
1.8.1.6
|
||||||
|
|
Loading…
Reference in a new issue