core/linux-aarch64 to 4.15.0-1

This commit is contained in:
Kevin Mihelich 2018-01-30 00:46:42 +00:00
parent 037f0e3ac2
commit 81478b9c12
5 changed files with 271 additions and 144 deletions

View file

@ -1,7 +1,7 @@
From 3c5582d1d2a45c7bf936fc629aea1cb007920e22 Mon Sep 17 00:00:00 2001
From 8a928056900e2d1172f174c54965744755654612 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/3] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++

View file

@ -1,7 +1,7 @@
From 33e8314cb096c9d61ebf1a09fc06a0edaa76f4f9 Mon Sep 17 00:00:00 2001
From d85e631bc608f1e310143d7c279db2d5cd5344c8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 7 Aug 2017 19:34:57 -0600
Subject: [PATCH 2/3] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
---
@ -9,10 +9,10 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
index fef82274a39d..64ff6318fdb0 100644
index 4f28628aa091..07e5f161958c 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -619,7 +619,7 @@
@@ -630,7 +630,7 @@
};
&pwm0 {

View file

@ -1,53 +0,0 @@
From ce7e420bba3d27c6b4f28526645b1fbd825e16fa Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Wed, 31 May 2017 11:59:56 +0200
Subject: [PATCH 3/3] arm64: dts: rockchip: enable display subsystem on
rk3399-firefly
Enable the graphics-related nodes on the rk3399-firefly which makes
it possible to see output on the on-board hdmi output.
Signed-off-by: Heiko Stuebner <heiko@sntech.de>
---
arch/arm64/boot/dts/rockchip/rk3399-firefly.dts | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
index 64ff6318fdb0..f7c5076d9416 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -255,6 +255,11 @@
status = "okay";
};
+&hdmi {
+ ddc-i2c-bus = <&i2c3>;
+ status = "okay";
+};
+
&i2c0 {
clock-frequency = <400000>;
i2c-scl-rising-time-ns = <168>;
@@ -728,3 +733,19 @@
status = "okay";
dr_mode = "host";
};
+
+&vopb {
+ status = "okay";
+};
+
+&vopb_mmu {
+ status = "okay";
+};
+
+&vopl {
+ status = "okay";
+};
+
+&vopl_mmu {
+ status = "okay";
+};
--
2.15.0

View file

@ -4,10 +4,10 @@
buildarch=8
pkgbase=linux-aarch64
_srcname=linux-4.14
_srcname=linux-4.15
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform"
pkgver=4.14.15
pkgver=4.15.0
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
@ -15,19 +15,16 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
'0003-arm64-dts-rockchip-enable-display-subsystem-on-rk339.patch'
'config'
'linux.preset'
'99-linux.hook')
md5sums=('bacdb9ffdcd922aa069a5e1520160e24'
'de16c219ce4548d63ff7d6c670340a9e'
'b99ebc82965c3405ee041025a9cd5fea'
'e798199b00b1467b186b8c965c201b95'
'49739c0b3550f1a85d52a7e24d846beb'
'23363bb2af5668dfd17ee8762e831967'
md5sums=('0d701ac1e2a67d47ce7127432df2c32b'
'c656b4169dd6c87f93dfb49edea3ddbf'
'79459eaa00aa5de588c73f3076f0907b'
'f5183ec7a29254844369b08271f360d7'
'b5ef67d6086e20de7b82265f562f88b1'
'1d4477026533efaa0358a40855d50a83')
@ -35,12 +32,11 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# ALARM patches
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch
git apply ../0003-arm64-dts-rockchip-enable-display-subsystem-on-rk339.patch
cat "${srcdir}/config" > ./.config

File diff suppressed because it is too large Load diff