alarm/xf86-video-armsoc-odroid fix

This commit is contained in:
Kevin Mihelich 2015-02-15 18:20:36 +00:00
parent 3eace5c548
commit 85240baaf0
2 changed files with 33 additions and 2 deletions

View file

@ -0,0 +1,24 @@
From a06634be9fe056b051e271ad4b83607d4b4ee2fc Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 15 Feb 2015 11:16:26 -0700
Subject: [PATCH] compat for newer xorg
---
src/armsoc_dumb.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/armsoc_dumb.c b/src/armsoc_dumb.c
index 8f29b7a..879d77c 100644
--- a/src/armsoc_dumb.c
+++ b/src/armsoc_dumb.c
@@ -27,6 +27,7 @@
#include <errno.h>
#include <unistd.h>
+#include <xorg-server.h>
#include <xf86.h>
#include <xf86drm.h>
#include <xf86drmMode.h>
--
2.3.0

View file

@ -14,14 +14,21 @@ makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverpro
options=('!libtool')
conflicts=(xf86-video-armsoc)
provides=(xf86-video-armsoc)
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#commit=${_commit}")
md5sums=('SKIP')
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#commit=${_commit}"
'0001-compat-for-newer-xorg.patch')
md5sums=('SKIP'
'c1d56bbecc8f4749b47052a90360aea6')
pkgver() {
cd $pkgname
echo $(git rev-list --count makepkg).$(git rev-parse --short makepkg)
}
prepare() {
cd $pkgname
git apply ../0001-compat-for-newer-xorg.patch
}
build() {
cd $pkgname