mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/rust to 1.60.0-1
This commit is contained in:
parent
e5cdd85842
commit
862038427c
3 changed files with 12 additions and 12 deletions
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||||
index 7d9b3da48ecb..3fa3d3bca373 100644
|
index f5ae8103cb05..a41a80a6c359 100644
|
||||||
--- a/src/bootstrap/dist.rs
|
--- a/src/bootstrap/dist.rs
|
||||||
+++ b/src/bootstrap/dist.rs
|
+++ b/src/bootstrap/dist.rs
|
||||||
@@ -998,7 +998,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
@@ -981,7 +981,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||||
let dirent = dirent.expect("read dir entry");
|
let dirent = dirent.expect("read dir entry");
|
||||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
||||||
4 files changed, 12 insertions(+), 3 deletions(-)
|
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||||
index 08bcea26ebe1..566f1ebbbc6a 100644
|
index 7a0d9a212c9d..a53bd70b224a 100644
|
||||||
--- a/compiler/rustc_session/src/config.rs
|
--- a/compiler/rustc_session/src/config.rs
|
||||||
+++ b/compiler/rustc_session/src/config.rs
|
+++ b/compiler/rustc_session/src/config.rs
|
||||||
@@ -1612,7 +1612,7 @@ pub fn parse_target_triple(
|
@@ -1741,7 +1741,7 @@ pub fn parse_target_triple(
|
||||||
early_error(error_format, &format!("target file {:?} does not exist", path))
|
early_error(error_format, &format!("target file {:?} does not exist", path))
|
||||||
})
|
})
|
||||||
}
|
}
|
||||||
|
@ -50,10 +50,10 @@ index 165505ee7313..00a7f5c2f8c1 100644
|
||||||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||||
f64:32:64-f80:32-n8:16:32-S128"
|
f64:32:64-f80:32-n8:16:32-S128"
|
||||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||||
index ca1949b9f75a..05d57c421843 100644
|
index 92678aed5b1a..52714d175dcc 100644
|
||||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||||
@@ -2380,6 +2380,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
@@ -2392,6 +2392,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||||
Ok(TargetTriple::TargetPath(canonicalized_path))
|
Ok(TargetTriple::TargetPath(canonicalized_path))
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -70,10 +70,10 @@ index ca1949b9f75a..05d57c421843 100644
|
||||||
///
|
///
|
||||||
/// If this target is a path, the file name (without extension) is returned.
|
/// If this target is a path, the file name (without extension) is returned.
|
||||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||||
index c2484f2d8f66..bfda13509939 100644
|
index aefbb398286a..6d902647eeea 100644
|
||||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||||
@@ -14,7 +14,7 @@ pub fn target() -> Target {
|
@@ -15,7 +15,7 @@ pub fn target() -> Target {
|
||||||
| SanitizerSet::THREAD;
|
| SanitizerSet::THREAD;
|
||||||
|
|
||||||
Target {
|
Target {
|
||||||
|
|
|
@ -16,7 +16,7 @@ highmem=1
|
||||||
pkgbase=rust
|
pkgbase=rust
|
||||||
pkgname=(rust rust-src)
|
pkgname=(rust rust-src)
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgver=1.59.0
|
pkgver=1.60.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||||
url=https://www.rust-lang.org/
|
url=https://www.rust-lang.org/
|
||||||
|
@ -36,13 +36,13 @@ source=(
|
||||||
0002-compiler-Change-LLVM-targets.patch
|
0002-compiler-Change-LLVM-targets.patch
|
||||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||||
)
|
)
|
||||||
sha256sums=('a7c8eeaee85bfcef84c96b02b3171d1e6540d15179ff83dddd9eafba185f85f9'
|
sha256sums=('20ca826d1cf674daf8e22c4f8c4b9743af07973211c839b85839742314c838b7'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'7b33955031f9a9c5d63077dedb0f99d77e4e7c996266952c1cec55626dca5dfc'
|
'7b33955031f9a9c5d63077dedb0f99d77e4e7c996266952c1cec55626dca5dfc'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'0f8cfbe0387dd62909fe9cb9523223ae1c2319494e2caf5fa4d0592198631b3e'
|
'0f8cfbe0387dd62909fe9cb9523223ae1c2319494e2caf5fa4d0592198631b3e'
|
||||||
'd97e87bfc21094efd5c8a9767f562ed8cdb355df9cd344826786eba5a2739dcb'
|
'7a69e38716957ff074c5f932a82bbea1d9a3713a3f39d9085977cdc8df336c43'
|
||||||
'93eeb6de7c455f8eb1e33d5c24784b37b5c1faafde47134106a8837e42004338'
|
'2ef851be0562d13431c5c81df0161f92984e79845fe986182225f2dae58a9452'
|
||||||
'f8ea25693ba42c7e185aa8677218783fe0cd60a3370926cb6996ec898b43d691')
|
'f8ea25693ba42c7e185aa8677218783fe0cd60a3370926cb6996ec898b43d691')
|
||||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||||
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
||||||
|
|
Loading…
Reference in a new issue