extra/libreoffice-fresh to 5.3.3-2

This commit is contained in:
Kevin Mihelich 2017-06-06 23:49:49 +00:00
parent 134efa3403
commit 8ac9d2ec60
2 changed files with 16 additions and 42 deletions

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=5.3.3.2
pkgver=5.3.3
pkgrel=1
pkgrel=2
arch=('i686' 'x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -141,7 +141,7 @@ sha256sums=('9632956926d9d5c9049ce5b81c2673f298ae73b873d53cce8cfaea8ee243619a'
'f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770'
'a0bd3e0186e043223bfb231a888e2bfb06c78ee2e07c2f0eca434236d173cf34'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'ad028513c29691b3ec3a35de21af2f224b48015afe0fbcc6fb834fdf7f613165'
'ff546050a1789b0cf62369524fe939526541e32a74bdd0c9137bbe0d40d7f533'
'76f62957d0058092b11316357d9d716a62b48a53e5277426ffa87429ab5510e4'
'd24cfcb556ae1db02087c49012bbc4621f9ef7e3465ca832e1410326d260f283')
@ -164,8 +164,8 @@ prepare() {
rm ${srcdir}/ext_sources/185d60944ea767075d27247c3162b3bc-unowinreg.dll
cp -f ${srcdir}/185d60944ea767075d27247c3162b3bc-unowinreg.dll ${srcdir}/ext_sources
# fix not upstreamable pyuno paths - patch taken from Debian
# patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
# fix not upstreamable pyuno paths - FS#54250
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do

View file

@ -1,44 +1,18 @@
diff --git a/desktop/scripts/soffice.sh b/desktop/scripts/soffice.sh
index defd7b2..ea2a809 100755
--- a/desktop/scripts/soffice.sh
+++ b/desktop/scripts/soffice.sh
@@ -128,6 +128,9 @@ if echo "$checks" | grep -q "cc" ; then
exit 1;
fi
+PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
+export PYTHONPATH
+
case "`uname -s`" in
NetBSD|OpenBSD|FreeBSD|DragonFly)
# this is a temporary hack until we can live with the default search paths
diff --git a/pyuno/source/module/uno.py b/pyuno/source/module/uno.py
index f93ac5e..92a2891 100644
--- a/pyuno/source/module/uno.py
+++ b/pyuno/source/module/uno.py
@@ -26,8 +26,12 @@
--- a/pyuno/source/module/uno.py 2017-05-03 18:46:29.000000000 +0200
+++ b/pyuno/source/module/uno.py.new 2017-06-06 17:11:27.585959637 +0200
@@ -16,8 +16,14 @@
# except in compliance with the License. You may obtain a copy of
# the License at http://www.apache.org/licenses/LICENSE-2.0 .
#
-import pyuno
+
+# Special modification to make uno load on Arch
+import os
import sys
+sys.path.append("/usr/lib/libreoffice/program/")
+os.putenv("URE_BOOTSTRAP", "vnd.sun.start.pathname:/usr/lib/libreoffice/program/fundamentalrc")
+
+import pyuno
import traceback
import warnings
+sys.path.append('/usr/lib/libreoffice/program')
+if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
+ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:/usr/lib/libreoffice/program/fundamentalrc"
import pyuno
try:
diff --git a/pyuno/source/officehelper.py b/pyuno/source/officehelper.py
index 610ac5f..df243d0 100755
--- a/pyuno/source/officehelper.py
+++ b/pyuno/source/officehelper.py
@@ -44,7 +44,7 @@ def bootstrap():
if "UNO_PATH" in os.environ:
sOffice = os.environ["UNO_PATH"]
else:
- sOffice = "" # lets hope for the best
+ sOffice = "/usr/lib/libreoffice/program"
sOffice = os.path.join(sOffice, "soffice")
if platform.startswith("win"):
sOffice += ".exe"