mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/chromium to 27.0.1453.93-1
This commit is contained in:
parent
677645093f
commit
8d5a548182
6 changed files with 27 additions and 154 deletions
|
@ -16,15 +16,15 @@ buildarch=4
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=26.0.1410.63
|
||||
pkgrel=2
|
||||
pkgver=27.0.1453.93
|
||||
pkgrel=1
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.chromium.org/"
|
||||
license=('BSD')
|
||||
depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss'
|
||||
'libgcrypt' 'ttf-font' 'udev' 'dbus' 'flac' 'opus' 'libwebp'
|
||||
'speech-dispatcher' 'pciutils' 'desktop-file-utils'
|
||||
'speech-dispatcher' 'pciutils' 'libpulse' 'desktop-file-utils'
|
||||
'hicolor-icon-theme')
|
||||
makedepends=('python2' 'perl' 'gperf' 'yasm' 'mesa' 'libgnome-keyring'
|
||||
'elfutils' 'subversion')
|
||||
|
@ -39,44 +39,29 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
|
|||
chromium.desktop
|
||||
chromium.default
|
||||
chromium.sh
|
||||
chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
|
||||
chromium-25.0.1364.152-fix-crash-when-cups-is-down.patch
|
||||
chromium-ppapi-r0.patch
|
||||
chromium-26.0.1410.43-audio-buffer-size.patch
|
||||
chromium-pnacl-r0.patch
|
||||
chromium-26.0.1410.43-speechd-0.8.patch
|
||||
die-sysroot-die.patch)
|
||||
sha256sums=('7af8f70745992afdee0196039b5beab1b86b6de7fa70ca4f4a04dc335f034b3f'
|
||||
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
|
||||
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
|
||||
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
|
||||
'c1baf14121502efbc2a31b64029dcafa0e28ca5b71ad0e28a3c6342d18198615'
|
||||
'36ff43d8e85a7eac305727057c4ffd45eb7a357ce212a4a3f153037bc34a5ace'
|
||||
'1f4b57670d317959bc2dc60e5d2a44aa8fc6028f7ed540cdb502fa0aa99c81bd'
|
||||
'5af41119d383b10c21f98f0e02d2259cc8cf60eefdb2fa737d8ed87d4c01f056'
|
||||
'9875ffcc0e9ae9420876ac66b130b1b017d445a031d43cbe0119793e1fb3781c'
|
||||
'23b04468881642ffdc8457016c8f91df395dfccb4af2ad6b758168180ae070f3'
|
||||
'66705264d9e679a58ed522b4475a06c8a5a4fe52a709c537b1a7d5aa43fb6c84')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/chromium-$pkgver"
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# Remove ARM sysroot garbage
|
||||
patch -Np1 -i "$srcdir/die-sysroot-die.patch"
|
||||
|
||||
# Fix build with glibc 2.16
|
||||
patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
|
||||
|
||||
# http://code.google.com/p/chromium/issues/detail?id=160574
|
||||
patch -Np1 -i "$srcdir/chromium-25.0.1364.152-fix-crash-when-cups-is-down.patch"
|
||||
|
||||
# Fix build without NaCl glibc toolchain (patch from Gentoo)
|
||||
patch -Np0 -i "$srcdir/chromium-ppapi-r0.patch"
|
||||
# Fix build without pnacl (patch from Gentoo)
|
||||
patch -Np0 -i "$srcdir/chromium-pnacl-r0.patch"
|
||||
|
||||
# Fix header location for speech-dispatcher 0.8 (patch from PLD Linux)
|
||||
patch -Np2 -i "$srcdir/chromium-26.0.1410.43-speechd-0.8.patch"
|
||||
|
||||
# http://code.google.com/p/chromium/issues/detail?id=178626
|
||||
patch -Np1 -i "$srcdir/chromium-26.0.1410.43-audio-buffer-size.patch"
|
||||
|
||||
# Use Python 2
|
||||
find . -type f -exec sed -i -r \
|
||||
-e 's|/usr/bin/python$|&2|g' \
|
||||
|
@ -85,10 +70,12 @@ build() {
|
|||
# There are still a lot of relative calls which need a workaround
|
||||
mkdir "$srcdir/python2-path"
|
||||
ln -s /usr/bin/python2 "$srcdir/python2-path/python"
|
||||
export PATH="$srcdir/python2-path:$PATH"
|
||||
}
|
||||
|
||||
ln -s "$srcdir/pepper_${_nacl_sdk%%.*}/toolchain/linux_x86_newlib" \
|
||||
native_client/toolchain/linux_x86_newlib
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
export PATH="$srcdir/python2-path:$PATH"
|
||||
|
||||
# CFLAGS are passed through release_extra_cflags below
|
||||
export -n CFLAGS CXXFLAGS
|
||||
|
@ -101,6 +88,7 @@ build() {
|
|||
-Dlinux_link_gsettings=1 \
|
||||
-Dlinux_link_libpci=1 \
|
||||
-Dlinux_link_libspeechd=1 \
|
||||
-Dlinux_link_pulseaudio=1 \
|
||||
-Dlinux_sandbox_path=/usr/lib/chromium/chromium-sandbox \
|
||||
-Dlinux_strip_binary=1 \
|
||||
-Dlinux_use_gold_binary=0 \
|
||||
|
@ -139,7 +127,7 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/chromium-$pkgver"
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
|
||||
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
diff -upr chromium-20.0.1132.57.orig/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h chromium-20.0.1132.57/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
|
||||
--- chromium-20.0.1132.57.orig/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h 2012-07-10 10:48:31.000000000 +0300
|
||||
+++ chromium-20.0.1132.57/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h 2012-07-11 23:44:11.000000000 +0300
|
||||
@@ -243,14 +243,13 @@ struct kernel_rusage {
|
||||
long ru_nivcsw;
|
||||
};
|
||||
|
||||
-struct siginfo;
|
||||
#if defined(__i386__) || defined(__arm__) || defined(__PPC__)
|
||||
|
||||
/* include/asm-{arm,i386,mips,ppc}/signal.h */
|
||||
struct kernel_old_sigaction {
|
||||
union {
|
||||
void (*sa_handler_)(int);
|
||||
- void (*sa_sigaction_)(int, struct siginfo *, void *);
|
||||
+ void (*sa_sigaction_)(int, siginfo_t *, void *);
|
||||
};
|
||||
unsigned long sa_mask;
|
||||
unsigned long sa_flags;
|
||||
@@ -287,13 +286,13 @@ struct kernel_sigaction {
|
||||
unsigned long sa_flags;
|
||||
union {
|
||||
void (*sa_handler_)(int);
|
||||
- void (*sa_sigaction_)(int, struct siginfo *, void *);
|
||||
+ void (*sa_sigaction_)(int, siginfo_t *, void *);
|
||||
};
|
||||
struct kernel_sigset_t sa_mask;
|
||||
#else
|
||||
union {
|
||||
void (*sa_handler_)(int);
|
||||
- void (*sa_sigaction_)(int, struct siginfo *, void *);
|
||||
+ void (*sa_sigaction_)(int, siginfo_t *, void *);
|
||||
};
|
||||
unsigned long sa_flags;
|
||||
void (*sa_restorer)(void);
|
|
@ -1,68 +0,0 @@
|
|||
From b824ad5ee90704db9942857145f04b8542924b12 Mon Sep 17 00:00:00 2001
|
||||
From: "noamsml@google.com"
|
||||
<noamsml@google.com@0039d316-1c4b-4281-b951-d872f2087c98>
|
||||
Date: Thu, 28 Feb 2013 19:00:49 +0000
|
||||
Subject: [PATCH] Fix crash in chrome when trying to print with CUPS down
|
||||
|
||||
This is a workaround for GTK bug https://bugzilla.gnome.org/show_bug.cgi?id=686838.
|
||||
|
||||
Removed listing of printers when setting up default settings in native print dialog,
|
||||
as it is not necessary (behavior verified to be unchanged). Added check to ensure
|
||||
print preview dialog does not try to instantiate a printer list when selecting a
|
||||
cloud printer, as this is also unnecessary (again, no behavior change).
|
||||
|
||||
BUG=160574
|
||||
|
||||
|
||||
Review URL: https://chromiumcodereview.appspot.com/12374003
|
||||
|
||||
git-svn-id: svn://svn.chromium.org/chrome/trunk/src@185284 0039d316-1c4b-4281-b951-d872f2087c98
|
||||
---
|
||||
chrome/browser/printing/print_dialog_gtk.cc | 18 +++++-------------
|
||||
1 file changed, 5 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/chrome/browser/printing/print_dialog_gtk.cc b/chrome/browser/printing/print_dialog_gtk.cc
|
||||
index 70fe427..d8cb419 100644
|
||||
--- a/chrome/browser/printing/print_dialog_gtk.cc
|
||||
+++ b/chrome/browser/printing/print_dialog_gtk.cc
|
||||
@@ -130,21 +130,11 @@ PrintDialogGtk::~PrintDialogGtk() {
|
||||
|
||||
void PrintDialogGtk::UseDefaultSettings() {
|
||||
DCHECK(!page_setup_);
|
||||
+ DCHECK(!printer_);
|
||||
|
||||
// |gtk_settings_| is a new object.
|
||||
gtk_settings_ = gtk_print_settings_new();
|
||||
-
|
||||
- scoped_ptr<GtkPrinterList> printer_list(new GtkPrinterList);
|
||||
- printer_ = printer_list->default_printer();
|
||||
- if (printer_) {
|
||||
- g_object_ref(printer_);
|
||||
- gtk_print_settings_set_printer(gtk_settings_,
|
||||
- gtk_printer_get_name(printer_));
|
||||
- page_setup_ = gtk_printer_get_default_page_size(printer_);
|
||||
- }
|
||||
-
|
||||
- if (!page_setup_)
|
||||
- page_setup_ = gtk_page_setup_new();
|
||||
+ page_setup_ = gtk_page_setup_new();
|
||||
|
||||
// No page range to initialize for default settings.
|
||||
PageRanges ranges_vector;
|
||||
@@ -173,10 +163,12 @@ bool PrintDialogGtk::UpdateSettings(const base::DictionaryValue& job_settings,
|
||||
return false;
|
||||
}
|
||||
|
||||
+ bool is_cloud_print = job_settings.HasKey(printing::kSettingCloudPrintId);
|
||||
+
|
||||
if (!gtk_settings_)
|
||||
gtk_settings_ = gtk_print_settings_new();
|
||||
|
||||
- if (!print_to_pdf) {
|
||||
+ if (!print_to_pdf && !is_cloud_print) {
|
||||
scoped_ptr<GtkPrinterList> printer_list(new GtkPrinterList);
|
||||
printer_ = printer_list->GetPrinterWithName(device_name.c_str());
|
||||
if (printer_) {
|
||||
--
|
||||
1.7.10
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
diff -upr chromium-26.0.1410.43.orig/media/audio/audio_util.cc chromium-26.0.1410.43/media/audio/audio_util.cc
|
||||
--- chromium-26.0.1410.43.orig/media/audio/audio_util.cc 2013-03-29 02:10:07.000000000 +0200
|
||||
+++ chromium-26.0.1410.43/media/audio/audio_util.cc 2013-03-29 02:21:41.000000000 +0200
|
||||
@@ -201,8 +201,6 @@ size_t GetAudioHardwareBufferSize() {
|
||||
HRESULT hr = CoreAudioUtil::GetPreferredAudioParameters(eRender, eConsole,
|
||||
¶ms);
|
||||
return FAILED(hr) ? kFallbackBufferSize : params.frames_per_buffer();
|
||||
-#elif defined(OS_LINUX)
|
||||
- return 512;
|
||||
#else
|
||||
return 2048;
|
||||
#endif
|
11
extra/chromium/chromium-pnacl-r0.patch
Normal file
11
extra/chromium/chromium-pnacl-r0.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ppapi/native_client/src/untrusted/pnacl_support_extension/pnacl_support_extension.gyp.orig 2013-03-27 19:49:17.000000000 +0100
|
||||
+++ ppapi/native_client/src/untrusted/pnacl_support_extension/pnacl_support_extension.gyp 2013-03-27 19:49:59.000000000 +0100
|
||||
@@ -13,7 +13,7 @@
|
||||
'target_name': 'pnacl_support_extension',
|
||||
'type': 'none',
|
||||
'conditions': [
|
||||
- ['disable_nacl==0 and disable_nacl_untrusted==0', {
|
||||
+ ['disable_nacl==0 and disable_pnacl==0 and disable_nacl_untrusted==0', {
|
||||
'dependencies': [
|
||||
'../../../../../ppapi/native_client/src/untrusted/pnacl_irt_shim/pnacl_irt_shim.gyp:pnacl_irt_shim',
|
||||
'../../../../../native_client/tools.gyp:prep_toolchain',
|
|
@ -1,11 +0,0 @@
|
|||
--- ppapi/ppapi_untrusted.gyp.orig 2012-06-12 10:20:16.000000000 +0200
|
||||
+++ ppapi/ppapi_untrusted.gyp 2012-06-12 10:20:52.000000000 +0200
|
||||
@@ -80,7 +80,7 @@
|
||||
],
|
||||
},
|
||||
'conditions': [
|
||||
- ['target_arch!="arm"', {
|
||||
+ ['target_arch!="arm" and disable_glibc==0', {
|
||||
'variables': {
|
||||
'build_glibc': 1,
|
||||
# NOTE: Use /lib, not /lib64 here; it is a symbolic link which
|
Loading…
Reference in a new issue