mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/mesa to 18.0.1-1
This commit is contained in:
parent
479f205d56
commit
8eb98edfd7
6 changed files with 125 additions and 136 deletions
|
@ -0,0 +1,71 @@
|
|||
From cd56731b2c63532d6ed97f7b39afa5977936b3bc Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <cd56731b2c63532d6ed97f7b39afa5977936b3bc.1523725229.git.jan.steffens@gmail.com>
|
||||
In-Reply-To: <ac8faf2b14ed1c9ce518eddfc9c5098b6f9c74dd.1523725229.git.jan.steffens@gmail.com>
|
||||
References: <ac8faf2b14ed1c9ce518eddfc9c5098b6f9c74dd.1523725229.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sat, 14 Apr 2018 18:43:23 +0200
|
||||
Subject: [PATCH 4/5] meson: Add library versions to swr drivers
|
||||
|
||||
This is for parity with autotools.
|
||||
|
||||
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
---
|
||||
src/gallium/drivers/swr/meson.build | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/gallium/drivers/swr/meson.build b/src/gallium/drivers/swr/meson.build
|
||||
index 43e1c5cc50..a6dbd7a3f6 100644
|
||||
--- a/src/gallium/drivers/swr/meson.build
|
||||
+++ b/src/gallium/drivers/swr/meson.build
|
||||
@@ -198,6 +198,7 @@ if with_swr_arches.contains('avx')
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -230,6 +231,7 @@ if with_swr_arches.contains('avx2')
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -257,30 +259,32 @@ if with_swr_arches.contains('knl')
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
|
||||
if with_swr_arches.contains('skx')
|
||||
swr_skx_args = cpp.first_supported_argument(
|
||||
'-target-cpu=x86-skylake', '-march=skylake-avx512', '-xCORE-AVX512',
|
||||
prefix : '''
|
||||
#if !defined(__AVX512F__) || !defined(__AVX512BW__)
|
||||
# error
|
||||
#endif ''',
|
||||
)
|
||||
if swr_skx_args == []
|
||||
error('Cannot find SKX support for swr.')
|
||||
endif
|
||||
|
||||
swr_arch_defines += '-DHAVE_SWR_SKX'
|
||||
swr_arch_libs += shared_library(
|
||||
'swrSKX',
|
||||
[files_swr_common, files_swr_arch],
|
||||
cpp_args : [swr_cpp_args, swr_skx_args, '-DKNOB_ARCH=KNOB_ARCH_AVX512'],
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
--
|
||||
2.16.2
|
||||
|
|
@ -0,0 +1,43 @@
|
|||
From 064f328419936a8a5df2b0474ae76196d92e6fa0 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <064f328419936a8a5df2b0474ae76196d92e6fa0.1523725229.git.jan.steffens@gmail.com>
|
||||
In-Reply-To: <ac8faf2b14ed1c9ce518eddfc9c5098b6f9c74dd.1523725229.git.jan.steffens@gmail.com>
|
||||
References: <ac8faf2b14ed1c9ce518eddfc9c5098b6f9c74dd.1523725229.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sat, 14 Apr 2018 18:49:14 +0200
|
||||
Subject: [PATCH 5/5] meson: Version libMesaOpenCL like autotools does
|
||||
|
||||
This is for parity with autotools. It names the library
|
||||
libMesaOpenCL.so.1.0.0 and points mesa.icd to the .1 symlink.
|
||||
|
||||
opencl_version now matches configure.ac's OPENCL_VERSION.
|
||||
|
||||
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
---
|
||||
src/gallium/targets/opencl/meson.build | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
|
||||
index bebe0547d4..317ad8dab4 100644
|
||||
--- a/src/gallium/targets/opencl/meson.build
|
||||
+++ b/src/gallium/targets/opencl/meson.build
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
opencl_link_args = []
|
||||
opencl_link_deps = []
|
||||
-opencl_version = '1.0'
|
||||
+opencl_version = '1'
|
||||
|
||||
if with_ld_version_script
|
||||
opencl_link_args += [
|
||||
@@ -55,7 +55,7 @@ libopencl = shared_library(
|
||||
cpp.find_library('clangLex', dirs : llvm_libdir),
|
||||
cpp.find_library('clangBasic', dirs : llvm_libdir),
|
||||
],
|
||||
- version : opencl_version,
|
||||
+ version : '@0@.0.0'.format(opencl_version),
|
||||
install : true,
|
||||
)
|
||||
|
||||
--
|
||||
2.16.2
|
||||
|
|
@ -9,8 +9,8 @@
|
|||
pkgbase=mesa
|
||||
pkgname=('libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
pkgver=18.0.0
|
||||
pkgrel=4
|
||||
pkgver=18.0.1
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols'
|
||||
|
@ -21,18 +21,16 @@ source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
|||
"meson_get_version.py::https://cgit.freedesktop.org/mesa/mesa/plain/bin/meson_get_version.py?h=mesa-18.0.0"
|
||||
LICENSE
|
||||
0001-glvnd-fix-gl-dot-pc.patch
|
||||
fix-install.diff
|
||||
fix-versions.diff
|
||||
ndebug.diff
|
||||
0004-meson-Add-library-versions-to-swr-drivers.patch
|
||||
0005-meson-Version-libMesaOpenCL-like-autotools-does.patch
|
||||
"atomic.patch::https://cgit.freedesktop.org/mesa/mesa/patch/?id=498faea103aa7966b435f21d8ff5e36172389b1e")
|
||||
sha512sums=('1494bb09357896a2505b3dcfec772268e28c765804f21e144948a314f1d79d99ff9f21062ef5860eb5a5a568b305a9c954585924a7ac8890fe1ebd8df3bcc396'
|
||||
sha512sums=('b0d610904b6f179a27b42aee5f479339e341926915cdc6adb08ac999a4a12539abc3776577e86af83e10381d9703ef1bca70bab81b43daf2c000622c9c3612d2'
|
||||
'SKIP'
|
||||
'cdc608d7b7de9e6eb6f1b2b4faef4864ac213d379b9dedc7c06e71726c2a1b88a0035d6ec50812a14ba4639e100158c6dff3a1d9456ab36c0a52988287c0d4bd'
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7'
|
||||
'75849eca72ca9d01c648d5ea4f6371f1b8737ca35b14be179e14c73cc51dca0739c333343cdc228a6d464135f4791bcdc21734e2debecd29d57023c8c088b028'
|
||||
'da32ac3b025282c584bfc962723151b6e11887e59e35086c616a987cb3a471051d60f2b303a91f37106ebb75621cbd9b3f560036f5beb88518cfe9d75c45ee03'
|
||||
'836f06af6feaa79a16bedd7a136d637b7f16e53d98b8b267554d98b5ff8c3fa45955b9e3ce0b8366d86860194e9147baf0257614fff85a471e2b90bbb3b1f5ab'
|
||||
'9ca216f8a84e767e4df2d02135004b173cb7905368573402cb8329e8e53101c5b519bf9b74cebfeab9ccd550b6c62c0fc88ec9a9e631023e011bb5634522c034'
|
||||
'0f5da6e48885713c7ddef9e5715e178e0a499bcb622d7f19e15b9e4b4647331d7bf14829218b6ab80f17bae90fd95b8df6a0a81203d8081686805ca5329531ff'
|
||||
'd3c01f61a0a0cc2f01e66e0126ad8b6386d4a53c1dc1b3b134800e4cd25507e458bac860cbed10cf4b46b04e8d50aba233870587b89c058fffd57436b48289bf'
|
||||
'75cd21bccc84a6b6b0de39c6d209c8bee0e5143b486433184ca078e8bc6797d30746be3ce5f7a89eea9bc3c7e2d68880412511fd6b9946252c7c7638523c6caa')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
|
@ -45,17 +43,9 @@ prepare() {
|
|||
# non-upstreamed ones
|
||||
patch -Np1 -i ../0001-glvnd-fix-gl-dot-pc.patch
|
||||
|
||||
# fix symlinks created for vdpau drivers to be relative
|
||||
# this is upstreamable
|
||||
patch -Np1 -i ../fix-install.diff
|
||||
|
||||
# fix library versioning
|
||||
# this is upstreamable
|
||||
patch -Np1 -i ../fix-versions.diff
|
||||
|
||||
# define NDEBUG for non-debug builds, like configure does
|
||||
# this is upstreamable
|
||||
patch -Np1 -i ../ndebug.diff
|
||||
# Upstreamed meson fixes
|
||||
patch -Np1 -i ../0004-meson-Add-library-versions-to-swr-drivers.patch
|
||||
patch -Np1 -i ../0005-meson-Version-libMesaOpenCL-like-autotools-does.patch
|
||||
|
||||
# file missing from tarball
|
||||
cp ../meson_get_version.py bin/
|
||||
|
@ -70,6 +60,7 @@ build() {
|
|||
|
||||
arch-meson mesa-$pkgver build \
|
||||
-D b_lto=false \
|
||||
-D b_ndebug=true \
|
||||
-D platforms=x11,wayland,drm,surfaceless \
|
||||
-D dri-drivers=nouveau \
|
||||
-D gallium-drivers=freedreno,nouveau,swrast,virgl${GALLIUM} \
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
diff -u -r mesa/bin/install_megadrivers.py mesa-patched/bin/install_megadrivers.py
|
||||
--- mesa/bin/install_megadrivers.py 2018-03-27 19:35:14.000000000 +0200
|
||||
+++ mesa-patched/bin/install_megadrivers.py 2018-03-28 10:27:15.898280592 +0200
|
||||
@@ -50,18 +50,13 @@
|
||||
print('installing {} to {}'.format(args.megadriver, driver))
|
||||
os.link(master, driver)
|
||||
|
||||
- try:
|
||||
- ret = os.getcwd()
|
||||
- os.chdir(to)
|
||||
-
|
||||
- name, ext = os.path.splitext(each)
|
||||
- while ext != '.so':
|
||||
- if os.path.exists(name):
|
||||
- os.unlink(name)
|
||||
- os.symlink(driver, name)
|
||||
- name, ext = os.path.splitext(name)
|
||||
- finally:
|
||||
- os.chdir(ret)
|
||||
+ name, ext = os.path.splitext(each)
|
||||
+ while ext != '.so':
|
||||
+ symlink = os.path.join(to, name)
|
||||
+ if os.path.exists(symlink):
|
||||
+ os.unlink(symlink)
|
||||
+ os.symlink(each, symlink)
|
||||
+ name, ext = os.path.splitext(name)
|
||||
os.unlink(master)
|
||||
|
||||
|
|
@ -1,74 +0,0 @@
|
|||
diff -u -r mesa/src/gallium/drivers/swr/meson.build mesa-patched/src/gallium/drivers/swr/meson.build
|
||||
--- mesa/src/gallium/drivers/swr/meson.build 2018-03-27 19:35:15.000000000 +0200
|
||||
+++ mesa-patched/src/gallium/drivers/swr/meson.build 2018-03-28 11:27:05.025710444 +0200
|
||||
@@ -198,6 +198,7 @@
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -230,6 +231,7 @@
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -257,6 +259,7 @@
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -281,6 +284,7 @@
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
diff -u -r mesa/src/gallium/targets/opencl/meson.build mesa-patched/src/gallium/targets/opencl/meson.build
|
||||
--- mesa/src/gallium/targets/opencl/meson.build 2018-03-27 19:35:15.000000000 +0200
|
||||
+++ mesa-patched/src/gallium/targets/opencl/meson.build 2018-03-28 11:28:56.345996522 +0200
|
||||
@@ -20,7 +20,6 @@
|
||||
|
||||
opencl_link_args = []
|
||||
opencl_link_deps = []
|
||||
-opencl_version = '1.0'
|
||||
|
||||
if with_ld_version_script
|
||||
opencl_link_args += [
|
||||
@@ -55,14 +54,14 @@
|
||||
cpp.find_library('clangLex', dirs : llvm_libdir),
|
||||
cpp.find_library('clangBasic', dirs : llvm_libdir),
|
||||
],
|
||||
- version : opencl_version,
|
||||
+ version : '1.0.0',
|
||||
install : true,
|
||||
)
|
||||
|
||||
if with_opencl_icd
|
||||
_config = configuration_data()
|
||||
_config.set('OPENCL_LIBNAME', 'MesaOpenCL')
|
||||
- _config.set('OPENCL_VERSION', opencl_version)
|
||||
+ _config.set('OPENCL_VERSION', '1')
|
||||
configure_file(
|
||||
configuration : _config,
|
||||
input : 'mesa.icd.in',
|
||||
diff -u -r mesa/src/gallium/targets/xa/meson.build mesa-patched/src/gallium/targets/xa/meson.build
|
||||
--- mesa/src/gallium/targets/xa/meson.build 2018-03-27 19:35:15.000000000 +0200
|
||||
+++ mesa-patched/src/gallium/targets/xa/meson.build 2018-03-28 11:10:32.110287167 +0200
|
||||
@@ -49,6 +49,7 @@
|
||||
dependencies : [
|
||||
dep_thread, driver_nouveau, driver_i915, driver_svga, driver_freedreno,
|
||||
],
|
||||
+ version : '2.3.0',
|
||||
install : true,
|
||||
)
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
diff --git i/meson.build w/meson.build
|
||||
index a4dfa62255..931e0389e6 100644
|
||||
--- i/meson.build
|
||||
+++ w/meson.build
|
||||
@@ -705,6 +705,8 @@ endif
|
||||
# Define DEBUG for debug builds only (debugoptimized is not included on this one)
|
||||
if get_option('buildtype') == 'debug'
|
||||
pre_args += '-DDEBUG'
|
||||
+else
|
||||
+ pre_args += '-DNDEBUG'
|
||||
endif
|
||||
|
||||
if get_option('shader-cache')
|
Loading…
Reference in a new issue