mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
71 lines
2.3 KiB
Diff
71 lines
2.3 KiB
Diff
From cd56731b2c63532d6ed97f7b39afa5977936b3bc Mon Sep 17 00:00:00 2001
|
|
Message-Id: <cd56731b2c63532d6ed97f7b39afa5977936b3bc.1523725229.git.jan.steffens@gmail.com>
|
|
In-Reply-To: <ac8faf2b14ed1c9ce518eddfc9c5098b6f9c74dd.1523725229.git.jan.steffens@gmail.com>
|
|
References: <ac8faf2b14ed1c9ce518eddfc9c5098b6f9c74dd.1523725229.git.jan.steffens@gmail.com>
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Sat, 14 Apr 2018 18:43:23 +0200
|
|
Subject: [PATCH 4/5] meson: Add library versions to swr drivers
|
|
|
|
This is for parity with autotools.
|
|
|
|
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
|
---
|
|
src/gallium/drivers/swr/meson.build | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/src/gallium/drivers/swr/meson.build b/src/gallium/drivers/swr/meson.build
|
|
index 43e1c5cc50..a6dbd7a3f6 100644
|
|
--- a/src/gallium/drivers/swr/meson.build
|
|
+++ b/src/gallium/drivers/swr/meson.build
|
|
@@ -198,6 +198,7 @@ if with_swr_arches.contains('avx')
|
|
link_args : [ld_args_gc_sections],
|
|
include_directories : [swr_incs],
|
|
dependencies : [dep_thread, dep_llvm],
|
|
+ version : '0.0.0',
|
|
install : true,
|
|
)
|
|
endif
|
|
@@ -230,6 +231,7 @@ if with_swr_arches.contains('avx2')
|
|
link_args : [ld_args_gc_sections],
|
|
include_directories : [swr_incs],
|
|
dependencies : [dep_thread, dep_llvm],
|
|
+ version : '0.0.0',
|
|
install : true,
|
|
)
|
|
endif
|
|
@@ -257,30 +259,32 @@ if with_swr_arches.contains('knl')
|
|
link_args : [ld_args_gc_sections],
|
|
include_directories : [swr_incs],
|
|
dependencies : [dep_thread, dep_llvm],
|
|
+ version : '0.0.0',
|
|
install : true,
|
|
)
|
|
endif
|
|
|
|
if with_swr_arches.contains('skx')
|
|
swr_skx_args = cpp.first_supported_argument(
|
|
'-target-cpu=x86-skylake', '-march=skylake-avx512', '-xCORE-AVX512',
|
|
prefix : '''
|
|
#if !defined(__AVX512F__) || !defined(__AVX512BW__)
|
|
# error
|
|
#endif ''',
|
|
)
|
|
if swr_skx_args == []
|
|
error('Cannot find SKX support for swr.')
|
|
endif
|
|
|
|
swr_arch_defines += '-DHAVE_SWR_SKX'
|
|
swr_arch_libs += shared_library(
|
|
'swrSKX',
|
|
[files_swr_common, files_swr_arch],
|
|
cpp_args : [swr_cpp_args, swr_skx_args, '-DKNOB_ARCH=KNOB_ARCH_AVX512'],
|
|
link_args : [ld_args_gc_sections],
|
|
include_directories : [swr_incs],
|
|
dependencies : [dep_thread, dep_llvm],
|
|
+ version : '0.0.0',
|
|
install : true,
|
|
)
|
|
endif
|
|
--
|
|
2.16.2
|
|
|