mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/gmic to 2.9.3-1
This commit is contained in:
parent
1dab4f0ec4
commit
902f89607c
2 changed files with 38 additions and 4 deletions
|
@ -11,14 +11,26 @@ highmem=1
|
|||
|
||||
pkgbase=gmic
|
||||
pkgname=(gmic zart gimp-plugin-gmic krita-plugin-gmic digikam-plugin-gmic)
|
||||
pkgver=2.9.2
|
||||
pkgrel=3
|
||||
pkgver=2.9.3
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url="https://gmic.eu/"
|
||||
license=(custom:CeCILL)
|
||||
makedepends=(cmake gimp qt5-base fftw openexr opencv eigen graphicsmagick qt5-tools digikam)
|
||||
source=(https://gmic.eu/files/source/gmic_$pkgver.tar.gz)
|
||||
sha256sums=('385db1ef3ef5805bc7bcb65255e188e349fc5e0ae35687b1b914291212bc4c91')
|
||||
source=(https://gmic.eu/files/source/gmic_$pkgver.tar.gz
|
||||
gmic-build-fix.patch::"https://github.com/dtschump/gmic/commit/52cd8898.patch"
|
||||
gmic-build-fix2.patch::"https://github.com/dtschump/gmic/commit/376f1b83.patch"
|
||||
gmic-qt-fix-build.patch)
|
||||
sha256sums=('eb55e75ac691d80f3a6a228bcf21ca5db064201b66aecde6d3ca5d1d8851f59b'
|
||||
'e73a7f9a256ca776106d029b7d247ae9f6f8aa8c49b8614be7f7d0e8afbc97c5'
|
||||
'e7f05332ced3784388c8f9aec4e0be36b334782d9d85fc77e3d9e6e063127706'
|
||||
'084891edbf1a005e5100bb6a69b4a6c9bbefe8898371c8fa442890e8b458942a')
|
||||
|
||||
prepare() {
|
||||
patch -d $pkgbase-$pkgver -p1 -i ../gmic-build-fix.patch
|
||||
patch -d $pkgbase-$pkgver -p1 -i ../gmic-build-fix2.patch
|
||||
patch -d $pkgbase-$pkgver/gmic-qt -p1 -i ../../gmic-qt-fix-build.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cmake -B build -S gmic-$pkgver \
|
||||
|
|
22
community/gmic/gmic-qt-fix-build.patch
Normal file
22
community/gmic/gmic-qt-fix-build.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff --git a/src/Host/digiKam/gmicqttoolplugin.cpp b/src/Host/digiKam/gmicqttoolplugin.cpp
|
||||
index c8da48d..b95c2c1 100644
|
||||
--- a/src/Host/digiKam/gmicqttoolplugin.cpp
|
||||
+++ b/src/Host/digiKam/gmicqttoolplugin.cpp
|
||||
@@ -35,7 +35,7 @@
|
||||
// Local includes
|
||||
|
||||
#include "MainWindow.h"
|
||||
-#include "Widgets/LanguageSelectionWidget.h"
|
||||
+#include "LanguageSettings.h"
|
||||
#include "DialogSettings.h"
|
||||
#include "gmic_qt.h"
|
||||
|
||||
@@ -118,7 +118,7 @@ void GmicQtToolPlugin::slotGmicQt()
|
||||
DialogSettings::loadSettings(GmicQt::GuiApplication);
|
||||
|
||||
// Translate according to current locale or configured language
|
||||
- QString lang = LanguageSelectionWidget::configuredTranslator();
|
||||
+ QString lang = LanguageSettings::configuredTranslator();
|
||||
|
||||
if (!lang.isEmpty() && (lang != "en"))
|
||||
{
|
Loading…
Reference in a new issue