mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs
This commit is contained in:
commit
90d44ee21c
8 changed files with 202 additions and 16 deletions
34
community/lxsession/PKGBUILD
Normal file
34
community/lxsession/PKGBUILD
Normal file
|
@ -0,0 +1,34 @@
|
|||
# $Id: PKGBUILD 53453 2011-08-03 19:42:00Z angvp $
|
||||
# Maintainer: Angel Velasquez <angvp@archlinux.org>
|
||||
# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - rebuild for libpng, remove this package when updated in ABS
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=lxsession
|
||||
pkgver=0.4.6.1
|
||||
pkgrel=1.1
|
||||
pkgdesc="Session manager of the LXDE Desktop (light version)"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL2')
|
||||
url="http://lxde.org/"
|
||||
groups=('lxde')
|
||||
depends=('gtk2' 'dbus')
|
||||
makedepends=('pkgconfig' 'intltool')
|
||||
replaces=('lxde-settings-daemon' 'lxsession-lite')
|
||||
conflicts=('lxsession-lite' 'lxde-settings-daemon')
|
||||
source=(http://downloads.sourceforge.net/lxde/lxsession-${pkgver}.tar.gz)
|
||||
md5sums=('e456b64c5ab3652a4dec661ec706dc6e')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/lxsession-$pkgver"
|
||||
./configure --sysconfdir=/etc --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/lxsession-$pkgver"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
32
community/toolame/PKGBUILD
Normal file
32
community/toolame/PKGBUILD
Normal file
|
@ -0,0 +1,32 @@
|
|||
# $Id: PKGBUILD 65411 2012-02-21 03:29:11Z spupykin $
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
|
||||
# Contributor: Victor Martinez Romanos <vmromanos@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Makefile replacements for ARM
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=toolame
|
||||
pkgver=02l
|
||||
pkgrel=9
|
||||
pkgdesc="An optimized mpeg 1/2 layer 2 audio encoder"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://sourceforge.net/projects/toolame"
|
||||
license=('LGPL')
|
||||
depends=('glibc')
|
||||
source=(http://downloads.sourceforge.net/sourceforge/toolame/toolame-02l.tgz
|
||||
toolame-02l.patch)
|
||||
md5sums=('5946e2dd78fbb57e54386b3b5d873fee'
|
||||
'7fe02630ce8f08bd279a4bce93e64128')
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
patch -p0 < ../toolame-02l.patch
|
||||
[ "$CARCH" = "x86_64" ] && sed -i "s|-march=i686|-march=x86-64|g" Makefile
|
||||
[ "$CARCH" = "arm" ] && sed -i "s|-march=i686|-march=armv5te|g" Makefile
|
||||
[ "$CARCH" = "armv7h" ] && sed -i "s|-march=i686|-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16|g" Makefile
|
||||
make
|
||||
install -D -m755 toolame $pkgdir/usr/bin/toolame
|
||||
}
|
86
community/toolame/toolame-02l.patch
Normal file
86
community/toolame/toolame-02l.patch
Normal file
|
@ -0,0 +1,86 @@
|
|||
--- Makefile 2006-02-07 16:32:57.000000000 +0100
|
||||
+++ Makefile 2006-02-07 16:39:07.000000000 +0100
|
||||
@@ -1,6 +1,3 @@
|
||||
-
|
||||
-CC = gcc
|
||||
-
|
||||
c_sources = \
|
||||
common.c \
|
||||
encode.c \
|
||||
@@ -28,16 +25,16 @@
|
||||
|
||||
#Uncomment this if you want to do some profiling/debugging
|
||||
#PG = -g -pg
|
||||
-PG = -fomit-frame-pointer
|
||||
+PG = -pipe
|
||||
|
||||
# Optimize flag. 3 is about as high as you can sanely go with GCC3.2.
|
||||
-OPTIM = -O3
|
||||
+OPTIM = -O2
|
||||
|
||||
# These flags are pretty much mandatory
|
||||
REQUIRED = -DNDEBUG -DINLINE=inline
|
||||
|
||||
#pick your architecture
|
||||
-ARCH = -march=pentium
|
||||
+ARCH = -march=i686
|
||||
#Possible x86 architectures
|
||||
#gcc3.2 => i386, i486, i586, i686, pentium, pentium-mmx
|
||||
# pentiumpro, pentium2, pentium3, pentium4, k6, k6-2, k6-3,
|
||||
@@ -56,7 +53,7 @@
|
||||
|
||||
NEW_02L_FIXES = -DNEWENCODE -DNEWATAN
|
||||
|
||||
-CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(TWEAKS) $(WARNINGS) $(NEW_02L_FIXES)
|
||||
+CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(FLAGS) $(WARNINGS) $(NEW_02L_FIXES)
|
||||
|
||||
PGM = toolame
|
||||
|
||||
@@ -75,16 +72,16 @@
|
||||
$(CC) $(CC_SWITCHES) -c $< -o $@
|
||||
|
||||
$(PGM): $(OBJ) Makefile
|
||||
- $(CC) $(PG) -o $(PGM) $(OBJ) $(LIBS)
|
||||
+ $(CC) -o $(PGM) $(OBJ) $(LIBS)
|
||||
|
||||
clean:
|
||||
- -rm $(OBJ) $(DEP)
|
||||
+ -rm $(OBJ) $(DEP) 2>/dev/null
|
||||
|
||||
megaclean:
|
||||
- -rm $(OBJ) $(DEP) $(PGM) \#*\# *~
|
||||
+ -rm $(OBJ) $(DEP) $(PGM) \#*\# *~ 2>/dev/null
|
||||
|
||||
distclean:
|
||||
- -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile
|
||||
+ -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile 2>/dev/null
|
||||
|
||||
tags: TAGS
|
||||
|
||||
|
||||
--- audio_read.c 2003-03-01 17:18:30.000000000 -0800
|
||||
+++ audio_read.c 2005-04-19 22:32:41.288998770 -0700
|
||||
@@ -436,7 +436,7 @@
|
||||
|
||||
if (pcm_aiff_data->sampleSize != sizeof (short) * BITS_IN_A_BYTE) {
|
||||
fprintf (stderr, "Sound data is not %d bits in \"%s\".\n",
|
||||
- sizeof (short) * BITS_IN_A_BYTE, file_name);
|
||||
+ (int)(sizeof (short) * BITS_IN_A_BYTE), file_name);
|
||||
exit (1);
|
||||
}
|
||||
|
||||
|
||||
--- fft.c 2003-03-01 23:14:45.000000000 -0800
|
||||
+++ fft.c 2005-04-19 22:47:49.019986989 -0700
|
||||
@@ -1190,9 +1190,9 @@
|
||||
static FLOAT atan_t[ATANSIZE];
|
||||
|
||||
INLINE FLOAT atan_table(FLOAT y, FLOAT x) {
|
||||
- int index;
|
||||
+ unsigned int index;
|
||||
|
||||
- index = (int)(ATANSCALE * fabs(y/x));
|
||||
+ index = (unsigned int)(ATANSCALE * fabs(y/x));
|
||||
if (index>=ATANSIZE)
|
||||
index = ATANSIZE-1;
|
||||
|
|
@ -4,11 +4,11 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - v7h needs to be built as -O1, workaround for gcc bug
|
||||
# - remove noautobuild on update
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=gmime
|
||||
pkgver=2.6.4
|
||||
pkgver=2.6.6
|
||||
pkgrel=1
|
||||
pkgdesc="Core mime parsing library"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -18,7 +18,7 @@ depends=('glib2' 'gpgme' 'zlib')
|
|||
makedepends=('gtk-sharp-2')
|
||||
options=('!libtool')
|
||||
source=(http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
|
||||
sha256sums=('2e85076c223fe8bf1392a7c1affa4454cb3bb6dec83016ad6e3230c65533f163')
|
||||
sha256sums=('efdff4cebaaa9b8dfe99832eb16f54ce60a7e02c5d1f3964f15d4ae0ddf6b3ee')
|
||||
|
||||
build() {
|
||||
# get rid of that .wapi errors in fakeroot
|
||||
|
@ -28,7 +28,8 @@ build() {
|
|||
[ $CARCH == "armv7h" ] && CFLAGS=`echo $CFLAGS | sed -e 's/-O2/-O1/'` && CXXFLAGS="$CFLAGS"
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
./configure --prefix=/usr --disable-static
|
||||
./configure --prefix=/usr --enable-smime \
|
||||
--disable-static
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 145025 2011-12-15 06:57:18Z andyrtr $
|
||||
# $Id: PKGBUILD 150689 2012-02-20 10:15:52Z andyrtr $
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -7,25 +7,31 @@
|
|||
plugrel=1
|
||||
|
||||
pkgname=gnutls
|
||||
pkgver=3.0.12
|
||||
pkgrel=1
|
||||
pkgver=3.0.13
|
||||
pkgrel=2
|
||||
pkgdesc="A library which provides a secure layer over a reliable transport layer"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL3' 'LGPL')
|
||||
url="http://www.gnu.org/software/gnutls/"
|
||||
install=gnutls.install
|
||||
options=('!libtool' '!zipman' 'makeflags')
|
||||
depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle>=2.4' 'p11-kit')
|
||||
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz)
|
||||
md5sums=('685fe5c00786c04b39e9aac362fa0cac')
|
||||
options=('!libtool' '!zipman')
|
||||
depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle>=2.4' 'p11-kit>=0.11')
|
||||
makedepends=('strace')
|
||||
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz{,.sig}
|
||||
buildfix.diff)
|
||||
md5sums=('ec549be557f31ea8c1738cb441ef23ec'
|
||||
'a6a9a1d148abd6377e7634eb03bdaf7c'
|
||||
'9b2a32b41391d95aeb8ddae3756fa191')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
# fix hanging make check - http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commit;h=642e6b5ca996325dc0ca6401a3b87039408b2585
|
||||
patch -Np1 -i ${srcdir}/buildfix.diff
|
||||
./configure --prefix=/usr \
|
||||
--with-zlib \
|
||||
--disable-static \
|
||||
--disable-guile \
|
||||
--disable-valgrind-tests # x86_64 test are all passed. some fail in i686 chroot
|
||||
--disable-valgrind-tests
|
||||
make
|
||||
}
|
||||
|
||||
|
|
28
extra/gnutls/buildfix.diff
Normal file
28
extra/gnutls/buildfix.diff
Normal file
|
@ -0,0 +1,28 @@
|
|||
index 17f6d3f..cc01dcd 100644 (file)
|
||||
|
||||
|
||||
--- a/tests/mini-loss-time.c
|
||||
+++ b/tests/mini-loss-time.c
|
||||
@@ -267,6 +267,7 @@ static void start (int server_packet, int client_packet)
|
||||
{
|
||||
/* parent */
|
||||
server (fd[0], server_packet);
|
||||
+ kill(child, SIGTERM);
|
||||
}
|
||||
else
|
||||
{
|
||||
--- a/src/libopts/m4/libopts.m4
|
||||
+++ b/src/libopts/m4/libopts.m4
|
||||
@@ -487,9 +487,9 @@ AC_DEFUN([LIBOPTS_CHECK_COMMON],[
|
||||
fi])
|
||||
|
||||
AC_ARG_ENABLE([libopts-install],
|
||||
- AC_HELP_STRING([--disable-libopts-install],
|
||||
- [Do not install libopts with client installation]))
|
||||
- AM_CONDITIONAL([INSTALL_LIBOPTS],[test "X${enable_libopts_install}" != Xno])
|
||||
+ AC_HELP_STRING([--enable-libopts-install],
|
||||
+ [Install libopts with client installation]))
|
||||
+ AM_CONDITIONAL([INSTALL_LIBOPTS],[test "X${enable_libopts_install}" = Xyes])
|
||||
|
||||
[if test -z "${NEED_LIBOPTS_DIR}" ; then]
|
||||
AC_MSG_CHECKING([whether autoopts-config can be found])
|
|
@ -10,9 +10,8 @@ plugrel=1
|
|||
pkgbase=lirc
|
||||
pkgname=('lirc' 'lirc-utils')
|
||||
pkgver=0.9.0
|
||||
pkgrel=8
|
||||
pkgrel=10
|
||||
epoch=1
|
||||
_kernver=3.0-ARCH
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.lirc.org/"
|
||||
license=('GPL')
|
||||
|
|
|
@ -10,7 +10,7 @@ plugrel=1
|
|||
|
||||
pkgbase=mysql
|
||||
pkgname=('libmysqlclient' 'mysql-clients' 'mysql')
|
||||
pkgver=5.5.20
|
||||
pkgver=5.5.21
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
|
@ -21,7 +21,7 @@ source=("http://ftp.gwdg.de/pub/misc/mysql/Downloads/MySQL-5.5/${pkgbase}-${pkgv
|
|||
'mysqld'
|
||||
'my.cnf'
|
||||
'alarm.patch')
|
||||
md5sums=('375794ebf84b4c7b63f1676bc7416cd0'
|
||||
md5sums=('86d6bd335054a0aed1756ed60574c16d'
|
||||
'2234207625baa29b2ff7d7b4f088abce'
|
||||
'1c949c0dbea5206af0db14942d9927b6'
|
||||
'9eb0ad531d162e031a2bcc08a5ab3bc5')
|
||||
|
|
Loading…
Reference in a new issue