alarm/uboot-odroid-c2 to 2015.01-2

This commit is contained in:
Kevin Mihelich 2016-02-27 00:54:13 +00:00
parent ff9e39ff85
commit 96562ba34d
5 changed files with 18 additions and 18 deletions

View file

@ -1,4 +1,4 @@
From 24ba32a8a4a560f821f7754b676a19de7597b23e Mon Sep 17 00:00:00 2001
From f1c2966fe1b01b98f405b8bf9aeebec552bbfec3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 19:29:25 -0700
Subject: [PATCH 1/4] remove cross compiling
@ -25,5 +25,5 @@ index 1da09c2..2968eb4 100644
KCONFIG_CONFIG ?= .config
--
2.7.0
2.7.1

View file

@ -1,4 +1,4 @@
From dc03be243f1d4b1c410b748373a9fda99c237797 Mon Sep 17 00:00:00 2001
From 12983d91742d4b981d032b94a5349427670b2cc9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 20:59:26 -0700
Subject: [PATCH 2/4] sd_fusing tweaks
@ -39,5 +39,5 @@ index 538185b..c14e0e2 100755
-echo Finished.
+echo "Successfully wrote U-Boot to $1"
--
2.7.0
2.7.1

View file

@ -1,4 +1,4 @@
From ce0efbe9297fafe9a18a6fdbf909600115e21746 Mon Sep 17 00:00:00 2001
From 434cc0fd97f9a82f94a5f128a633c071b09fd119 Mon Sep 17 00:00:00 2001
From: Hans de Goede <hdegoede@redhat.com>
Date: Sat, 7 Feb 2015 22:52:40 +0100
Subject: [PATCH 3/4] Add linux/compiler-gcc5.h to fix builds with gcc5
@ -89,5 +89,5 @@ index 0000000..c8c5659
+#define __HAVE_BUILTIN_BSWAP16__
+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
--
2.7.0
2.7.1

View file

@ -1,4 +1,4 @@
From 6af9b7ee486ca363c9417870abe9646f80f3bc0d Mon Sep 17 00:00:00 2001
From 1c175a4cfda5cf7c783bb0a43481b8f8d821d9bd Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 21:23:59 -0700
Subject: [PATCH 4/4] arch linux arm modifications
@ -22,12 +22,12 @@ index 6774e37..bb08f96 100644
filesize = getenv_ulong("filesize", 16, 0);
diff --git a/include/configs/odroidc2.h b/include/configs/odroidc2.h
index c1140b4..1268ca5 100644
index 74da65d..a03d388 100644
--- a/include/configs/odroidc2.h
+++ b/include/configs/odroidc2.h
@@ -74,6 +74,13 @@
@@ -75,6 +75,13 @@
#define CONFIG_BOOTDELAY 1 // Seconds
#define CONFIG_ABORTBOOT_WITH_ENTERKEY
+/* Arch Linux ARM */
+#define CONFIG_CMD_FS_GENERIC
@ -40,5 +40,5 @@ index c1140b4..1268ca5 100644
#define CONFIG_SYS_MAXARGS 64
--
2.7.0
2.7.1

View file

@ -8,7 +8,7 @@ noautobuild=1
pkgname=uboot-odroid-c2
pkgver=2015.01
pkgrel=1
pkgrel=2
pkgdesc="U-Boot for ODROID-C2"
arch=('aarch64')
url="https://github.com/hardkernel/u-boot"
@ -16,19 +16,19 @@ license=('GPL')
install=$pkgname.install
makedepends=('git' 'bc')
backup=('boot/boot.ini')
_commit=5785ef87af8998195c94af38a6b6d0b6ef327afa
_commit=beda6948c78a85c9705a877f9d012fec10032ef2
source=("https://github.com/hardkernel/u-boot/archive/${_commit}.tar.gz"
'boot.ini'
'0001-remove-cross-compiling.patch'
'0002-sd_fusing-tweaks.patch'
'0003-Add-linux-compiler-gcc5.h-to-fix-builds-with-gcc5.patch'
'0004-arch-linux-arm-modifications.patch')
md5sums=('46c3c2c4e28e18c04e81fc878868f5ca'
md5sums=('7a625a809336ae0b917addfe30c7ba34'
'04b71c2e7ec5734f9646cfed8d26f7ae'
'2ade162338fe32a4a156eede084222c0'
'296596234d264ae7d5278e2c4068144f'
'75d6a8bf332b61b8499bb49e99918078'
'e15e3965405942b388f5aa51b4880cce')
'063ed1211b9ff1f045f2480b02dcc7f0'
'568e66da8b3e339fe653b05c375de4db'
'fddd7cc81ad9e8dc76441376ff8c56f8'
'0f2c6a61e94d48dffd2c17dd22d4e3e6')
prepare() {
cd u-boot-${_commit}