extra/libvpx to 1.4.0-1

This commit is contained in:
Kevin Mihelich 2015-04-21 11:57:20 +00:00
parent d29e5bb205
commit 97f673562e
2 changed files with 77 additions and 73 deletions

View file

@ -1,14 +1,15 @@
# $Id: PKGBUILD 149273 2012-02-06 17:33:27Z ibiru $
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building
# - disable neon
pkgname=libvpx
pkgver=1.3.0
pkgver=1.4.0
pkgrel=1
pkgdesc='The VP8 Codec SDK'
pkgdesc='VP8 and VP9 codec'
arch=('i686' 'x86_64')
url='http://www.webmproject.org/'
license=('BSD')
@ -18,14 +19,19 @@ makedepends=('yasm' 'git')
source=($pkgname::git+http://code.google.com/p/webm.libvpx#tag=v$pkgver
fix-armhf-link.patch)
md5sums=('SKIP'
'018b866555f34c366c397797b2663994')
'3d54d292cdb5752f199e9551fbc1ac14')
prepare() {
cd $pkgname
patch -p1 -i ../fix-armhf-link.patch
}
build() {
cd $pkgname
patch -p1 -i ../fix-armhf-link.patch
./configure --prefix=/usr \
--enable-vp8 \
--enable-vp9 \
--enable-runtime-cpu-detect \
--enable-shared \
--enable-postproc \
--enable-pic \

View file

@ -1,7 +1,8 @@
diff -urN a/build/make/configure.sh b/build/make/configure.sh
--- a/build/make/configure.sh 2013-12-07 14:22:52.597542382 -0700
+++ b/build/make/configure.sh 2013-12-07 14:26:51.541053756 -0700
@@ -601,10 +601,14 @@
diff --git a/build/make/configure.sh b/build/make/configure.sh
index 25c9f80..396e5b0 100644
--- a/build/make/configure.sh
+++ b/build/make/configure.sh
@@ -623,10 +623,14 @@ process_common_toolchain() {
# detect tgt_isa
case "$gcctarget" in
@ -17,15 +18,18 @@ diff -urN a/build/make/configure.sh b/build/make/configure.sh
tgt_isa=armv7
float_abi=hard
;;
@@ -614,6 +618,7 @@
@@ -634,6 +638,10 @@ process_common_toolchain() {
tgt_isa=armv7
float_abi=softfp
;;
armv5te*)
tgt_isa=armv5te
+ armv5te*)
+ tgt_isa=armv5te
+ float_abi=soft
;;
+ ;;
*x86_64*|*amd64*)
tgt_isa=x86_64
@@ -799,7 +804,6 @@
;;
@@ -831,7 +839,6 @@ process_common_toolchain() {
case ${tgt_cc} in
gcc)
@ -33,10 +37,10 @@ diff -urN a/build/make/configure.sh b/build/make/configure.sh
link_with_cc=gcc
setup_gnu_toolchain
arch_int=${tgt_isa##armv}
@@ -807,13 +811,6 @@
@@ -839,13 +846,6 @@ process_common_toolchain() {
check_add_asflags --defsym ARCHITECTURE=${arch_int}
tune_cflags="-mtune="
if [ ${tgt_isa} = "armv7" ]; then
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
- if [ -z "${float_abi}" ]; then
- check_cpp <<EOF && float_abi=hard || float_abi=softfp
-#ifndef __ARM_PCS_VFP
@ -47,18 +51,12 @@ diff -urN a/build/make/configure.sh b/build/make/configure.sh
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
@@ -823,12 +820,9 @@
@@ -854,6 +854,8 @@ EOF
check_add_asflags -mfpu=neon
fi
- if [ -z "${tune_cpu}" ]; then
- tune_cpu=cortex-a8
- fi
else
- check_add_cflags -march=${tgt_isa}
- check_add_asflags -march=${tgt_isa}
+ check_add_cflags -march=${tgt_isa} -mfloat-abi=${float_abi}
+ check_add_asflags -march=${tgt_isa} -mfloat-abi=${float_abi}
check_add_cflags -march=${tgt_isa}
check_add_asflags -march=${tgt_isa}
fi
enabled debug && add_asflags -g