mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/mono to 3.2.1-1
This commit is contained in:
parent
670514a434
commit
9954c68bf4
4 changed files with 15 additions and 31 deletions
|
@ -7,7 +7,7 @@
|
|||
# and using autogen.sh to rebuild for configure.in changes.
|
||||
|
||||
pkgname=mono
|
||||
pkgver=3.0.12
|
||||
pkgver=3.2.1
|
||||
pkgrel=1
|
||||
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
|
||||
arch=(i686 x86_64)
|
||||
|
@ -18,12 +18,13 @@ makedepends=('pkgconfig')
|
|||
options=('!libtool' '!makeflags')
|
||||
provides=('monodoc')
|
||||
conflicts=('monodoc')
|
||||
source=(http://download.mono-project.com/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2
|
||||
install=mono.install
|
||||
source=(http://download.mono-project.com/sources/mono/${pkgname}-${pkgver}.tar.bz2
|
||||
mono.binfmt.d
|
||||
alarm.patch)
|
||||
md5sums=('7833809f5ddac1b8c605d4d26789987b'
|
||||
mono.install)
|
||||
md5sums=('bb613f9c93f57c29abcb7270f3215eb2'
|
||||
'b9ef8a65fea497acf176cca16c1e2402'
|
||||
'db43f2824188e4d1583b676f2e62db24')
|
||||
'ca1108e9638b01c26453ee663592a4e5')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
@ -36,10 +37,10 @@ build() {
|
|||
sed -i 's/AM_PROG_CC_STDC/AC_PROG_CC/' configure.in
|
||||
sed -i 's/AUTOMAKE_OPTIONS = cygnus//' runtime/Makefile.am
|
||||
./autogen.sh --prefix=/usr --sysconfdir=/etc \
|
||||
--with-fpu=VFP
|
||||
--with-fpu=VFP --bindir=/usr/bin --sbindir=/usr/bin
|
||||
else
|
||||
sed -i 's/armv6=yes/armv6=no/' configure
|
||||
./configure --prefix=/usr --sysconfdir=/etc
|
||||
./configure --prefix=/usr --sysconfdir=/etc --bindir=/usr/bin --sbindir=/usr/bin
|
||||
fi
|
||||
make
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- trunk/mcs/class/System.Web.Services/System.Web.Services.Description/BasicProfileChecker.cs 2008/07/01 20:17:46 107006
|
||||
+++ trunk/mcs/class/System.Web.Services/System.Web.Services.Description/BasicProfileChecker.cs 2008/10/28 09:32:46 117243
|
||||
@@ -177,7 +177,7 @@
|
||||
foreach (OperationMessage om in op.Messages) {
|
||||
Message msg = ctx.Services.GetMessage (om.Message);
|
||||
foreach (MessagePart part in msg.Parts)
|
||||
- parts.Add (part,part);
|
||||
+ parts [part] = part; // do not use Add() - there could be the same MessagePart instance.
|
||||
}
|
||||
}
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
--- mono/mini/mini-amd64.c 2009-03-19 21:08:18 UTC (rev 129824)
|
||||
+++ mono/mini/mini-amd64.c 2009-03-19 21:09:53 UTC (rev 129825)
|
||||
@@ -1009,7 +1009,7 @@
|
||||
locals_size += mono_type_size (ins->inst_vtype, &ialign);
|
||||
}
|
||||
|
||||
- if ((cfg->num_varinfo > 10000) || (locals_size >= (1 << 15))) {
|
||||
+ if ((cfg->num_varinfo > 5000) || (locals_size >= (1 << 15)) || (header->code_size > 110000)) {
|
||||
/* Avoid hitting the stack_alloc_size < (1 << 16) assertion in emit_epilog () */
|
||||
cfg->arch.omit_fp = FALSE;
|
||||
}
|
||||
|
||||
|
7
extra/mono/mono.install
Normal file
7
extra/mono/mono.install
Normal file
|
@ -0,0 +1,7 @@
|
|||
post_install() {
|
||||
ln -sf /bin/mono-sgen /bin/mono
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
Loading…
Reference in a new issue