mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libreoffice-still to 7.2.5-3
This commit is contained in:
parent
3397ac7b58
commit
996124bf58
2 changed files with 82 additions and 1 deletions
|
@ -0,0 +1,76 @@
|
|||
From db43e8a2a02adaa3571137b82855c01fad4c2534 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 2 Feb 2022 16:21:43 +0000
|
||||
Subject: rhbz#2047319 drop the SolarMutex before QApplication::init()
|
||||
|
||||
https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/24#note_383915
|
||||
|
||||
reproducible with with qt5-qtwayland-5.15.2-17.fc35.x86_64 and
|
||||
export OOO_FORCE_DESKTOP=plasma5
|
||||
export SAL_USE_VCLPLUGIN=gtk3
|
||||
|
||||
Change-Id: Icdf6b8709865c723c266e6400169b33639a1b0e4
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/129428
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
|
||||
---
|
||||
shell/Library_kf5be.mk | 1 +
|
||||
shell/source/backends/kf5be/kf5backend.cxx | 23 +++++++++++++++--------
|
||||
2 files changed, 16 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/shell/Library_kf5be.mk b/shell/Library_kf5be.mk
|
||||
index 628145176e0f..157f8b9836f8 100644
|
||||
--- a/shell/Library_kf5be.mk
|
||||
+++ b/shell/Library_kf5be.mk
|
||||
@@ -20,6 +20,7 @@ $(eval $(call gb_Library_use_libraries,kf5be1,\
|
||||
cppu \
|
||||
cppuhelper \
|
||||
sal \
|
||||
+ vcl \
|
||||
))
|
||||
|
||||
$(eval $(call gb_Library_set_componentfile,kf5be1,shell/source/backends/kf5be/kf5be1))
|
||||
diff --git a/shell/source/backends/kf5be/kf5backend.cxx b/shell/source/backends/kf5be/kf5backend.cxx
|
||||
index e9e10e60fd27..2b41414c54cd 100644
|
||||
--- a/shell/source/backends/kf5be/kf5backend.cxx
|
||||
+++ b/shell/source/backends/kf5be/kf5backend.cxx
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <rtl/ustring.hxx>
|
||||
#include <sal/types.h>
|
||||
#include <uno/current_context.hxx>
|
||||
+#include <vcl/svapp.hxx>
|
||||
|
||||
#include <osl/process.h>
|
||||
#include <osl/thread.h>
|
||||
@@ -172,14 +173,20 @@ void initQApp(std::map<OUString, css::beans::Optional<css::uno::Any>>& rSettings
|
||||
unsetenv("SESSION_MANAGER");
|
||||
}
|
||||
|
||||
- std::unique_ptr<QApplication> app(new QApplication(nFakeArgc, pFakeArgv));
|
||||
- QObject::connect(app.get(), &QObject::destroyed, app.get(), [nFakeArgc, pFakeArgv]() {
|
||||
- for (int i = 0; i < nFakeArgc; ++i)
|
||||
- free(pFakeArgv[i]);
|
||||
- delete[] pFakeArgv;
|
||||
- });
|
||||
-
|
||||
- readKDESettings(rSettings);
|
||||
+ {
|
||||
+ // rhbz#2047319 drop the SolarMutex during the execution of QApplication::init()
|
||||
+ // https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/24#note_383915
|
||||
+ SolarMutexReleaser aReleaser; // rhbz#2047319 drop the SolarMutex during the execution
|
||||
+
|
||||
+ std::unique_ptr<QApplication> app(new QApplication(nFakeArgc, pFakeArgv));
|
||||
+ QObject::connect(app.get(), &QObject::destroyed, app.get(), [nFakeArgc, pFakeArgv]() {
|
||||
+ for (int i = 0; i < nFakeArgc; ++i)
|
||||
+ free(pFakeArgv[i]);
|
||||
+ delete[] pFakeArgv;
|
||||
+ });
|
||||
+
|
||||
+ readKDESettings(rSettings);
|
||||
+ }
|
||||
|
||||
if (session_manager != nullptr)
|
||||
{
|
||||
--
|
||||
cgit v1.2.1
|
||||
|
|
@ -20,7 +20,7 @@ pkgbase=libreoffice-still
|
|||
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
|
||||
_LOver=7.2.5.2
|
||||
pkgver=7.2.5
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="https://www.libreoffice.org/"
|
||||
|
@ -68,6 +68,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
mdds-2.0-and-orcus-0.17.diff
|
||||
0001_drop_the_SolarMutex_before_QApplication.patch
|
||||
soffice-template.desktop.in
|
||||
libreoffice-still.sh libreoffice-still.csh)
|
||||
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
||||
|
@ -117,6 +118,7 @@ sha256sums=('67c1bfb059d433286b0252a915627b33af63bb5f4b6ec9509d13b9dd475512a7'
|
|||
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
|
||||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'fd73edaa09a48e2b2c4f4f32af68f1ef01cc181d49a5dfc1f65a5ad4883d7db8'
|
||||
'81a8551aaea0ab1750d36fb8bfbd04340a43eaab349a43c1384d21ef6504ab47'
|
||||
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
|
||||
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
|
||||
'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
|
||||
|
@ -143,6 +145,9 @@ prepare() {
|
|||
# fix build with current system libixion/liborcus/mdds
|
||||
patch -Np1 -i "${srcdir}"/mdds-2.0-and-orcus-0.17.diff
|
||||
|
||||
# fix crash on start - FS#73471
|
||||
patch -Np1 -i "${srcdir}"/0001_drop_the_SolarMutex_before_QApplication.patch
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
case "$i" in
|
||||
|
|
Loading…
Reference in a new issue