mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-odroid-c1 to 3.10.79-4
This commit is contained in:
parent
7b29ec2e6a
commit
9a7432287e
4 changed files with 13 additions and 59 deletions
|
@ -1,43 +0,0 @@
|
|||
From d8e25abf2feb8e2125a236d2391d8fc5c6b56785 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 22 Jan 2015 22:24:22 -0700
|
||||
Subject: [PATCH 1/3] dirty status led active low hack
|
||||
|
||||
---
|
||||
drivers/gpio/gpiolib-of.c | 14 ++++++++++++--
|
||||
1 file changed, 12 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c
|
||||
index 4e3a8de..cba15b1 100644
|
||||
--- a/drivers/gpio/gpiolib-of.c
|
||||
+++ b/drivers/gpio/gpiolib-of.c
|
||||
@@ -73,14 +73,24 @@ static int of_gpiochip_find_and_xlate(struct gpio_chip *gc, void *data)
|
||||
#include <linux/amlogic/aml_gpio_consumer.h>
|
||||
int of_get_named_gpio_flags(struct device_node *np, const char *propname,
|
||||
int index __attribute__((unused)),
|
||||
- enum of_gpio_flags *flags __attribute__((unused)))
|
||||
+ enum of_gpio_flags *flags)
|
||||
{
|
||||
const char *str;
|
||||
+ int gpio;
|
||||
|
||||
if(of_property_read_string(np, "gpios", &str))
|
||||
return -EPROBE_DEFER;
|
||||
|
||||
- return amlogic_gpio_name_map_num(str);
|
||||
+ gpio = amlogic_gpio_name_map_num(str);
|
||||
+
|
||||
+ if (flags != NULL) {
|
||||
+ if (gpio == 13)
|
||||
+ *flags = 1;
|
||||
+ else
|
||||
+ *flags = 0;
|
||||
+ }
|
||||
+
|
||||
+ return gpio;
|
||||
}
|
||||
#else
|
||||
int of_get_named_gpio_flags(struct device_node *np, const char *propname,
|
||||
--
|
||||
2.4.1
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From b248983da561b9ad93b0f91ff9fc1e6b44ca059f Mon Sep 17 00:00:00 2001
|
||||
From d65a7d93ea65dc8cbb133497334ce1c529815a78 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 19 Mar 2015 18:31:00 -0600
|
||||
Subject: [PATCH 2/3] remove backports cflags
|
||||
Subject: [PATCH 1/2] remove backports cflags
|
||||
|
||||
---
|
||||
backports/Makefile | 8 +++-----
|
|
@ -1,7 +1,7 @@
|
|||
From 76c66bc752ac11dd7058c4c1d45902e094ad0545 Mon Sep 17 00:00:00 2001
|
||||
From 46de4e3a5f56c5915beb4a69e4a3af9c88aaa482 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 30 Apr 2015 20:15:13 -0600
|
||||
Subject: [PATCH 3/3] AUFS fix for 3.10.76
|
||||
Subject: [PATCH 2/2] AUFS fix for 3.10.76
|
||||
|
||||
---
|
||||
fs/aufs/debug.c | 2 +-
|
|
@ -4,12 +4,12 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=linux-odroid-c1
|
||||
_commit=428e2c771e07cfebe31a44afe96c75f22ad28ea0
|
||||
_commit=5fd2c0a66767fc6a92ff9c0b5daed57215c78ebc
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ODROID-C1"
|
||||
pkgver=3.10.79
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
arch=('armv7h')
|
||||
url="https://github.com/hardkernel/linux"
|
||||
license=('GPL2')
|
||||
|
@ -19,25 +19,22 @@ source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
|||
"git+https://github.com/mdrjr/c1_bootini.git"
|
||||
'config'
|
||||
'amlogic.service'
|
||||
'0001-dirty-status-led-active-low-hack.patch'
|
||||
'0002-remove-backports-cflags.patch'
|
||||
'0003-AUFS-fix-for-3.10.76.patch')
|
||||
md5sums=('6e2f1be1b95ee01334c14e90eaa4b4ba'
|
||||
'0001-remove-backports-cflags.patch'
|
||||
'0002-AUFS-fix-for-3.10.76.patch')
|
||||
md5sums=('5e25414b8054c8cdb44af268e2998958'
|
||||
'SKIP'
|
||||
'892014616cf866d7f46e13e63659e187'
|
||||
'b8956789318f49cec5b8bb0b41654a9b'
|
||||
'fe6c0fb78823349280ff39de6fbadc40'
|
||||
'c2557467b38978bb2da6ff11520c85d8'
|
||||
'e9be2a15e087403ded7a9df9a1901933')
|
||||
'5cbceb4671d498ebd3548c6d02b5324d'
|
||||
'160a47ab9efd5cbbf4b0ac392ae59180')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
git apply ../0001-dirty-status-led-active-low-hack.patch
|
||||
git apply ../0002-remove-backports-cflags.patch
|
||||
git apply ../0003-AUFS-fix-for-3.10.76.patch
|
||||
git apply ../0001-remove-backports-cflags.patch
|
||||
git apply ../0002-AUFS-fix-for-3.10.76.patch
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
|
Loading…
Reference in a new issue