mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added core/nss
This commit is contained in:
parent
b4718a9b06
commit
9cd403d0ee
8 changed files with 582 additions and 0 deletions
123
core/nss/PKGBUILD
Normal file
123
core/nss/PKGBUILD
Normal file
|
@ -0,0 +1,123 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - export USE_64=1 for AArch64
|
||||
|
||||
pkgbase=nss
|
||||
pkgname=(nss ca-certificates-mozilla)
|
||||
pkgver=3.19.2
|
||||
pkgrel=2
|
||||
pkgdesc="Mozilla Network Security Services"
|
||||
arch=(i686 x86_64)
|
||||
url="http://www.mozilla.org/projects/security/pki/nss/"
|
||||
license=('MPL' 'GPL')
|
||||
_nsprver=4.10.7
|
||||
depends=("nspr>=${_nsprver}" 'sqlite' 'zlib' 'sh' 'p11-kit')
|
||||
makedepends=('perl' 'python2')
|
||||
options=('!strip' '!makeflags' 'staticlibs')
|
||||
source=("https://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_${pkgver//./_}_RTM/src/${pkgbase}-${pkgver}.tar.gz"
|
||||
certdata2pem.py bundle.sh nss.pc.in nss-config.in legacy-certs.patch)
|
||||
sha256sums=('1306663e8f61d8449ad8cbcffab743a604dcd9f6f34232c210847c51dce2c9ae'
|
||||
'af13c30801a8a27623948206458432a4cf98061b75ff6e5b5e03912f93c034ee'
|
||||
'045f520403f715a4cc7f3607b4e2c9bcc88fee5bce58d462fddaa2fdb0e4c180'
|
||||
'b9f1428ca2305bf30b109507ff335fa00bce5a7ce0434b50acd26ad7c47dd5bd'
|
||||
'e44ac5095b4d88f24ec7b2e6a9f1581560bd3ad41a3d198596d67ef22f67adb9'
|
||||
'22330fcde2dac5fa4733f7d77bffbbd31d91cbaa338738afdc2a8ebfccb61184')
|
||||
|
||||
prepare() {
|
||||
mkdir certs
|
||||
|
||||
cd nss-$pkgver
|
||||
|
||||
# FS#45479: Reenable two weak Verisign certificates used by login.live.com
|
||||
# Otherwise, accessing this site via Epiphany (GnuTLS) or Skype (OpenSSL) fails
|
||||
# Also see https://gist.github.com/grawity/15eabf67191e17080241
|
||||
patch nss/lib/ckfw/builtins/certdata.txt ../legacy-certs.patch
|
||||
|
||||
# Respect LDFLAGS
|
||||
sed -e 's/\$(MKSHLIB) -o/\$(MKSHLIB) \$(LDFLAGS) -o/' \
|
||||
-i nss/coreconf/rules.mk
|
||||
|
||||
ln -sr nss/lib/ckfw/builtins/certdata.txt ../certs/
|
||||
ln -sr nss/lib/ckfw/builtins/nssckbi.h ../certs/
|
||||
}
|
||||
|
||||
|
||||
build() {
|
||||
cd certs
|
||||
python2 ../certdata2pem.py
|
||||
|
||||
cd ..
|
||||
sh bundle.sh
|
||||
|
||||
cd nss-$pkgver/nss
|
||||
export BUILD_OPT=1
|
||||
export NSS_USE_SYSTEM_SQLITE=1
|
||||
export NSS_ENABLE_ECC=1
|
||||
export NSPR_INCLUDE_DIR="`nspr-config --includedir`"
|
||||
export NSPR_LIB_DIR="`nspr-config --libdir`"
|
||||
export XCFLAGS="${CFLAGS}"
|
||||
|
||||
[ "$CARCH" = "x86_64" -o "$CARCH" = "aarch64" ] && export USE_64=1
|
||||
|
||||
make -C coreconf
|
||||
make -C lib/dbm
|
||||
make
|
||||
}
|
||||
|
||||
package_nss() {
|
||||
install=nss.install
|
||||
|
||||
cd nss-$pkgver
|
||||
install -d "$pkgdir"/usr/{bin,include/nss,lib/pkgconfig}
|
||||
|
||||
NSS_VMAJOR=$(grep '#define.*NSS_VMAJOR' nss/lib/nss/nss.h | awk '{print $3}')
|
||||
NSS_VMINOR=$(grep '#define.*NSS_VMINOR' nss/lib/nss/nss.h | awk '{print $3}')
|
||||
NSS_VPATCH=$(grep '#define.*NSS_VPATCH' nss/lib/nss/nss.h | awk '{print $3}')
|
||||
|
||||
sed ../nss.pc.in \
|
||||
-e "s,%libdir%,/usr/lib,g" \
|
||||
-e "s,%prefix%,/usr,g" \
|
||||
-e "s,%exec_prefix%,/usr/bin,g" \
|
||||
-e "s,%includedir%,/usr/include/nss,g" \
|
||||
-e "s,%NSPR_VERSION%,${_nsprver},g" \
|
||||
-e "s,%NSS_VERSION%,${pkgver},g" \
|
||||
> "$pkgdir/usr/lib/pkgconfig/nss.pc"
|
||||
ln -s nss.pc "$pkgdir/usr/lib/pkgconfig/mozilla-nss.pc"
|
||||
|
||||
sed ../nss-config.in \
|
||||
-e "s,@libdir@,/usr/lib,g" \
|
||||
-e "s,@prefix@,/usr/bin,g" \
|
||||
-e "s,@exec_prefix@,/usr/bin,g" \
|
||||
-e "s,@includedir@,/usr/include/nss,g" \
|
||||
-e "s,@MOD_MAJOR_VERSION@,${NSS_VMAJOR},g" \
|
||||
-e "s,@MOD_MINOR_VERSION@,${NSS_VMINOR},g" \
|
||||
-e "s,@MOD_PATCH_VERSION@,${NSS_VPATCH},g" \
|
||||
> "$pkgdir/usr/bin/nss-config"
|
||||
chmod 755 "$pkgdir/usr/bin/nss-config"
|
||||
|
||||
cd dist/*.OBJ/bin
|
||||
install -t "$pkgdir/usr/bin" *util shlibsign signtool signver ssltap
|
||||
|
||||
cd ../lib
|
||||
install -t "$pkgdir/usr/lib" *.so
|
||||
install -t "$pkgdir/usr/lib" -m644 libcrmf.a *.chk
|
||||
|
||||
cd ../../public/nss
|
||||
install -t "$pkgdir/usr/include/nss" -m644 *.h
|
||||
|
||||
rm "$pkgdir/usr/lib/libnssckbi.so"
|
||||
ln -s libnssckbi-p11-kit.so "$pkgdir/usr/lib/libnssckbi.so"
|
||||
}
|
||||
|
||||
package_ca-certificates-mozilla() {
|
||||
pkgdesc="Mozilla's set of trusted CA certificates"
|
||||
depends=(ca-certificates-utils)
|
||||
install=ca-certificates-mozilla.install
|
||||
|
||||
local _certdir="$pkgdir/usr/share/ca-certificates/trust-source"
|
||||
install -Dm644 ca-bundle.trust.crt "$_certdir/mozilla.trust.crt"
|
||||
install -Dm644 ca-bundle.neutral-trust.crt "$_certdir/mozilla.neutral-trust.crt"
|
||||
install -Dm644 ca-bundle.supplement.p11-kit "$_certdir/mozilla.supplement.p11-kit"
|
||||
}
|
54
core/nss/bundle.sh
Normal file
54
core/nss/bundle.sh
Normal file
|
@ -0,0 +1,54 @@
|
|||
#!/bin/sh
|
||||
# From Fedora's ca-certificates.spec
|
||||
|
||||
(
|
||||
cat <<EOF
|
||||
# This is a bundle of X.509 certificates of public Certificate
|
||||
# Authorities. It was generated from the Mozilla root CA list.
|
||||
# These certificates are in the OpenSSL "TRUSTED CERTIFICATE"
|
||||
# format and have trust bits set accordingly.
|
||||
# An exception are auxiliary certificates, without positive or negative
|
||||
# trust, but are used to assist in finding a preferred trust path.
|
||||
# Those neutral certificates use the plain BEGIN CERTIFICATE format.
|
||||
#
|
||||
# Source: nss/lib/ckfw/builtins/certdata.txt
|
||||
# Source: nss/lib/ckfw/builtins/nssckbi.h
|
||||
#
|
||||
# Generated from:
|
||||
EOF
|
||||
cat certs/nssckbi.h | grep -w NSS_BUILTINS_LIBRARY_VERSION | awk '{print "# " $2 " " $3}'
|
||||
echo '#'
|
||||
) > ca-bundle.trust.crt
|
||||
for f in certs/*.crt; do
|
||||
echo "processing $f"
|
||||
tbits=`sed -n '/^# openssl-trust/{s/^.*=//;p;}' $f`
|
||||
distbits=`sed -n '/^# openssl-distrust/{s/^.*=//;p;}' $f`
|
||||
alias=`sed -n '/^# alias=/{s/^.*=//;p;q;}' $f | sed "s/'//g" | sed 's/"//g'`
|
||||
targs=""
|
||||
if [ -n "$tbits" ]; then
|
||||
for t in $tbits; do
|
||||
targs="${targs} -addtrust $t"
|
||||
done
|
||||
fi
|
||||
if [ -n "$distbits" ]; then
|
||||
for t in $distbits; do
|
||||
targs="${targs} -addreject $t"
|
||||
done
|
||||
fi
|
||||
if [ -n "$targs" ]; then
|
||||
echo "trust flags $targs for $f" >> info.trust
|
||||
openssl x509 -text -in "$f" -trustout $targs -setalias "$alias" >> ca-bundle.trust.crt
|
||||
else
|
||||
echo "no trust flags for $f" >> info.notrust
|
||||
# p11-kit-trust defines empty trust lists as "rejected for all purposes".
|
||||
# That's why we use the simple file format
|
||||
# (BEGIN CERTIFICATE, no trust information)
|
||||
# because p11-kit-trust will treat it as a certificate with neutral trust.
|
||||
# This means we cannot use the -setalias feature for neutral trust certs.
|
||||
openssl x509 -text -in "$f" >> ca-bundle.neutral-trust.crt
|
||||
fi
|
||||
done
|
||||
|
||||
for p in certs/*.p11-kit; do
|
||||
cat "$p" >> ca-bundle.supplement.p11-kit
|
||||
done
|
11
core/nss/ca-certificates-mozilla.install
Normal file
11
core/nss/ca-certificates-mozilla.install
Normal file
|
@ -0,0 +1,11 @@
|
|||
post_install() {
|
||||
usr/bin/update-ca-trust
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
post_install
|
||||
}
|
199
core/nss/certdata2pem.py
Normal file
199
core/nss/certdata2pem.py
Normal file
|
@ -0,0 +1,199 @@
|
|||
#!/usr/bin/python
|
||||
# vim:set et sw=4:
|
||||
#
|
||||
# certdata2pem.py - splits certdata.txt into multiple files
|
||||
#
|
||||
# Copyright (C) 2009 Philipp Kern <pkern@debian.org>
|
||||
# Copyright (C) 2013 Kai Engert <kaie@redhat.com>
|
||||
#
|
||||
# This program is free software; you can redistribute it and/or modify
|
||||
# it under the terms of the GNU General Public License as published by
|
||||
# the Free Software Foundation; either version 2 of the License, or
|
||||
# (at your option) any later version.
|
||||
#
|
||||
# This program is distributed in the hope that it will be useful,
|
||||
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
# GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program; if not, write to the Free Software
|
||||
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301,
|
||||
# USA.
|
||||
|
||||
import base64
|
||||
import os.path
|
||||
import re
|
||||
import sys
|
||||
import textwrap
|
||||
import urllib
|
||||
|
||||
objects = []
|
||||
|
||||
def printable_serial(obj):
|
||||
return ".".join(map(lambda x:str(ord(x)), obj['CKA_SERIAL_NUMBER']))
|
||||
|
||||
# Dirty file parser.
|
||||
in_data, in_multiline, in_obj = False, False, False
|
||||
field, type, value, obj = None, None, None, dict()
|
||||
for line in open('certdata.txt', 'r'):
|
||||
# Ignore the file header.
|
||||
if not in_data:
|
||||
if line.startswith('BEGINDATA'):
|
||||
in_data = True
|
||||
continue
|
||||
# Ignore comment lines.
|
||||
if line.startswith('#'):
|
||||
continue
|
||||
# Empty lines are significant if we are inside an object.
|
||||
if in_obj and len(line.strip()) == 0:
|
||||
objects.append(obj)
|
||||
obj = dict()
|
||||
in_obj = False
|
||||
continue
|
||||
if len(line.strip()) == 0:
|
||||
continue
|
||||
if in_multiline:
|
||||
if not line.startswith('END'):
|
||||
if type == 'MULTILINE_OCTAL':
|
||||
line = line.strip()
|
||||
for i in re.finditer(r'\\([0-3][0-7][0-7])', line):
|
||||
value += chr(int(i.group(1), 8))
|
||||
else:
|
||||
value += line
|
||||
continue
|
||||
obj[field] = value
|
||||
in_multiline = False
|
||||
continue
|
||||
if line.startswith('CKA_CLASS'):
|
||||
in_obj = True
|
||||
line_parts = line.strip().split(' ', 2)
|
||||
if len(line_parts) > 2:
|
||||
field, type = line_parts[0:2]
|
||||
value = ' '.join(line_parts[2:])
|
||||
elif len(line_parts) == 2:
|
||||
field, type = line_parts
|
||||
value = None
|
||||
else:
|
||||
raise NotImplementedError, 'line_parts < 2 not supported.\n' + line
|
||||
if type == 'MULTILINE_OCTAL':
|
||||
in_multiline = True
|
||||
value = ""
|
||||
continue
|
||||
obj[field] = value
|
||||
if len(obj.items()) > 0:
|
||||
objects.append(obj)
|
||||
|
||||
# Build up trust database.
|
||||
trustmap = dict()
|
||||
for obj in objects:
|
||||
if obj['CKA_CLASS'] != 'CKO_NSS_TRUST':
|
||||
continue
|
||||
key = obj['CKA_LABEL'] + printable_serial(obj)
|
||||
trustmap[key] = obj
|
||||
print " added trust", key
|
||||
|
||||
# Build up cert database.
|
||||
certmap = dict()
|
||||
for obj in objects:
|
||||
if obj['CKA_CLASS'] != 'CKO_CERTIFICATE':
|
||||
continue
|
||||
key = obj['CKA_LABEL'] + printable_serial(obj)
|
||||
certmap[key] = obj
|
||||
print " added cert", key
|
||||
|
||||
def obj_to_filename(obj):
|
||||
label = obj['CKA_LABEL'][1:-1]
|
||||
label = label.replace('/', '_')\
|
||||
.replace(' ', '_')\
|
||||
.replace('(', '=')\
|
||||
.replace(')', '=')\
|
||||
.replace(',', '_')
|
||||
label = re.sub(r'\\x[0-9a-fA-F]{2}', lambda m:chr(int(m.group(0)[2:], 16)), label)
|
||||
serial = printable_serial(obj)
|
||||
return label + ":" + serial
|
||||
|
||||
trust_types = {
|
||||
"CKA_TRUST_DIGITAL_SIGNATURE": "digital-signature",
|
||||
"CKA_TRUST_NON_REPUDIATION": "non-repudiation",
|
||||
"CKA_TRUST_KEY_ENCIPHERMENT": "key-encipherment",
|
||||
"CKA_TRUST_DATA_ENCIPHERMENT": "data-encipherment",
|
||||
"CKA_TRUST_KEY_AGREEMENT": "key-agreement",
|
||||
"CKA_TRUST_KEY_CERT_SIGN": "cert-sign",
|
||||
"CKA_TRUST_CRL_SIGN": "crl-sign",
|
||||
"CKA_TRUST_SERVER_AUTH": "server-auth",
|
||||
"CKA_TRUST_CLIENT_AUTH": "client-auth",
|
||||
"CKA_TRUST_CODE_SIGNING": "code-signing",
|
||||
"CKA_TRUST_EMAIL_PROTECTION": "email-protection",
|
||||
"CKA_TRUST_IPSEC_END_SYSTEM": "ipsec-end-system",
|
||||
"CKA_TRUST_IPSEC_TUNNEL": "ipsec-tunnel",
|
||||
"CKA_TRUST_IPSEC_USER": "ipsec-user",
|
||||
"CKA_TRUST_TIME_STAMPING": "time-stamping",
|
||||
"CKA_TRUST_STEP_UP_APPROVED": "step-up-approved",
|
||||
}
|
||||
|
||||
openssl_trust = {
|
||||
"CKA_TRUST_SERVER_AUTH": "serverAuth",
|
||||
"CKA_TRUST_CLIENT_AUTH": "clientAuth",
|
||||
"CKA_TRUST_CODE_SIGNING": "codeSigning",
|
||||
"CKA_TRUST_EMAIL_PROTECTION": "emailProtection",
|
||||
}
|
||||
|
||||
for tobj in objects:
|
||||
if tobj['CKA_CLASS'] == 'CKO_NSS_TRUST':
|
||||
key = tobj['CKA_LABEL'] + printable_serial(tobj)
|
||||
print "producing trust for " + key
|
||||
trustbits = []
|
||||
distrustbits = []
|
||||
openssl_trustflags = []
|
||||
openssl_distrustflags = []
|
||||
for t in trust_types.keys():
|
||||
if tobj.has_key(t) and tobj[t] == 'CKT_NSS_TRUSTED_DELEGATOR':
|
||||
trustbits.append(t)
|
||||
if t in openssl_trust:
|
||||
openssl_trustflags.append(openssl_trust[t])
|
||||
if tobj.has_key(t) and tobj[t] == 'CKT_NSS_NOT_TRUSTED':
|
||||
distrustbits.append(t)
|
||||
if t in openssl_trust:
|
||||
openssl_distrustflags.append(openssl_trust[t])
|
||||
|
||||
fname = obj_to_filename(tobj)
|
||||
try:
|
||||
obj = certmap[key]
|
||||
except:
|
||||
obj = None
|
||||
|
||||
if obj != None:
|
||||
fname += ".crt"
|
||||
else:
|
||||
fname += ".p11-kit"
|
||||
|
||||
f = open(fname, 'w')
|
||||
if obj != None:
|
||||
f.write("# alias=%s\n"%tobj['CKA_LABEL'])
|
||||
f.write("# trust=" + " ".join(trustbits) + "\n")
|
||||
f.write("# distrust=" + " ".join(distrustbits) + "\n")
|
||||
if openssl_trustflags:
|
||||
f.write("# openssl-trust=" + " ".join(openssl_trustflags) + "\n")
|
||||
if openssl_distrustflags:
|
||||
f.write("# openssl-distrust=" + " ".join(openssl_distrustflags) + "\n")
|
||||
f.write("-----BEGIN CERTIFICATE-----\n")
|
||||
f.write("\n".join(textwrap.wrap(base64.b64encode(obj['CKA_VALUE']), 64)))
|
||||
f.write("\n-----END CERTIFICATE-----\n")
|
||||
else:
|
||||
f.write("[p11-kit-object-v1]\n")
|
||||
f.write("label: ");
|
||||
f.write(tobj['CKA_LABEL']);
|
||||
f.write("\n")
|
||||
f.write("class: certificate\n")
|
||||
f.write("certificate-type: x-509\n")
|
||||
f.write("issuer: \"");
|
||||
f.write(urllib.quote(tobj['CKA_ISSUER']));
|
||||
f.write("\"\n")
|
||||
f.write("serial-number: \"");
|
||||
f.write(urllib.quote(tobj['CKA_SERIAL_NUMBER']));
|
||||
f.write("\"\n")
|
||||
if (tobj['CKA_TRUST_SERVER_AUTH'] == 'CKT_NSS_NOT_TRUSTED') or (tobj['CKA_TRUST_EMAIL_PROTECTION'] == 'CKT_NSS_NOT_TRUSTED') or (tobj['CKA_TRUST_CODE_SIGNING'] == 'CKT_NSS_NOT_TRUSTED'):
|
||||
f.write("x-distrusted: true\n")
|
||||
f.write("\n\n")
|
||||
print " -> written as '%s', trust = %s, openssl-trust = %s, distrust = %s, openssl-distrust = %s" % (fname, trustbits, openssl_trustflags, distrustbits, openssl_distrustflags)
|
26
core/nss/legacy-certs.patch
Normal file
26
core/nss/legacy-certs.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- certdata.txt 2015-06-27 23:31:01.419795911 +0200
|
||||
+++ certdata-legacy-less.txt 2015-06-27 23:57:47.106199639 +0200
|
||||
@@ -577,9 +577,9 @@
|
||||
\002\020\160\272\344\035\020\331\051\064\266\070\312\173\003\314
|
||||
\272\277
|
||||
END
|
||||
-CKA_TRUST_SERVER_AUTH CK_TRUST CKT_NSS_MUST_VERIFY_TRUST
|
||||
+CKA_TRUST_SERVER_AUTH CK_TRUST CKT_NSS_TRUSTED_DELEGATOR
|
||||
CKA_TRUST_EMAIL_PROTECTION CK_TRUST CKT_NSS_TRUSTED_DELEGATOR
|
||||
-CKA_TRUST_CODE_SIGNING CK_TRUST CKT_NSS_MUST_VERIFY_TRUST
|
||||
+CKA_TRUST_CODE_SIGNING CK_TRUST CKT_NSS_TRUSTED_DELEGATOR
|
||||
CKA_TRUST_STEP_UP_APPROVED CK_BBOOL CK_FALSE
|
||||
|
||||
#
|
||||
@@ -17186,9 +17186,9 @@
|
||||
\002\020\074\221\061\313\037\366\320\033\016\232\270\320\104\277
|
||||
\022\276
|
||||
END
|
||||
-CKA_TRUST_SERVER_AUTH CK_TRUST CKT_NSS_MUST_VERIFY_TRUST
|
||||
+CKA_TRUST_SERVER_AUTH CK_TRUST CKT_NSS_TRUSTED_DELEGATOR
|
||||
CKA_TRUST_EMAIL_PROTECTION CK_TRUST CKT_NSS_TRUSTED_DELEGATOR
|
||||
-CKA_TRUST_CODE_SIGNING CK_TRUST CKT_NSS_MUST_VERIFY_TRUST
|
||||
+CKA_TRUST_CODE_SIGNING CK_TRUST CKT_NSS_TRUSTED_DELEGATOR
|
||||
CKA_TRUST_STEP_UP_APPROVED CK_BBOOL CK_FALSE
|
||||
|
||||
#
|
145
core/nss/nss-config.in
Normal file
145
core/nss/nss-config.in
Normal file
|
@ -0,0 +1,145 @@
|
|||
#!/bin/sh
|
||||
|
||||
prefix=@prefix@
|
||||
|
||||
major_version=@MOD_MAJOR_VERSION@
|
||||
minor_version=@MOD_MINOR_VERSION@
|
||||
patch_version=@MOD_PATCH_VERSION@
|
||||
|
||||
usage()
|
||||
{
|
||||
cat <<EOF
|
||||
Usage: nss-config [OPTIONS] [LIBRARIES]
|
||||
Options:
|
||||
[--prefix[=DIR]]
|
||||
[--exec-prefix[=DIR]]
|
||||
[--includedir[=DIR]]
|
||||
[--libdir[=DIR]]
|
||||
[--version]
|
||||
[--libs]
|
||||
[--cflags]
|
||||
Dynamic Libraries:
|
||||
nss
|
||||
nssutil
|
||||
ssl
|
||||
smime
|
||||
EOF
|
||||
exit $1
|
||||
}
|
||||
|
||||
if test $# -eq 0; then
|
||||
usage 1 1>&2
|
||||
fi
|
||||
|
||||
lib_ssl=yes
|
||||
lib_smime=yes
|
||||
lib_nss=yes
|
||||
lib_nssutil=yes
|
||||
|
||||
while test $# -gt 0; do
|
||||
case "$1" in
|
||||
-*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
|
||||
*) optarg= ;;
|
||||
esac
|
||||
|
||||
case $1 in
|
||||
--prefix=*)
|
||||
prefix=$optarg
|
||||
;;
|
||||
--prefix)
|
||||
echo_prefix=yes
|
||||
;;
|
||||
--exec-prefix=*)
|
||||
exec_prefix=$optarg
|
||||
;;
|
||||
--exec-prefix)
|
||||
echo_exec_prefix=yes
|
||||
;;
|
||||
--includedir=*)
|
||||
includedir=$optarg
|
||||
;;
|
||||
--includedir)
|
||||
echo_includedir=yes
|
||||
;;
|
||||
--libdir=*)
|
||||
libdir=$optarg
|
||||
;;
|
||||
--libdir)
|
||||
echo_libdir=yes
|
||||
;;
|
||||
--version)
|
||||
echo ${major_version}.${minor_version}.${patch_version}
|
||||
;;
|
||||
--cflags)
|
||||
echo_cflags=yes
|
||||
;;
|
||||
--libs)
|
||||
echo_libs=yes
|
||||
;;
|
||||
ssl)
|
||||
lib_ssl=yes
|
||||
;;
|
||||
smime)
|
||||
lib_smime=yes
|
||||
;;
|
||||
nss)
|
||||
lib_nss=yes
|
||||
;;
|
||||
nssutil)
|
||||
lib_nssutil=yes
|
||||
;;
|
||||
*)
|
||||
usage 1 1>&2
|
||||
;;
|
||||
esac
|
||||
shift
|
||||
done
|
||||
|
||||
# Set variables that may be dependent upon other variables
|
||||
if test -z "$exec_prefix"; then
|
||||
exec_prefix=`pkg-config --variable=exec_prefix nss`
|
||||
fi
|
||||
if test -z "$includedir"; then
|
||||
includedir=`pkg-config --variable=includedir nss`
|
||||
fi
|
||||
if test -z "$libdir"; then
|
||||
libdir=`pkg-config --variable=libdir nss`
|
||||
fi
|
||||
|
||||
if test "$echo_prefix" = "yes"; then
|
||||
echo $prefix
|
||||
fi
|
||||
|
||||
if test "$echo_exec_prefix" = "yes"; then
|
||||
echo $exec_prefix
|
||||
fi
|
||||
|
||||
if test "$echo_includedir" = "yes"; then
|
||||
echo $includedir
|
||||
fi
|
||||
|
||||
if test "$echo_libdir" = "yes"; then
|
||||
echo $libdir
|
||||
fi
|
||||
|
||||
if test "$echo_cflags" = "yes"; then
|
||||
echo -I$includedir
|
||||
fi
|
||||
|
||||
if test "$echo_libs" = "yes"; then
|
||||
libdirs="-Wl,-rpath-link,$libdir -L$libdir"
|
||||
if test -n "$lib_ssl"; then
|
||||
libdirs="$libdirs -lssl${major_version}"
|
||||
fi
|
||||
if test -n "$lib_smime"; then
|
||||
libdirs="$libdirs -lsmime${major_version}"
|
||||
fi
|
||||
if test -n "$lib_nss"; then
|
||||
libdirs="$libdirs -lnss${major_version}"
|
||||
fi
|
||||
if test -n "$lib_nssutil"; then
|
||||
libdirs="$libdirs -lnssutil${major_version}"
|
||||
fi
|
||||
echo $libdirs
|
||||
fi
|
||||
|
13
core/nss/nss.install
Normal file
13
core/nss/nss.install
Normal file
|
@ -0,0 +1,13 @@
|
|||
post_upgrade() {
|
||||
if (($(vercmp $2 3.18-3) < 0)); then
|
||||
# This symlink was created by ldconfig because we linked to
|
||||
# pkcs11/p11-kit-trust.so from libnssckbi.so; the chain was:
|
||||
# p11-kit-trust.so -> libnssckbi.so -> pkcs11/p11-kit-trust.so
|
||||
# Now we have:
|
||||
# libnssckbi.so -> libnssckbi-p11-kit.so
|
||||
# which no longer creates an incorrect p11-kit-trust.so symlink
|
||||
if [[ $(readlink usr/lib/p11-kit-trust.so) == libnssckbi.so ]]; then
|
||||
rm usr/lib/p11-kit-trust.so
|
||||
fi
|
||||
fi
|
||||
}
|
11
core/nss/nss.pc.in
Normal file
11
core/nss/nss.pc.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
prefix=%prefix%
|
||||
exec_prefix=%exec_prefix%
|
||||
libdir=%libdir%
|
||||
includedir=%includedir%
|
||||
|
||||
Name: NSS
|
||||
Description: Network Security Services
|
||||
Version: %NSS_VERSION%
|
||||
Requires: nspr >= %NSPR_VERSION%
|
||||
Libs: -lssl3 -lsmime3 -lnss3 -lnssutil3
|
||||
Cflags: -I${includedir}
|
Loading…
Reference in a new issue