mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
aur/ffmpeg-shinobi to 4.3.4-2
This commit is contained in:
parent
0c988c72c5
commit
9df761dc76
2 changed files with 86 additions and 5 deletions
78
aur/ffmpeg-shinobi/0002-add-build-fix-for-dav1d-1.0.0.patch
Normal file
78
aur/ffmpeg-shinobi/0002-add-build-fix-for-dav1d-1.0.0.patch
Normal file
|
@ -0,0 +1,78 @@
|
|||
From 2546e1ed27f92a840a2cf319e3c1833799974cf1 Mon Sep 17 00:00:00 2001
|
||||
From: BlackEagle <ike.devolder@gmail.com>
|
||||
Date: Fri, 29 Apr 2022 14:33:12 +0200
|
||||
Subject: [PATCH] add build fix for dav1d 1.0.0
|
||||
|
||||
Taken from https://github.com/FFmpeg/FFmpeg/commit/e204846ec16c1ab34c7f3a681734cf5190433018
|
||||
|
||||
add FF_DAV1D_VERSION_AT_LEAST
|
||||
|
||||
Extracted from https://github.com/FFmpeg/FFmpeg/commit/7ee17ec7e46afef0e0af20af196292ec75f50b62
|
||||
|
||||
Signed-off-by: BlackEagle <ike.devolder@gmail.com>
|
||||
---
|
||||
libavcodec/libdav1d.c | 24 ++++++++++++++++++++++--
|
||||
1 file changed, 22 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libavcodec/libdav1d.c b/libavcodec/libdav1d.c
|
||||
index bbb3ec1e6c..08b4af8ac8 100644
|
||||
--- a/libavcodec/libdav1d.c
|
||||
+++ b/libavcodec/libdav1d.c
|
||||
@@ -30,6 +30,9 @@
|
||||
#include "decode.h"
|
||||
#include "internal.h"
|
||||
|
||||
+#define FF_DAV1D_VERSION_AT_LEAST(x,y) \
|
||||
+ (DAV1D_API_VERSION_MAJOR > (x) || DAV1D_API_VERSION_MAJOR == (x) && DAV1D_API_VERSION_MINOR >= (y))
|
||||
+
|
||||
typedef struct Libdav1dContext {
|
||||
AVClass *class;
|
||||
Dav1dContext *c;
|
||||
@@ -140,6 +143,15 @@ static av_cold int libdav1d_init(AVCodecContext *c)
|
||||
if (dav1d->operating_point >= 0)
|
||||
s.operating_point = dav1d->operating_point;
|
||||
|
||||
+#if FF_DAV1D_VERSION_AT_LEAST(6,0)
|
||||
+ if (dav1d->frame_threads || dav1d->tile_threads)
|
||||
+ s.n_threads = FFMAX(dav1d->frame_threads, dav1d->tile_threads);
|
||||
+ else
|
||||
+ s.n_threads = FFMIN(threads, DAV1D_MAX_THREADS);
|
||||
+ s.max_frame_delay = (c->flags & AV_CODEC_FLAG_LOW_DELAY) ? 1 : s.n_threads;
|
||||
+ av_log(c, AV_LOG_DEBUG, "Using %d threads, %d max_frame_delay\n",
|
||||
+ s.n_threads, s.max_frame_delay);
|
||||
+#else
|
||||
s.n_tile_threads = dav1d->tile_threads
|
||||
? dav1d->tile_threads
|
||||
: FFMIN(floor(sqrt(threads)), DAV1D_MAX_TILE_THREADS);
|
||||
@@ -148,6 +160,7 @@ static av_cold int libdav1d_init(AVCodecContext *c)
|
||||
: FFMIN(ceil(threads / s.n_tile_threads), DAV1D_MAX_FRAME_THREADS);
|
||||
av_log(c, AV_LOG_DEBUG, "Using %d frame threads, %d tile threads\n",
|
||||
s.n_frame_threads, s.n_tile_threads);
|
||||
+#endif
|
||||
|
||||
res = dav1d_open(&dav1d->c, &s);
|
||||
if (res < 0)
|
||||
@@ -384,11 +397,18 @@ static av_cold int libdav1d_close(AVCodecContext *c)
|
||||
return 0;
|
||||
}
|
||||
|
||||
+#ifndef DAV1D_MAX_FRAME_THREADS
|
||||
+#define DAV1D_MAX_FRAME_THREADS DAV1D_MAX_THREADS
|
||||
+#endif
|
||||
+#ifndef DAV1D_MAX_TILE_THREADS
|
||||
+#define DAV1D_MAX_TILE_THREADS DAV1D_MAX_THREADS
|
||||
+#endif
|
||||
+
|
||||
#define OFFSET(x) offsetof(Libdav1dContext, x)
|
||||
#define VD AV_OPT_FLAG_VIDEO_PARAM | AV_OPT_FLAG_DECODING_PARAM
|
||||
static const AVOption libdav1d_options[] = {
|
||||
- { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_TILE_THREADS, VD },
|
||||
- { "framethreads", "Frame threads", OFFSET(frame_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_FRAME_THREADS, VD },
|
||||
+ { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_TILE_THREADS, VD | AV_OPT_FLAG_DEPRECATED },
|
||||
+ { "framethreads", "Frame threads", OFFSET(frame_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_FRAME_THREADS, VD | AV_OPT_FLAG_DEPRECATED },
|
||||
{ "filmgrain", "Apply Film Grain", OFFSET(apply_grain), AV_OPT_TYPE_BOOL, { .i64 = -1 }, -1, 1, VD },
|
||||
{ "oppoint", "Select an operating point of the scalable bitstream", OFFSET(operating_point), AV_OPT_TYPE_INT, { .i64 = -1 }, -1, 31, VD },
|
||||
{ "alllayers", "Output all spatial layers", OFFSET(all_layers), AV_OPT_TYPE_BOOL, { .i64 = 0 }, 0, 1, VD },
|
||||
--
|
||||
2.36.0
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
# Maintainer: graysky <graysky AT archlinux DOT us>
|
||||
# Maintainer: graysky <therealgraysky AT proton DOT me>
|
||||
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
|
@ -13,7 +13,7 @@ pkgname=ffmpeg-shinobi
|
|||
_pkgname=ffmpeg
|
||||
_tag=e23098a712d532a393a0ae7ed6e22eb905ad06d2
|
||||
pkgver=4.3.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc='FFmpeg from the release/4.3 branch for use with Shinobi'
|
||||
arch=(x86_64 aarch64 armv6h armv7h)
|
||||
url=https://ffmpeg.org/
|
||||
|
@ -113,10 +113,12 @@ source=(
|
|||
git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
|
||||
vmaf-model-path.patch
|
||||
0001-configure-use-no-narrowing-for-cuda-llvm-compilation.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/52cc323735ced6e8095cfd3acea0e36e35c76eb2
|
||||
0002-add-build-fix-for-dav1d-1.0.0.patch
|
||||
)
|
||||
sha256sums=('SKIP'
|
||||
'8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d'
|
||||
'9a661c1e4f0cbad393fb76da1d9fde6dced3918c29bc39b22b996ec4f4c6cecd')
|
||||
'9a661c1e4f0cbad393fb76da1d9fde6dced3918c29bc39b22b996ec4f4c6cecd'
|
||||
'bcde6299a805430c3ca1f2807101edc7001e77b1934088db9057f74d9a9dd8f6')
|
||||
|
||||
pkgver() {
|
||||
cd ffmpeg
|
||||
|
@ -127,8 +129,9 @@ pkgver() {
|
|||
prepare() {
|
||||
cd ffmpeg
|
||||
|
||||
patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
|
||||
patch -Np1 -i "${srcdir}"/0001-configure-use-no-narrowing-for-cuda-llvm-compilation.patch
|
||||
patch -p1 -i ../vmaf-model-path.patch
|
||||
patch -p1 -i ../0001-configure-use-no-narrowing-for-cuda-llvm-compilation.patch
|
||||
patch -p1 -i ../0002-add-build-fix-for-dav1d-1.0.0.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue