mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed alarm/uboot-oxnas
This commit is contained in:
parent
198e2e3ba5
commit
9f3f89c116
4 changed files with 0 additions and 163 deletions
|
@ -1,43 +0,0 @@
|
|||
# U-Boot: PLX/Oxford Semiconductor NAS7820
|
||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
buildarch=2
|
||||
|
||||
pkgname=uboot-oxnas
|
||||
pkgver=2013.10
|
||||
pkgrel=2
|
||||
pkgdesc="U-Boot for PLX/Oxford Semiconductor NAS7820"
|
||||
arch=('arm')
|
||||
url="https://github.com/linux-sunxi/u-boot-sunxi/tree/sunxi-current"
|
||||
license=('GPL')
|
||||
_commit=a0140080d966a080fe0c7f5e3a5a84856e02a32e
|
||||
source=("https://github.com/kref/u-boot-oxnas/archive/${_commit}.tar.gz"
|
||||
'alarm.patch'
|
||||
'packager'
|
||||
'flash')
|
||||
md5sums=('27d8094d90aaffcbf7527f963f498504'
|
||||
'0633e9da16f0fd4957883b55e67900c8'
|
||||
'9c38473d3e0168eefe38f41413bd77d8'
|
||||
'fe2586f3eeb43b5b533e9e85175d13f9')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-oxnas-${_commit}
|
||||
patch -p1 -i "${srcdir}"/alarm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd u-boot-oxnas-${_commit}
|
||||
|
||||
unset CFLAGS CXXFLAGS LDFLAGS
|
||||
|
||||
make distclean
|
||||
make ox820_ext4_config
|
||||
make u-boot.{bin,img} spl/u-boot-spl.bin
|
||||
../packager u-boot.{bin,wrapped} || true
|
||||
}
|
||||
|
||||
package() {
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
cp u-boot-oxnas-${_commit}/{u-boot.{wrapped,img},spl/u-boot-spl.bin} "${pkgdir}"/boot
|
||||
cp flash "${pkgdir}"/boot
|
||||
}
|
|
@ -1,85 +0,0 @@
|
|||
diff -urN a/include/configs/ox820.h b/include/configs/ox820.h
|
||||
--- a/include/configs/ox820.h 2014-01-03 05:19:54.000000000 -0700
|
||||
+++ b/include/configs/ox820.h 2014-01-24 19:47:31.542099246 -0700
|
||||
@@ -28,7 +28,7 @@
|
||||
#define CONFIG_SYS_DCACHE_OFF
|
||||
|
||||
/* clock */
|
||||
-#define CONFIG_PLLA_FREQ_MHZ 800
|
||||
+#define CONFIG_PLLA_FREQ_MHZ 850
|
||||
#define CONFIG_RPSCLK 6250000
|
||||
#define CONFIG_SYS_HZ 1000
|
||||
#define CONFIG_SYS_CLK_FREQ CONFIG_RPSCLK
|
||||
@@ -63,7 +63,7 @@
|
||||
#define NAND_ALE_ADDR_PIN 18
|
||||
#define MTDPARTS_DEFAULT "mtdparts=41000000.nand:" \
|
||||
"14m(boot)," \
|
||||
- "-(data)"
|
||||
+ "-(data)"
|
||||
#define MTDIDS_DEFAULT "nand0=41000000.nand"
|
||||
|
||||
/* net */
|
||||
@@ -179,6 +179,8 @@
|
||||
/* boot */
|
||||
#define CONFIG_IDENT_STRING " for OXNAS"
|
||||
#define CONFIG_MACH_TYPE MACH_TYPE_OXNAS
|
||||
+#define CONFIG_OF_SEPARATE
|
||||
+#define CONFIG_DEFAULT_DEVICE_TREE "ox820-pogoplug-pro"
|
||||
#ifndef CONFIG_SPL_BUILD
|
||||
/* Enable devicetree support */
|
||||
#define CONFIG_OF_LIBFDT
|
||||
@@ -194,8 +196,9 @@
|
||||
/* memtest works on */
|
||||
#define CONFIG_SYS_LOAD_ADDR (CONFIG_SYS_SDRAM_BASE)
|
||||
#define CONFIG_SYS_AUTOLOAD "no"
|
||||
+#define CONFIG_CMD_BOOTZ
|
||||
|
||||
-#define CONFIG_BOOTARGS "console=ttyS0,115200n8 root=/dev/sda2 ubi.mtd=data,512"
|
||||
+#define CONFIG_BOOTARGS "console=ttyS0,115200n8 root=/dev/sda1 rw rootwait " MTDPARTS_DEFAULT
|
||||
#define CONFIG_BOOTCOMMAND "run ideboot"
|
||||
#define CONFIG_BOOT_RETRY_TIME -1
|
||||
#define CONFIG_RESET_TO_RETRY 60
|
||||
@@ -205,18 +208,26 @@
|
||||
#define CONFIG_IPADDR 192.168.0.100
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
- "updboot=" \
|
||||
- "bootp;" \
|
||||
- "tftp 60000000 u-boot.img;" \
|
||||
- "ide write 60000000 400 400\0" \
|
||||
- "console=" CONFIG_DEFAULT_CONSOLE \
|
||||
- "bootargs=" CONFIG_DEFAULT_CONSOLE \
|
||||
- "mtdids=" MTDIDS_DEFAULT "\0" \
|
||||
- "mtdparts=" MTDPARTS_DEFAULT "\0" \
|
||||
+ "console=" CONFIG_DEFAULT_CONSOLE \
|
||||
+ "bootargs=" CONFIG_BOOTARGS "\0" \
|
||||
+ "ideboot=" \
|
||||
+ "load ide 0:1 0x60500000 /boot/zImage;" \
|
||||
+ "load ide 0:1 0x67e26000 /boot/dtbs/ox820-pogoplug-pro.dtb;" \
|
||||
+ "bootz 0x60500000 - 0x67e26000" "\0" \
|
||||
+ "usbboot=" \
|
||||
+ "usb start;" \
|
||||
+ "load usb 0:1 0x60500000 /boot/zImage;" \
|
||||
+ "load usb 0:1 0x67e26000 /boot/dtbs/ox820-pogoplug-pro.dtb;" \
|
||||
+ "usb stop;" \
|
||||
+ "setenv bootargs " \
|
||||
+ "console=ttyS0,115200n8 " \
|
||||
+ "root=/dev/sdb1 rw rootwait " \
|
||||
+ MTDPARTS_DEFAULT ";" \
|
||||
+ "bootz 0x60500000 - 0x67e26000" "\0" \
|
||||
"safeboot=" \
|
||||
"setexpr.b keypressed '*44200005' '&' 1;" \
|
||||
"if test $keypressed = 0;" \
|
||||
- "then run netcon;" \
|
||||
+ "then run serialcon;" \
|
||||
"fi" "\0" \
|
||||
"serialcon=" \
|
||||
"echo switch to serial console;" \
|
||||
@@ -324,6 +335,7 @@
|
||||
#define CONFIG_FAT_WRITE
|
||||
#define CONFIG_CMD_EXT2
|
||||
#define CONFIG_CMD_EXT4
|
||||
+#define CONFIG_CMD_FS_GENERIC
|
||||
#ifndef CONFIG_SPL_BUILD
|
||||
#define CONFIG_CMD_EXT4_WRITE
|
||||
#endif
|
|
@ -1,35 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# uncomment line below and set to the correct disk
|
||||
#disk=/dev/sdX
|
||||
|
||||
if [ -z "${disk}" ] ; then
|
||||
echo "You must uncomment/set the 'disk' variable"
|
||||
exit -1
|
||||
fi
|
||||
|
||||
stage1File=/boot/u-boot-spl.bin
|
||||
ubootFile=/boot/u-boot.wrapped
|
||||
|
||||
perl <<EOF | dd of="$disk" bs=512
|
||||
print "\x00" x 0x1a4;
|
||||
print "\x00\x5f\x01\x00";
|
||||
print "\x00\xdf\x00\x00";
|
||||
print "\x00\x80\x00\x00";
|
||||
print "\x00" x (0x1b0 -0x1a4 -12 );
|
||||
print "\x22\x80\x00\x00";
|
||||
print "\x22\x00\x00\x00";
|
||||
print "\x00\x80\x00\x00";
|
||||
EOF
|
||||
|
||||
if [ -f $stage1File ];then
|
||||
echo "Writing stage 1"
|
||||
dd if=$stage1File of="$disk" bs=512 seek=34
|
||||
fi
|
||||
|
||||
if [ -f $ubootFile ];then
|
||||
echo "Writing uboot"
|
||||
dd if=$ubootFile of="$disk" bs=512 seek=154
|
||||
fi
|
||||
|
||||
sync
|
Binary file not shown.
Loading…
Reference in a new issue