mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-base to 5.7.0-6
This commit is contained in:
parent
5cb6d3f94e
commit
a03d7d601b
3 changed files with 22 additions and 3 deletions
|
@ -10,7 +10,7 @@
|
|||
pkgname=qt5-base
|
||||
_qtver=5.7.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=3
|
||||
pkgrel=6
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
|
@ -35,12 +35,14 @@ source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submo
|
|||
qtbug-53071.patch::"https://github.com/qtproject/qtbase/commit/e9041c7fc.patch"
|
||||
qtbug-53071b.patch::"https://github.com/qtproject/qtbase/commit/cd25866f.patch"
|
||||
qtbug-53237.patch::"https://github.com/qtproject/qtbase/commit/8e889378.patch"
|
||||
qtbug-49452.patch::"https://github.com/qt/qtbase/commit/6f423555.patch")
|
||||
qtbug-49452.patch::"https://github.com/qt/qtbase/commit/6f423555.patch"
|
||||
qtbase-memory-leak.patch::"https://github.com/qt/qtbase/commit/42283868.patch")
|
||||
md5sums=('184f9460b40752d71b15b827260580c2'
|
||||
'462f079cd46f869def6858903a718bf5'
|
||||
'da4fd787ea877516397a027412e975e1'
|
||||
'981255fb1aea0d3c0b5c5f306fe374da'
|
||||
'646aea77ca90031c453a65ef61db55f9')
|
||||
'646aea77ca90031c453a65ef61db55f9'
|
||||
'9842c327b091b360da7a4d90f5fdf4da')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -68,6 +70,9 @@ prepare() {
|
|||
|
||||
# Fix freetype engine performance
|
||||
patch -p1 -i ../qtbug-49452.patch
|
||||
|
||||
# Fix memory leak
|
||||
patch -p1 -i ../qtbase-memory-leak.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
13
extra/qt5-base/no-gtk-qpa-on-wayland.patch
Normal file
13
extra/qt5-base/no-gtk-qpa-on-wayland.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp b/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
||||
index db264d1..e3cb2f3 100644
|
||||
--- a/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
||||
+++ b/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
||||
@@ -814,7 +814,7 @@ QStringList QGenericUnixTheme::themeNames()
|
||||
#ifndef QT_NO_SETTINGS
|
||||
result.push_back(QLatin1String(QKdeTheme::name));
|
||||
#endif
|
||||
- } else if (gtkBasedEnvironments.contains(desktopName)) {
|
||||
+ } else if (gtkBasedEnvironments.contains(desktopName) && QString::fromLocal8Bit(qgetenv("XDG_SESSION_TYPE")) != QLatin1String("wayland")) {
|
||||
// prefer the GTK3 theme implementation with native dialogs etc.
|
||||
result.push_back(QStringLiteral("gtk3"));
|
||||
// fallback to the generic Gnome theme if loading the GTK3 theme fails
|
|
@ -4,3 +4,4 @@ gcin
|
|||
calibre
|
||||
akonadi
|
||||
skrooge
|
||||
qt5dxcb-plugin
|
||||
|
|
Loading…
Reference in a new issue