mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
13 lines
920 B
Diff
13 lines
920 B
Diff
diff --git a/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp b/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
|
index db264d1..e3cb2f3 100644
|
|
--- a/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
|
+++ b/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
|
@@ -814,7 +814,7 @@ QStringList QGenericUnixTheme::themeNames()
|
|
#ifndef QT_NO_SETTINGS
|
|
result.push_back(QLatin1String(QKdeTheme::name));
|
|
#endif
|
|
- } else if (gtkBasedEnvironments.contains(desktopName)) {
|
|
+ } else if (gtkBasedEnvironments.contains(desktopName) && QString::fromLocal8Bit(qgetenv("XDG_SESSION_TYPE")) != QLatin1String("wayland")) {
|
|
// prefer the GTK3 theme implementation with native dialogs etc.
|
|
result.push_back(QStringLiteral("gtk3"));
|
|
// fallback to the generic Gnome theme if loading the GTK3 theme fails
|