extra/texmacs to 1.99.10-1

This commit is contained in:
Kevin Mihelich 2019-06-30 15:18:47 +00:00
parent 8f5c175896
commit a181c230fa
2 changed files with 26 additions and 25 deletions

View file

@ -5,7 +5,7 @@
# - patch to fix size_t check on ARM
pkgname=texmacs
pkgver=1.99.9
pkgver=1.99.10
pkgrel=1
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor TeX-fonts and CAS-interface (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas) in one."
arch=('x86_64')
@ -22,15 +22,14 @@ makedepends=('ghostscript' 'cmake')
source=(http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-${pkgver}-src.tar.gz
fix-size_t-check.patch)
options=('!emptydirs')
sha256sums=('29f0cd141ac81a62fd6d1dd04a53b500083deeca97a5e150ebef62e493d32545'
'c7ea32216be57e8cf29109c89b47afd55b2c1e6c4bc31e377ca9d278cde18f09')
sha256sums=('025e5a2eed92b76fedd9430fb1e8aed968d4cf59031f09f048bb9e19d95c22cc'
'09de18741b6a3b8590e76be52c571b2799b906cc3ecdd0eb6594c2ffdef3ad83')
prepare() {
cd TeXmacs-${pkgver}-src
sed -i 's/env python/env python2/' \
plugins/{mathematica/bin/realpath.py,python/bin/tm_python,sage/bin/tm_sage} \
TeXmacs/misc/inkscape_extension/texmacs_reedit.py
find -name '*.py' | xargs sed -i 's/env python/env python2/'
sed -e 's/env python/env python2/' -i plugins/{gnuplot/bin/tm_gnuplot,python/bin/tm_python,graph/bin/tm_graph}
sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
patch -p1 -i ../fix-size_t-check.patch
@ -43,7 +42,6 @@ build() {
cd build
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGUILECONFIG_EXECUTABLE=/usr/bin/guile-config1.8
make

View file

@ -1,21 +1,24 @@
diff -urN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2017-12-21 13:27:33.000000000 -0700
+++ b/CMakeLists.txt 2018-03-18 16:15:51.243005972 -0600
@@ -279,14 +279,14 @@
CHECK_C_SOURCE_COMPILES( "#include <guile/gh.h>
#include <libguile.h>
void print_string (SCM s) {
- int len_r;
+ size_t len_r;
char* r= gh_scm2newstr (s, &len_r); } int main() { return 0; }
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 942b5adfd..f7e14ec08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -291,16 +291,16 @@ check_c_source_compiles ("
#include <guile/gh.h>
#include <libguile.h>
void print_string (SCM s) {
- int len_r;
+ size_t len_r;
char* r= gh_scm2newstr (s, &len_r);
}
int main() { return 0; }
" _guile_str_size_test)
IF(_guile_str_size_test)
- SET(guile_str_size_t int)
-ELSE(_guile_str_size_test)
SET(guile_str_size_t size_t)
+ELSE(_guile_str_size_test)
+ SET(guile_str_size_t int)
ENDIF(_guile_str_size_test)
if (_guile_str_size_test)
- set (guile_str_size_t int)
-else (_guile_str_size_test)
set (guile_str_size_t size_t)
+else (_guile_str_size_test)
+ set (guile_str_size_t int)
endif (_guile_str_size_test)
MESSAGE(STATUS "Checking whether ... arguments behave correctly")
message (STATUS "Checking whether ... arguments behave correctly")