extra/thunderbird to 45.7.1-2

This commit is contained in:
Kevin Mihelich 2017-02-22 03:19:46 +00:00
parent d9112913e1
commit a7a0de06e7
8 changed files with 1745 additions and 232 deletions

View file

@ -7,55 +7,40 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - mozconfig changes for ARM
# - patch to remove NEON/SIMD checks from configure
# - memory saving LDFLAGS
# - disable jemalloc on aarch64
# - disable ion on !aarch64
buildarch=28
buildarch=12
highmem=1
pkgname=thunderbird
pkgver=45.7.1
pkgrel=1
pkgrel=2
pkgdesc="Standalone mail and news reader from mozilla.org"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
arch=(i686 x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/thunderbird/"
depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
'dbus-glib' 'alsa-lib' 'libvpx' 'libevent' 'nss' 'hunspell'
'sqlite' 'ttf-font' 'icu')
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
'libpulse' 'inetutils')
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
libvpx libevent nss hunspell sqlite ttf-font icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils)
optdepends=('libcanberra: for sound support')
options=('!emptydirs' '!makeflags')
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
mozconfig
thunderbird.desktop
thunderbird-install-dir.patch
firefox-gcc-6.0.patch mozilla-1228540.patch mozilla-1228540-1.patch
vendor.js
no-neon.patch
mozilla-1253216.patch)
options=('!emptydirs' '!makeflags')
thunderbird-install-dir.patch fix-wifi-scanner.diff firefox-gtk3-20.patch
firefox-gcc-6.0.patch mozilla-1228540.patch mozilla-1228540-1.patch)
sha256sums=('5fc7a39c6a1baacfa37d6a52c9384f70c171dd0bb581576d370bdb29c84b9ffb'
'e6ab613a6d15668ac6856b591d07efa4a338671dad4ce09e9254662848462ee5'
'3fba13d88aeb003ab0811ef739463858172ce0662a1c7d62835df3d83ddbb8fb'
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
'2e355a477f1df792cd7f9d1e3a56030543e0cf2d09051dd293ba495a7edb54fd'
'4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf'
'3a3e84c702ee31450a3e84698441aceb11cf44e64c9fedcaddb8cb50db759417'
'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19'
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
'59f40d8b2480aa67bf76f4f119826b6828a6a59cc040caf1ab5a6e19eef44c6e'
'1e7ef08acd46aeacc8cd8b2c89012983fb2c8c18648e0f3e9371b0c76caedbde')
'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
# more information.
_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_google_default_client_id=413772536636.apps.googleusercontent.com
_google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
# Mozilla API keys (see https://location.services.mozilla.com/api)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@ -65,42 +50,73 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
cd $pkgname-$pkgver
mkdir path
ln -s /usr/bin/python2 path/python
cp ../mozconfig .mozconfig
cd $pkgname-$pkgver
patch -Np1 -i ../thunderbird-install-dir.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
# https://bugzilla.mozilla.org/show_bug.cgi?id=1234158
patch -d mozilla -Np1 < ../firefox-gtk3-20.patch
# Required for GCC 6
patch -d mozilla -Np1 < ../firefox-gcc-6.0.patch
patch -d mozilla -Np1 < ../mozilla-1228540.patch
patch -d mozilla -Np1 < ../mozilla-1228540-1.patch
patch -Np0 -i ../no-neon.patch
echo -n "$_google_api_key" >google-api-key
echo "ac_add_options --with-google-api-keyfile=\"$PWD/google-api-key\"" >>.mozconfig
echo -n "$_google_default_client_id $_google_default_client_secret" >google-oauth-api-key
echo "ac_add_options --with-google-oauth-api-keyfile=\"$PWD/google-oauth-api-key\"" >>.mozconfig
echo -n "$_mozilla_api_key" >mozilla-api-key
echo "ac_add_options --with-mozilla-api-keyfile=\"$PWD/mozilla-api-key\"" >>.mozconfig
mkdir "$srcdir/path"
ln -s /usr/bin/python2 "$srcdir/path/python"
cat >.mozconfig <<END
ac_add_options --enable-application=mail
if [[ $CARCH == "aarch64" ]]; then
echo "ac_add_options --disable-jemalloc" >> .mozconfig
echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
else
echo "ac_add_options --disable-ion" >> .mozconfig
fi
patch -p2 -d mozilla < ../mozilla-1253216.patch
ac_add_options --prefix=/usr
ac_add_options --enable-release
ac_add_options --enable-gold
ac_add_options --enable-pie
# Branding
ac_add_options --enable-official-branding
# Keys
ac_add_options --with-google-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
# System libraries
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
ac_add_options --enable-system-pixman
# Features
ac_add_options --enable-default-toolkit=cairo-gtk3
ac_add_options --enable-startup-notification
ac_add_options --disable-gstreamer
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
STRIP_FLAGS="--strip-debug"
ac_add_options --disable-elf-hack
ac_add_options --disable-ion
ac_add_options --disable-webrtc
END
}
build() {
cd $pkgname-$pkgver
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@ -108,12 +124,8 @@ build() {
LDFLAGS+=" -Wl,-z,now"
# GCC 6
CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
# Help with memory usage
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
export PATH="$srcdir/path:$PATH"
make -f client.mk build
@ -123,22 +135,40 @@ package() {
cd $pkgname-$pkgver
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
install -Dm644 ../vendor.js "$pkgdir/usr/lib/thunderbird/defaults/preferences/vendor.js"
_vendorjs="$pkgdir/usr/lib/thunderbird/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
pref("intl.locale.matchOS", true);
// Disable default mailer checking.
pref("mail.shell.checkDefaultMail", false);
// Don't disable our bundled extensions in the application directory
pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);
END
for i in 16 22 24 32 48 256; do
install -Dm644 other-licenses/branding/thunderbird/mailicon$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/thunderbird.png"
install -Dm644 other-licenses/branding/thunderbird/mailicon$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/thunderbird.png"
done
install -Dm644 ../thunderbird.desktop \
"$pkgdir/usr/share/applications/thunderbird.desktop"
"$pkgdir/usr/share/applications/thunderbird.desktop"
# Use system-provided dictionaries
rm -rf "$pkgdir"/usr/lib/thunderbird/{dictionaries,hyphenation}
ln -s /usr/share/hunspell "$pkgdir/usr/lib/thunderbird/dictionaries"
ln -s /usr/share/hyphen "$pkgdir/usr/lib/thunderbird/hyphenation"
rm -r "$pkgdir"/usr/lib/thunderbird/dictionaries
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/thunderbird/dictionaries"
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/thunderbird/hyphenation"
# Replace duplicate binary with symlink
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/thunderbird" <<END
#!/bin/sh
exec /usr/lib/thunderbird/thunderbird "\$@"
END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf thunderbird "$pkgdir/usr/lib/thunderbird/thunderbird-bin"
ln -srf "$pkgdir/usr/bin/thunderbird" \
"$pkgdir/usr/lib/thunderbird/thunderbird-bin"
}

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,16 @@
netwerk/wifi/nsWifiScannerDBus.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git c/netwerk/wifi/nsWifiScannerDBus.cpp i/netwerk/wifi/nsWifiScannerDBus.cpp
index 182553e18fa6e104..6fa0a0b023d3e45f 100644
--- c/netwerk/wifi/nsWifiScannerDBus.cpp
+++ i/netwerk/wifi/nsWifiScannerDBus.cpp
@@ -62,7 +62,7 @@ nsWifiScannerDBus::SendMessage(const char* aInterface,
return NS_ERROR_FAILURE;
}
} else if (!strcmp(aFuncCall, "GetAll")) {
- const char* param = "";
+ const char* param = "org.freedesktop.NetworkManager.AccessPoint";
if (!dbus_message_iter_append_basic(&argsIter, DBUS_TYPE_STRING, &param)) {
return NS_ERROR_FAILURE;
}

View file

@ -1,42 +0,0 @@
ac_add_options --enable-application=mail
ac_add_options --prefix=/usr
ac_add_options --libdir=/usr/lib
ac_add_options --enable-release
ac_add_options --enable-pie
ac_add_options --enable-official-branding
# ALARM
ac_add_options --disable-elf-hack
ac_add_options --disable-neon
ac_add_options --disable-webrtc
ac_add_options --disable-debug
ac_add_options --disable-debug-symbols
# System libraries
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
ac_add_options --enable-system-pixman
# Features
ac_add_options --enable-calendar
ac_add_options --enable-startup-notification
ac_add_options --disable-gstreamer
ac_add_options --disable-updater
ac_add_options --disable-installer
ac_add_options --disable-crashreporter
STRIP_FLAGS="--strip-debug"
# vim:set ft=sh:

View file

@ -1,12 +0,0 @@
diff -up firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h.old firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h
--- firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h.old 2016-03-01 09:45:01.000000000 +0100
+++ firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h 2016-03-03 13:13:34.915015391 +0100
@@ -305,7 +305,7 @@ AtomicOperations::isLockfree(int32_t siz
|| defined(__ppc__) || defined(__PPC__)
# include "jit/none/AtomicOperations-ppc.h"
#elif defined(JS_CODEGEN_NONE)
-# include "jit/none/AtomicOperations-none.h"
+# include "jit/none/AtomicOperations-ppc.h"
#elif defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)
# include "jit/x86-shared/AtomicOperations-x86-shared.h"
#else

View file

@ -1,96 +0,0 @@
--- mozilla/configure.orig 2016-04-19 12:42:57.280811615 -0600
+++ mozilla/configure 2016-04-19 12:44:20.697690476 -0600
@@ -7389,14 +7389,7 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_SIMD 1
-EOF
-
- HAVE_ARM_SIMD=1
+ HAVE_ARM_SIMD=
fi
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
@@ -7428,27 +7421,13 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_NEON 1
-EOF
-
- HAVE_ARM_NEON=1
+ HAVE_ARM_NEON=
if test -n "$ARM_ARCH"; then
if test "$ARM_ARCH" -lt 7; then
BUILD_ARM_NEON=
else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
+ BUILD_ARM_NEON=
fi
fi
fi
--- mozilla/js/src/configure.orig 2016-04-07 15:33:39.000000000 -0600
+++ mozilla/js/src/configure 2016-04-19 12:44:20.697690476 -0600
@@ -6578,14 +6578,7 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_SIMD 1
-EOF
-
- HAVE_ARM_SIMD=1
+ HAVE_ARM_SIMD=
fi
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
@@ -6617,27 +6610,13 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_NEON 1
-EOF
-
- HAVE_ARM_NEON=1
+ HAVE_ARM_NEON=
if test -n "$ARM_ARCH"; then
if test "$ARM_ARCH" -lt 7; then
BUILD_ARM_NEON=
else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
+ BUILD_ARM_NEON=
fi
fi
fi

View file

@ -1,12 +0,0 @@
post_install() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -1,9 +0,0 @@
// Use LANG environment variable to choose locale
pref("intl.locale.matchOS", true);
// Disable default mailer checking.
pref("mail.shell.checkDefaultMail", false);
// Don't disable our bundled extensions in the application directory
pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);